Duet 2 Wifi + BL-Touch doens´t work, no Trigger-Signal



  • @justd said in Duet 2 Wifi + BL-Touch doens´t work, no Trigger-Signal:

    WiFi Server Version: 1.21
    Web Interface Version: 1.21.2-dc42

    Your main firmware is up to date, but your wifi and web interface are still out of date. upload the 2.02 zip file to the DWC, and it will update everything as needed.

    In this M558 P9 H7 F120 T9000 X0 Y0 Z1, is here the H7 correct.. (bevore it was H5)?

    The H value is the dive height. It can be whatever you need it to be. 5mm is usually fine. It's the height that it raises the print head before starting to probe.

    In the WEB Interface, I can´t see no z-Probe 1000.. allways 0

    The way the BLTouch works, you won't likely be able to see the web interface change. Since as soon as the pin retracts, it triggers, but then resets. So you may not catch it flash to 1000 on the interface before it goes back to 0. That's normal.

    The Z-Axis doesn´t stop if the probe is triggered

    This would mean that the white wire isn't getting the signal to the Duet. Replace the crimp connection if you can and verify the wire continuity with a multimeter.



  • Thank you for the hint. Now

    Softwareinformationen
    Firmwarename: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Elektronik: Duet WiFi 1.02 or later
    Firmware Version: 2.02(RTOS) (2018-12-24b1)
    WiFi Server Version: 1.21
    Web Interface Version: 1.22.6

    Thats all the newest FW what I could find at the original WEB-Site.

    I have a osciloscope.. but at my last movement I couln´d find my probe..
    I bought a new one .. for future.

    To reduce the possibilities, I connect the BL-Touch directly to the board.. without the long cable from the X-Wagon.

    Aaah.. do I need the 240Ohm resistor I´v read many times or not?

    Another Idea, how can I check if the BLTouch is not damaged?
    Selftest is ok, deploy and retract is working.



  • I´v check with an digital multimeter the correct signal flow from the BLTouch circuit up to the connector.. it´s OK
    But this digital multimeter is to slow for a short signal.

    uups. after WEB-Server updating.. the WiFi doesn´t work.. grr..



  • Now it is
    WiFi firmware version 1.22

    WiFi is running..
    Softwareinformationen
    Firmwarename: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Elektronik: Duet WiFi 1.02 or later
    Firmware Version: 2.02(RTOS) (2018-12-24b1)
    WiFi Server Version: 1.22
    Web Interface Version: 1.22.6

    What I see.. is, if I pull off the z-Probe connector, then I see at the web-interface the Z-Probe=1000.
    If I connect back.. there is still 0..

    Also after updating the SW.. no changes with the bltouch stuff.. same es before.

    To check, if the BTouch is OK.. I ordered a new one.. with the ne plastic-Pin.. should be better than so version with the aluminium-Pin. But this arrive in 2 weeks hopfully.

    Any other hints for me?
    I have no Idea whats wrong.



  • I can't think of anything other than the probe not working.

    Perhaps you can find something here:
    https://duet3d.dozuki.com/Wiki/BLTouch_Troubleshooting



  • the clones break easily.
    happend to me as well. would not trigger no matter what.
    i build a bfptouch in the end.
    https://www.thingiverse.com/thing:2890290



  • @Phaedrux Thank you for the link.. helpfull

    @Veti yes it seems so as me.
    Your bfptouch looks interesting, if you have no functional printer.. no possible to print one.

    I ordered an origin BLTouch... and maybe next weeks I see more.
    I hope the V 3.0 is much more stable.



  • I go forward.. temporary I switch to a Z-Switch, to adjust E01 for correct extruding.. done
    I calibrate the X,Y,Z-Axis movement.. Works.... done
    So my test Cube is 20x20x20.. but the heatbed seems to hot.. I couln´d remove the Object from the headbed... smile
    It is as it is placed with superglue.. .. Filament is ABS-neXt from Eins3D.. Wow..

    Sorry for my bad english, I´m not a nativ speaker and my last lesson is much years ago.



  • Try heating the bed up again to soften the plastic and see if it can be pulled off. I find it helpful to use something like glue stick to act as a release agent.



  • Now also the E1 is running..
    WOW I´d never thought before, that so much differences between diverses PFT-supply pipes exist. WOW
    In my case.. is 30% smaler inner diamenter.. and so .. at a bowden 3D Printer it´s much more power and pressure neccssary.
    Too much for the filament.
    I changed these supply pipes.. and all works fine..

    I learn every day with this printer.



  • Glue stick as release agent??..
    I´v read often, with glue stick some object have a better grip.. instead of better release.

    I try it at first with a much lower bed temperature. but for today.. it´s a long day for me.. it´s finish.
    I could remove the Object.. for today.. it´s damaged.. but for the first test..ok

    Good result.. first probe is print.. and nearly works good.. the side surface are the best what I print ever.. I´m happy with this..
    for the next day´s I wil spend my eye about the top cover.. that not so good..
    But this is for my opinion a point of temperatur and speed.

    At the Moment I print this with very slow speed and 245°c



  • Yes the glue stick also helps it stick, but it keeps the plastic from bonding directly to the print surface.


  • administrators

    If the bed is removable from the printer, try putting the bed+print in the fridge or freezer to help remove the print from the bed.



  • Oh, it´s this surface.. and I´m happy with this..

    I playing around with diffrent surfaces at my first printer.. Aluminium+ liquid glue, or (i Don´t know the Word in english) Pertinax like elektronik boards... nothing was really good .
    Also good conditions are Glass-Surface and it´s really good to remove the objects. But in 350x350x4mm, with 6 little holes.. gmm.. not easy to buy this .. and much expensive.



  • @justd Try 3DLac if you can get it in your part of the world. https://www.3dlac.com/



  • Hi, yesterday arrive the new BLTouch V3.0.. and .. works super fine...
    But this one, have other dimensions (Length) as the old one.

    Whats the best Way to calibrate the BLTouch mechanic?



  • OK.. is done.. hightmap is saved..





  • Now it´s working.. .. Now I tune some S3D parameters for different filaments.

    Does anyone know the scripts for toolchange at printing time?
    For print with 2 different Materials or different colors at one Object. I know, should be two objects in one printingfile a combined object.
    What I´m searching for is, the scripts for Simplify 3 D.
    Ok, it´s a little offtopic here


  • administrators

    You can do the tool changing either in the Duet's own tool change files (see https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter#Section_Tool_change_files) or in S3D. if you put the commands ni the Duet tool change files, then all S3D needs to generate is a T command to change tool.


Log in to reply