Duet 2 Maestro Error: Short-to-ground on drivers 1



  • I am getting asn error on my Duet 2 Maestro Error: Short-to-ground on drivers 1. This seems to be the extruder motor as all the rest xyz work and home fine. The board is connected to a ender3, but I don.t think that matters. Below is a copy of Diagnostics. Any help appriciated for a newby.

    M122
    SENDING:M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 Maestro version 2.02(RTOS) running on Duet Maestro 1.0
    Board ID: XXXXXXXXXX
    Used output buffers: 1 of 20 (11 max)
    === RTOS ===
    Static ram: 19476
    Dynamic ram: 92904 of which 0 recycled
    Exception stack ram used: 216
    Never used ram: 18476
    Tasks: NETWORK(ready,1600) HEAT(blocked,1300) MAIN(running,3932) IDLE(ready,204)
    Owned mutexes:
    === Platform ===
    Last reset 00:01:45 ago, cause: power up
    Last software reset at 2019-03-24 14:15, reason: User, spinning module GCodes, available RAM 18408 bytes (slot 2)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x04418000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    [ERROR] Error status: 0

    Free file entries: 10
    SD card 0 detected, interface speed: 15.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 27.3, current 28.1, max 28.2
    Supply voltage: min 0.3, current 0.3, max 0.3, under voltage events: 0, over voltage events: 0, power good: no
    Driver 0: ok, read errors 0, write errors 0, ifcount 0, reads 0, timeouts 0
    Driver 1: ok, read errors 0, write errors 0, ifcount 0, reads 0, timeouts 0
    Driver 2: ok, read errors 0, write errors 0, ifcount 0, reads 0, timeouts 0
    Driver 3: ok, read errors 0, write errors 0, ifcount 0, reads 0, timeouts 0
    Driver 4: ok, read errors 0, write errors 0, ifcount 0, reads 0, timeouts 0
    Driver 5: ok, read errors 0, write errors 0, ifcount 0, reads 0, timeouts 0
    Driver 6: ok, read errors 0, write errors 0, ifcount 0, reads 0, timeouts 0
    Date/time: 1970-01-01 00:00:00
    Slowest loop: 0.30ms; fastest: 0.06ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm: 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0, chamberHeaters = -1 -1
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is ready with "M122" in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    lcd is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 0.28ms; fastest: 0.02ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 0 of 8
    Interface state 5, link 100Mbps full duplex



  • check the wire with a multimeter if all wires are actually crimped properly

    also try adding this line to your config.
    M569 P3 D2 ; Extruder in Spreadcyle



  • All wires are crimped correctly. Thanks for the fast reply


  • administrators

    Unless you have remapped axes using M584, driver 1 is the Y axis driver. Is the Y axis moving normally? Is the error message triggered by particular movements, for example rapid Y axis movement?

    Please send command M569 P1 and report the response.



  • Thanks for the reply. At work at the moment so I will check it later.



  • @dc42 said in Duet 2 Maestro Error: Short-to-ground on drivers 1:

    M569 P1

    Gcode reports the following.

    Connecting...
    Printer is now online.

    M569 P1
    SENDING:M569 P1
    Drive 1 runs in reverse, active low enable, step timing fast, mode stealthChop, ccr 0x00053, toff 3, tblank 0, hstart/hend/hdec 5/0/0, tpwmthrs 2000 (4.7 mm/sec)

    What have I done wrong again 😞



  • @dc42

    Y seems normal. Yonnected to y x to x z to z and e to e0 is that correct or am I lossing it.





  • Thanks, getting a new error code now which reads. Error: short-to-ground reported by driver(s) 3.
    and the extruder stepper motor dances about like a bee at a hive. Any ideas. I have tried two stepper motors one brand new with the same result.


  • administrators

    @dumbo said in Duet 2 Maestro Error: Short-to-ground on drivers 1:

    Thanks, getting a new error code now which reads. Error: short-to-ground reported by driver(s) 3.
    and the extruder stepper motor dances about like a bee at a hive. Any ideas. I have tried two stepper motors one brand new with the same result.

    Four likely possibilities:

    1. Stepper motor phase wires have been mixed up. This happens easily if the stepper motors have connectors on them and you bought the cables from a different supplier (or even from the same supplier in some cases).

    2. Faulty stepper driver chip. If this is the problem, the fault is likely persist even with no stepper motor connected to that output.

    3. An actual short between the stepper motor wires, or to ground.

    4. Using stealthChop at too high a speed. This could give the short-to-ground error at high speeds.



  • Thanks for the reply. If it is a ground problem how would I fix it? Also were are the settings for stealthChop located. Cable seems OK so that's may be out of the equation. Also how do I change the stepper for the Extruder to the spare one. Simple questions but not being familiar with the configuration of the Duet it is a bit of a learning curve as I am sure you will agree. Thanks for the help.



  • @dumbo said in Duet 2 Maestro Error: Short-to-ground on drivers 1:

    Also were are the settings for stealthChop located.

    see the first reply.

    for drive mapping see
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M584_Set_drive_mapping


  • administrators

    The settings for stealthChop are in M569. Your M569 response indicates that it will switch to spreadCycle at 4.7mm/sec, which is reasonable. So I don't think your stealthChop settings are to blame.

    The simplest way to change to the second extruder is to locate the M563 command in config.g, and in that command change D0 to D1.



  • If it is indeed a grounding issue as you mentioned how would that be resolved



  • @dc42 said in Duet 2 Maestro Error: Short-to-ground on drivers 1:

    M563

    Using D1 extruder works fine. So how do I cure the D0 connector error please.



  • if another driver works then this sounds like a warranty case.


  • administrators

    I agree. @Veti, I suggest you submit a warranty claim.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.