Extruder stepper not turning

  • This is a new setup. Everything seemed to be working quite well. I had just completed an 11 hour print and a 5 hour print. Tried to retract the filament to unload and the stepper buzzes, clicks but will not turn. I assumed the cables had gone bad based on how it was acting so I took a separate stepper motor with a brand new cable and attached it to the correct connection on the DuetWifi, turned on the heat and tried to extrude or retract and again the stepper will not turn. It buzzes and clicks but will not turn.
    Blown driver? Can I upload a vid?

  • Andy - is your hotend warm when trying to retract? It sounds like the stepper is stalled - and if your filaments cooled down and stuck to the sides of your heatbreak and nozzle or simply over-retracted and jammed it's a good possibility.

    I'd go back to the original cable - and remove the filament manually before troubleshooting further just to rule out a stall due to a jam or low current on the stepper

  • administrators

    Yes it could be a failed driver. If the E1 motor output is free, please try using that one, to diagnose whether the driver is the problem.

  • @doccox Yes of course I heated up the extruder that 1st time. The "Extrude" button is disabled prior to heating up anyways.

  • @dc42 Yes, I saw this in another similar thread. I was about to try this then I tried swapping the X axis stepper into the E0 connector. and the stepper (the X axis) worked for 1 try. Then started again. I also am now seeing weirds stuff happening in the X and Y steppers. They are acting like they're getting completely incorrect voltages and are reversed.
    Is it possible that the config is somehow corrupted?

  • Seems OK to me...
    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X88.57 Y88.57 Z400.00 E96.28 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z400.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; Set accelerations (mm/s^2)
    M906 X800.00 Y800.00 Z800.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

  • administrators

    @andy-cohen, I suggest you run M122 after seeing these issues, and check the report for under voltage events.

  • @dc42 Seems it continues to deteriorate. Now when I try to move the Y axis the carriage moves in X even though the Y cables are in the Y connector.

    Seems to me this board is defective. I'll contact the reseller Monday AM.

    Doesn't Duet3D do burn ins??? If they did this would have showed up.

  • @andy-cohen

    Check the SD card. If the contents are not being read correctly from the SD card, your configuration will not be used. Your printer is a corexy, correct? That could explain why X/Y motors are getting activated at the incorrect times. A default cartesian config would not work well for your machine.

    I've heard sometimes that the cheap SD cards that ship with the duets can fail. Try a different SD card, or verify first that it is being read at all. What's the name of the printer on the paneldue/DWC? If the config is not being read, the name will be "My Duet" or something like that.

  • @bot I pulled the sd card and looked at it on my Mac. Looks fine; reads and writes fine. Although your guess was a good one. It would explain quite a bit. When the X stepper does move it's a LOT harsher as though it's getting way too much power.

    Examined the board carefully and there's zero marks anywhere from arcing or scorching. No smell at all. So no bridging or shorting. You would think that a fail within like this would brick it.

    Is there some way of doing a hard reset?

  • @andy-cohen

    Even though you can read the SD card on your mac or pc, there have been reported times where the SD card is still not readable by the Duet. Usually, IIRC, this was solved by using a different SD card. Sometimes it was fixed by formatting the sd card as fat 32 and starting over, and other times, more rarely, the sd card socket itself became faulty.

    Can you inser the SD card into the duet and verify via the web control or PanelDue if the SD config is being loaded properly? The easiest way is to check the machine name.

  • Moderator

    Can you post some more details?

    What firmware version? Board version?
    Entire config.g?
    Results of M122?

  • @bot It's using the correct name I gave it in the config file. Whats interesting is now I am getting the dialog you see in the attached.0_1555297894831_IMG_5676.jpg

Log in to reply