Large Scale printer - Test of stepper motor

  • Hi

    I am currently designing a large scale printer for which i'm using external drivers and the Duet 2 Wifi Board + Breakout Board. Currently i am testing to see how the board works and how the stepper drivers work, but i cannot get the motor to run. Every time i send a G0 command it returns with "G0/G1: Insufficient axes homed. The command M564 H0 S0 which should solve the problem does nothing.
    I there something i'm missing, or is it simply impossible to test the stepper motor without having the rest of the printer hooked up?


    Best regards

  • try relative moves with G91

  • For homing routines you need to add S2 in any G0 / G1 commands that moves an axis before it is homed.

    For testing move the head/platform to some where where it can move in all directions then tell the machine it is at a specific location such as (10,10,10) with G92:

    G92 X10 Y10 Z10

    This will let you move the axis (go small distances and slow to start) before you are ready to launch into setting up and testing homing routines.

  • You could quite easily bench test the electronics with the limit switches and probes loose if you wished. Get direction sorted then write a rough homing routine and prod the switches at appropriate times to give you some confidence in the macros. To be fair though it's not that bad on the machine if you take it easy.

  • Hi Everyone

    Thank you for the answers. This is the setup i am using at the moment. The printer is designed but not build at the moment.


    Using the G0 Xnnn S2 code, the warning disappears as it should, but the stepper motor is not moving still. I have the driver hooked up the the breakout board on port E2, number 5. I then use the M584 X5 to set the x-direction to this port.
    With this and the S2 addition to G0 i would expect the motor to start turning.

  • administrators

    To test stepper motor individually, send G91 to select relative mode, then use G1 S2 moves.

  • I'm not expecting to be any help but others will need to see the motors section of your config file including acceleration, instantaneous speed, direction, max speed, steps per mm and the feed rate that you have been trying to use.

  • This might be a really stupid question. I have the board hooked up to my laptop now, and the stepper driver directly to the wall, but does the board need more power than what my laptop can provide to send the signal?

  • @eplov : you need to supply VIN voltage to drive the onboard stepper motor drivers, not sure about external drivers though...

  • @whosrdaddy Yeah that makes sense in my head too. If i need to run stepper motors of the build in drivers then i would need extra voltage, but given that the stepper driver is hooked directly up to the wall, and the board only has to output a digital signal i do not know if i needs more voltage.

  • administrators

    It sounds that you are using an external stepper driver. How have you connected it to the Duet?

  • @dc42 I am using a FuyuMotion FMDT220A48NOM Stepper driver and a Nema 34 stepper motor.
    I have connected the S+ to 5PU+, S- to 5PU-, D+ to 5DR+ and D- to DR-.

    You can see the circuit diagram for their motion controller and the stepper controller below.

    0_1556007232021_Circuit diagram.png

  • administrators

    Please post your config,g file. I suspect that either you haven't mapped XYZ to your external drivers using M584, or you haven't extended the step pulse timing using M569.

    It sounds to me that your drivers have a motor disable input instewade of a motor enable input. In which case, you can connect them to the EN+/EN- outputs on the breakout board, but you need to invert the enable polarity in the M569 commands.

  • @dc42 I am currently only using M584 to set the X axis to port 5 to 9 to test all ports on the breakout board. I have currently not attached the Enable pins, given the same thought as you mentioned.

  • @dc42 Everything is working now. It was the enable signal. Thank you very much for your help.

Log in to reply