motor phase A may be disconnected reported by driver(s) 1

  • I have just bought a new Duet 2 Wifi v1.04 and when setting up my new coreXY machine I could not get the Y motor to move normaly.
    It jitters forwards and backwards. So i mounted that motor on the X driver (with the same cable) and it worked. tried an identical motor on the Y driver and it jittered.

    When i give a G1 S2 Y50 command i get the message Warning: motor phase A may be disconnected reported by driver(s) 1.
    It does not give it with short motor movements like 10mm.

    Im guessing the driver is broken on the board could this be correct? could I troubble shoot to make shure this is the issue.

    Info for trouble shooting

    Motor specs:
    Nema 17 | 1,8 degree/step | 1.7A max

    Firmware setup

    G code troubleshooting
    M906: Motor current (mA) - X:1500, Y:1500, Z:1700, E:600:600, idle factor 0%
    (tried this with 1A per driver issue persisted)
    M913: Motor current % of normal - X:100, Y:100, Z:100, E:100 :100
    M122: 0_1555357728217_M122.txt

  • check your stepper motor wiring with a multimeter first. sometimes the crimp work is bad.

    if the wire is good try swapping the e1 and y drivers using
    M584 X0 Y4 Z2 E3:1 (do double check this. this was of the top of my head)

  • @veti
    Dude you just saved my duet.
    Checked the wires and indeed 2 wires had a bad crimp.
    Crimped them again and now it works!.

    Thank you, stupid me forgot to swap out the wire from the driver to my connector on the back of my electronics box.

  • @Veti I just tried this but now I can't control my Y axis. Would you be so kind as to tell me what g-code I can send to undo this? Thank you!