Perplexing E-steps and Flow calibration problem



  • Ever since I upgraded my Ender 3 with a DuetWifi I have been having extrusion problems.
    I recently bought a genuine Titan Aero to try to remedy the problems, as well as for the ability to print flexible materials more easily.
    After I installed the TA I calibrated my E-steps and ended up with 407.5 (1.8 step angle, 7.3 hob diameter, 3:1 gear ratio). After this I did a flow test by printing a single-layer cube and measuring its sides. I measured an average .44 mm when It should've been .4 wall size. When I adjusted my flow to 90.9% to match the results from this test I got major under-extrusion ( huge gaps between lines of filament). I had to raise my flow to 105% to get good extrusion.
    I measured my filament's diameter over a few meters and saw an average of 1.74 mm, and getting as low as 1.73 mm.

    The other issue I'm seeing is that when I print a XYZ test cube with the value for flow that gives me good results (105%), I will get significant over extrusion on the first 6 layers (I use 6 top and 6 bottom layers). These bottom layers bulge out about a mm farther than the rest of the cube. The rest of the cube looks great. I have to resort to adding a post-processing script to bring the flow of these 6 lower layers to about 85% flow to get a decent looking cube. I am really puzzled by this issue and want to know if anyone has encountered anything similar or knows what could be the problem.
    Thank you in advance for any help

    Additional info: using Cura 4.0, Hatchbox PLA, .4 mm Nozzle size, .2 layer height, 60 mm/s print speed.



  • @ezln137 said in Perplexing E-steps and Flow calibration problem:

    I measured my filament's diameter over a few meters and saw an average of 1.74 mm

    Not sure what's going on but just wanted to be sure you know that when you measure the filament (good on you!) be sure you measure around the filament at each point you check.

    I just measured one this AM that was 1.75 at one point, but went down to 1.69 when measured clockwise 60° at the same point!!

    Same point on the length, but be sure to measure a few places around the diameter too.



  • Great suggestion. I measured all around the filament and I did see some variation, but not as big as what you mentioned. With the different measurements the average gets closer to 1.75 mm.
    Thanks for the reply, I'm gonna keep experimenting with settings to see if I get better results.



  • Is the first layer going down smoothly? The over extrusion at the base but under extrusion father up would indicate that the first layer height may be off.

    My preferred way to calibrate the e steps and flow rate can be found here: https://forum.duet3d.com/topic/9999/horrible-print-results-help-needed/14



  • I had similar issues (and I’ve seen others here) and it was the thermistor settings.
    I don’t know if the online configuration was set wrong or it was “operator error” in each case but it had me chasing my tail.
    Perhaps if you post details of your config and thermistor type someone can rule this out.



  • @phaedrux said in Perplexing E-steps and Flow calibration problem:

    Is the first layer going down smoothly? The over extrusion at the base but under extrusion father up would indicate that the first layer height may be off.

    My preferred way to calibrate the e steps and flow rate can be found here: https://forum.duet3d.com/topic/9999/horrible-print-results-help-needed/14

    Yes, the first layer looks good. That's pretty much the procedure I follow for calibrating e-steps and flow.

    Here is my config file. I am using the stock Ender 3 thermistor ( 100K ohm NTC 3950FB) for the bed and stock Titan Aero thermistor (Semitec 104-GT2 thermistors) for hotend.

    Here's my config:
    0_1555904131877_config.g



  • This post is deleted!


  • Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E407.5 ; Set steps per mm
    M566 X1000.00 Y1200.00 Z24.00 E300.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X30000.00 Y30000.00 Z300.00 E900.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z100.00 E4000.00 ; Set accelerations (mm/s^2)
    M906 X1200.00 Y800.00 Z800.00 E925.00 I20 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X235 Y235 Z250 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S1 ; Set active high endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X15:8 Y15:195 S20 ; Define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4066 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S100 ; Set temperature limit for heater 0 to 100C
    M305 P1 B4725 C7.060000e-8 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S285 ; Set temperature limit for heater 1 to 285C

    ; Fans
    M106 P0 S1 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    M307 H1 A254.3 C127.8 D2.2 S1.0 V24.3 ; PID configuration
    ; Custom settings
    ; M592 D0 A0.0121 B-0.0005



  • Looks alright to me. Not sure how to explain your over extruded early layers and under extruded later layers.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.