Disabling fan burst at startup



  • Hi guys, I think I saw this setting somewhere, but can not find it anywhere today. Searched the heck out of google already. Basically I am looking to disable full speed fan burst at duet startup. I can not locate the gcode in config file that is actually causing it, therefore I can not disable. Any thoughts?



  • It's the B parameter of M106 to blip the fan at full power.

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M106_Fan_On



  • @phaedrux I was on that page, can't believe I missed that! Thanks! It's not set, but I am gonna try B0 now!



  • @phaedrux Ok, better now, no more burst! BUT - it still starts the fan under this line, actually twice for some reason:

    M106 P1 B0 S0.4 I0 F100 H1 T160

    Now instead of full burst it does 0.4 and twice... Any ideas of how to keep it from starting at all? I am a bit lost on this one.



  • S0 should have it start at off. S0.4 would start it at 40%. If it's fan port 1, it's defaulted to be the hotend fan which will blip automatically at startup incase the heaters were on during a power cycle


  • administrators

    The Fan 1 hardware port is designed to turn the fan on by default, until firmware turns it off. It's a safety feature, for the benefit of users (like me!) who sometimes flash firmware while the hot end is hot, to avoid getting a filament jam if the fan doesn't start up promptly or the SD card is missing. So there isn't any way in firmware of getting the fan not to turn on briefly at power up or reset. But if the hot end is cold, it should only turn on for one brief burst.



  • @dc42 said in Disabling fan burst at startup:

    The Fan 1 hardware port is designed to turn the fan on by default, until firmware turns it off. It's a safety feature, for the benefit of users (like me!) who sometimes flash firmware while the hot end is hot, to avoid getting a filament jam if the fan doesn't start up promptly or the SD card is missing. So there isn't any way in firmware of getting the fan not to turn on briefly at power up or reset. But if the hot end is cold, it should only turn on for one brief burst.

    You can get around this by mapping another fan port to the hotend fan and have nothing connected to fan1 .



  • Thanks guys. My hotend doesn't have any heat creep like that, so it was not logical to me, but now it is clear! I'll just leave it as it is now.


Log in to reply