Heater VIN for Part Fan or how to assign Fan 2 to Tool 0



  • Hi guys,

    I am new to the Duet Wifi and try to run a CoreXY with it. The printer is already running but I have some issues and need some help. The first thing is the part fan.

    In order to reduce the wires to the hotend, I connected the part fan to VIN of the heating cartridge. Then I connected the - wire of the fan to FAN0-. But it does not work when I set FAN 0 to 100% in the web interface. V_FAN is set to VIN by jumper. I assume VIN is not equal to VFAN though? Is there a schematic available?
    But when I connect the fan to FAN2- it works and I can set Fan 2 in the web interface.
    Sending M106 P2 S255 works as well.
    But my slicer only generates M106 S255. I can`t make it export the "P2".
    So I tried to assign fan 2 to tool 0 by sending: M563 P0 F2 or M563 P0 F0:2
    No Success.

    Hope I could make my problem clear and that someone can explain either:
    Why works only Fan 2 while I connect Fan+ to VIN of the heater?
    or
    How to make Fan 2 react on M106 S255?



  • please post your entire config



  • @jorge What is the voltage of your power supply, and what is the voltage of the fan you are trying to use? Also, have you seen this https://duet3d.dozuki.com/Wiki/Connecting_and_configuring_fans?



  • Here is my config:
    0_1555923956089_config.g

    My power supply has 24V and the fan as well.
    I have read the article. Thats where I found the M563 command. But I must misunderstand something.



  • for the fans to be controlled by m106 you have to turn off Thermostatic control.
    you also dont have a config for fan 2.
    see the configurator. https://configurator.reprapfirmware.org/Start

    also max speed of 90000 is a bit high.



  • @jorge

    To get a fan to work as a part cooling fan, and as @Veti said, you need to turn off thermostactic mode by using H-1.

    So for fan 0, you need to use something like M106 P0 S0 I0 H-1 and likewise if you want to use fan 2, then M106 P2 S0 I0 H-1. The simplest thing would be to use fan 0, then you don't need to map a different fan to a tool.


  • administrators

    @Jorge, for schematics see https://github.com/T3P3/Duet.

    Fan 1 on the Duet WiFi/Ethernet is set up as a thermostatic hot end fan by default, so to use it as a part cooling fan you need to disable thermostatic mode as @deckingman says. Fans 0 and 2 should be controllable by default. So maybe there is something wrong with your Fan0 output.

    You can map the part cooling fan to particular fans using the F parameter of your M563 tool definition commands. For example, if your M563 P0 command includes parameter F2 then any M106 command without a P parameter will be routed to Fan2 when tool 0 is active.



  • @dc42 said in Heater VIN for Part Fan or how to assign Fan 2 to Tool 0:

    .................Fans 0 and 2 should be controllable by default. So maybe there is something wrong with your Fan0 output.

    David. If you take a gander at the config.g that the OP posted, you'll see that he had set Fan 0 set to be thermostatic. So there may well be nothing wrong with the output.


  • administrators

    @deckingman said in Heater VIN for Part Fan or how to assign Fan 2 to Tool 0:

    @dc42 said in Heater VIN for Part Fan or how to assign Fan 2 to Tool 0:

    .................Fans 0 and 2 should be controllable by default. So maybe there is something wrong with your Fan0 output.

    David. If you take a gander at the config.g that the OP posted, you'll see that he had set Fan 0 set to be thermostatic. So there may well be nothing wrong with the output.

    Good point:

    M106 P0 S0 I0 F500 H T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on

    H with no number after it will be interpreted as H0.



  • Thank you guys! I have a long print running, so I can't test it now, but it sounds like you found the reason for Fan 0 not to work.
    Is the thermostatic function a modifiable setting in the online configurator? Or can I change this only manually?

    And I still don't understand, why I can't run Fan 2 by sending this:
    M563 P0 F2
    M106 S255

    Is this not what @dc42 said?

    But sending this works:
    M106 P2 S255

    And setting Fan 2 in the web interface works as well.



  • on the last page of the configurator for the fans (where you can add Fan2) there is a button for Thermostatic Control



  • Ahh how could I not see!? So it really was a noob problem. Now it works. Thank you so much!


Log in to reply