Duet wifi stepper noise in signal



  • After many months of completely unsuccessful printing with the Duet and loads of flipping back to my RAMBO, I’ve finally decided to check duet hardware for problems.
    I’d first like to point of that my printer prints near perfectly whenever I swap back to my RAMBO. The Power supply is adequate, with correct voltage and current being supplied with very low vripple. The mechanical aspects of the printer are also in great shape.
    Today I decided to check the steppers to see how they looked under the oscilloscope, and I was a bit shocked to see how jittery and un-square they were. I can understand why they may not be perfectly square under a load, but the jittering looks to be a stepper phase timing issue. Note that this video is with the motor powered, stationary. I did check it without the stepper, and the waves are much more squared but still jittery(lessened. I would show a video, but now the duet keeps stopping itself because it detects that the motor is disconnected. I can’t seem to bypass that safety feature anymore. On my Rambo, stepper unplugged, everything looks great. Plugged in, the signals get more rounded with slightly more noise, but way better than the duet.
    Is this how all duetwifi stepper ports look? https://streamable.com/5jo00
    FW:2.02
    Printer: Makergear M2



  • the TMC drivers manipulate the wave form for noise reduction
    see
    https://www.trinamic.com/fileadmin/assets/Support/Appnotes/AN001-spreadCycle.pdf



  • So, in other-words, yours looks similar to that and its normal?



  • @veti said in Duet wifi stepper noise in signal:

    https://www.trinamic.com/fileadmin/assets/Support/Appnotes/AN001-spreadCycle.pdf

    "Hissing or chirping chopper noise can be annoying. Especially in motor standstill, many applications
    are required to be silent. While the latest TRINAMIC drivers support stealthChop for absolutely silent ..."

    I can't wait to give it a try. It's noticeable when steppers are stationary.



  • Is your old Duet for sale?



  • @zapta said in Duet wifi stepper noise in signal:

    I can't wait to give it a try. It's noticeable when steppers are stationary.

    on the duet maestro where stealthchop2 is supported at low speeds you dont even hear the movement.
    on my delta the fan makes the most noise.



  • @Ret Can you post a picture of the bad prints the duet is producing?



  • config file too?



  • And maybe a sample of sliced gcode? Which slicer? Is it set to reprap gcode flavour?



  • Here is my config. Just to let you all know, I manage a print farm with custom and commercial desktop FDM printers, so I’m not anywhere near new to printing. I have them all tuned and printing very well, but they’re running marlin, repetier, and smoothie.

    The big issues I’m still having is rough movement from the printer and a poor rough top layer where the extruder fills a 2-7mm section. Both of these issues (from experience) are normally related to jerk and acceleration, yet I have tried nearly every single possible combination with results not getting much better from the last test ran. I've tried tuning pressure advance and it helps, but needs a value of about 0.75 to smooth out that top layer, but trashes the rest of the print. I also get uneven extrusions, and different print results from running the same gcode right after the first. To throw in, I’ve tried S3D, Cura, slic3r, idea maker, and Pathio, all horrible results. I’ve still not gotten an answer to this post regarding the very strange jittery and noisy stepper signal. Yes, the drivers manipulate the signal, but does mine look at all similar to any of yours? To be clear, I’m not talking about audible noise, I’m referring to noise in the signal. Seems like a couple of you may have drifted from that.

    About a year ago I started THIS thread. My config file has been changed since then, but results haven’t gotten much better, a year ago.

    OEM setttings for marlin:
    #define DEFAULT_MAX_ACCELERATION {900,1000,30,2000}
    #define DEFAULT_MAX_FEEDRATE {200, 200, 25, 25}
    #define DEFAULT_XYJERK 4.0
    #define DEFAULT_ZJERK 0.4
    #define DEFAULT_EJERK 1.0

    These images reflect the gcode.
    1_1556294322049_simple_boat5.gcode 0_1556294322048_config.g



  • Here are the images:
    1_1556294340762_20190426_114544.jpg 0_1556294340762_20190426_114532.jpg



  • @ret said in Duet wifi stepper noise in signal:

    Makergear M2

    where did you get the values for the M305 from?
    From what i can see in their firmware both hed and thermistor are the same.
    yet your config has different values.
    also those values do not correspond to the marlin thermistor 1 values.



  • The bed and hotend thermistor are in fact the same model. I did try with the equivalent thermistor settings from marlin, but went further on tuning them.



  • I don't know about the motor signal noise. @dc42 would have to weigh in there.

    From your config.g though your jerk values seem very low.

    M566 X240 Y240 Z30 E120

    Remember those values are mm/min not mm/s for reprap. Though it looks like you're just using the values from marlin. However, the way jerk works between the two isn't necessarily the same if I recall. Certainly not the same when it comes to the extruder and how jerk interacts with pressure advance. Not to mention how Z jerk can interact with mesh grid compensation.

    Try M566 X900 Y900 Z120 E6000

    I know that for me, with X and Y jerk values that low the quick back and forth zig zag moves slow down way too much and ends up oozing a lot leading to the rough surface like in your picture.


  • administrators

    The only good way to tell if the stepper driver is supplying the correct waveform to the stepper motors is to use a current probe in series with one of the windings. Modern stepper drivers use various techniques to reduce EMI and, achieve accurate low current microstepping, and to implement advanced features such as stealthchop.



  • @Phaedrux I'm aware of the units. I initially copied over the exact (converted) units from marlins FW, with no success. I've tried more duet printer standard accel and jerk like yours and it doesn't improve anything. I printed the little boat again with your exact jerk settings and it turned out worse than with the low jerk and accel. The makergear is a very solid printer, but its not designed for very high speeds, accel, and jerk. Any other suggestions?



  • Can you show us a comparison of two photos of prints, one showing the effects you're trying to correct and another that doesn't show these effects, ideally printed on the same printer?

    The prints you have shown don't look amazing, but they don't look bad. I would hesitate to implicate anything other than different settings exciting mechanical errors in different ways.



  • @bot I ran out of white, but this is the same sliced settings, printed on my rambo, just modified the jerk and acceleration gcode commands and format. You can clearly see the difference between the two, and that's not even using my normal RAMBO slicing settings, that's using the settings that work the best on the duet, but are still not good.

    0_1556549347286_20190429_102917.jpg



  • @ret

    That was printed on the exact same printer? I do see a difference, and it seems related to the extruder axis IMO. Would you agree?

    Can you post the accel, jerk, and speed settings you are using in marlin, and then post what settings you used on the duet? Please include the values for the extruder axis.



  • How confident are you in the accuracy of your thermistor values?

    M305 P1 T100000 B4138 C0 R4700

    The white one does look kind of over extruded, but that could also be from printing too hot?


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.