DBot Not Printing



  • Thank you in advanced for any help!

    I setup my DBOT and it all ready to test print.

    Im using simplfied 3d, I used the settings based on the build guide. When I go to upload and print the printer start the heating process. About 1min into the process the print shows 100% complete, the heaters get up to temp , the system homes and then nothing.,

    Any Ideas?



  • Tried Slic3r as well same result, seems to have something to do with when it homes it have the first initial heating


  • administrators

    How odd. Have a look at the gcode file to see what is in the start gcode (the code put in by s3d/slic3r at the beginning before the print starts) to see if any of that is weird. The wiki has a list of all the gcodes and their usage which can be a handle reference.



  • If I understand correctly, the problem occurs after the printer has homed? In which case, it could be something screwy with your homing files. Can you post them. Ian



  • @deckingman yeah seems to happen right after it homes. Im using a config generated by the configuration tool
    ; Relative positioning
    G91

    ; Lift Z
    G1 Z5 F6000

    ; Course home X or Y
    G1 S1 X-305 Y305 F1800
    ; Course home X
    G1 S1 X-305
    ; Course home Y
    G1 S1 Y305

    : Move away from the endstops
    G1 X5 Y-5 F6000

    ; Fine home X
    G1 S1 X-305 F360
    ; Fine home Y
    G1 S1 Y305

    ; Move Z down until the switch triggers
    G1 S1 Z-305 F1800

    ; Absolute positioning
    G90

    ; Tell the firmware where we are
    G92 Z2.5

    ; Uncomment the following line to lift the nozzle after probing
    ;G1 Z5 F100



  • Here is also part of the GCODE from one of the test cubes

    M107
    M190 S65 ; set bed temperature
    M104 S215 ; set temperature
    G28 ; home all axes
    G1 Z5 F5000 ; lift nozzle

    M109 S215 ; wait for temperature to be reached
    G21 ; set units to millimeters
    G90 ; use absolute coordinates
    M82 ; use absolute distances for extrusion
    G92 E0
    G1 Z0.300 F7800.000
    G1 E-2.00000 F2400.00000
    G92 E0
    G1 X120.004 Y115.787 F7800.000
    G1 E2.00000 F2400.00000



  • Well did more testing seems its not based on the homing it based on the heated bed coming to temp or right when it switchs from telling it to finish heating the bead and start heating the nozzle

    The process is upload, heated bed get to 65C , it homes and then says its finished


  • administrators

    Your cube gcode waits for bed temperature to be reached, but it doesn't wait for hot end temperature to be reached. It's probably a setting in your slicer. Or you can add M116 to your slicer start gcode to force it to wait. Scratch that, somehow I overlooked the M109.



  • I finally figure it out, after it homed twice for some reason it killed the job.

    I changed the config provided below for homeall and now its printing.

    Now just have to tune the extrusion

    G91 ; relative mode
    G1 S1 X-240 Y260 F3000 ; course home X or Y
    G1 S1 X-240 ; course home X
    G1 S1 Y260 ; course home Y
    G1 X4 Y-4 F600 ; move away from the endstops
    G1 S1 X-10 ; fine home X
    G1 S1 Y10 ; fine home Y
    G91
    G1 Z5 F6000
    G1 Z-305 S1 F1800
    G90
    ; Tell the firmware where we are
    G92 Z0



  • @dc42 in the gcode isnt that what m190 does ?


  • administrators

    @loft:

    @dc42 in the gcode isnt that what m190 does ?

    It's what M109 does - somehow I overlooked that command.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.