Duet homing on Ender 5



  • Having some problems setting up this Duet Wifi board on a Creality Ender 5.

    This is my second board, the previous, up to the point of fitting a BLTouch, was no problem, ran through the RFF config tool and all went well, even managed a couple of prints. On this occasion I cannot get the printer to home (using the same settings as previous).

    The printer is trying to home after clicking "home all", but is only moving in around 5 to 10mm jerks in all directions. Repeatedly pressing this will eventually get the print head to home on the Z axis but only close on the X and Y, then stops.

    I tried the "home all test" macro and the Z axis took off at a horrendous rate, luckily I was able to switch the printer off before any inevitable damage to the printer was done.

    Any help appreciated.



  • Can you post your config.g and homing files?





  • Blobs and stringing are usually a sign that your extruder and/or z axis isn't moving fast enough.

    Comparing your config to the marlin config it would seem that your extruder jerk is quite a bit lower. (300 vs 120) and your extruder max speed is only 25mm/s which could be limiting your retraction speed.

    Here's what I would change in config.g

    M566 X600.00 Y600.00 Z60.00 E3000.00       ; Set maximum instantaneous speed changes (mm/min)
    M203 X30000.00 Y30000.00 Z500.00 E6000.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z200.00 E6000.00     ; Set accelerations (mm/s^2)
    


  • Thanks, I’ll implement your changes. However as I cannot even get the printer to home yet I haven’t looked at the extruder.

    I did put in some conservative setting to give me time to switch the printer off should anything go awry, which it did with the home test macro.

    Not sure those changes will do anything to get the printer to home, is there anything else I need to look at?



  • Have you checked the endstop status to ensure you have set them up correctly and they trigger correctly using M119?



  • I haven’t ran an M119 yet (print head won’t reach the endstops). The endstop LED’s are lit up and go out when I depress each endstop switch - does that sound correct?



  • No. They should light when triggered, not the other way round.
    Hence using M119. If it says triggered when not triggered, you need to swap your endstops round in the firmware. It would stop you from homing.



  • Excellent, thanks, I'll do that later today and report back.


  • administrators

    @brian_k said in Duet homing on Ender 5:

    I haven’t ran an M119 yet (print head won’t reach the endstops). The endstop LED’s are lit up and go out when I depress each endstop switch - does that sound correct?

    If they are normally closed switches (the most common type), then that's correct. But check that the Duet is reading them correctly, using M119.



  • Sorry, just to be clear, do you mean switch the endstops from “Active Low (NO)” to “Active High (NC)” in the RRF config tool?

    Or should I switch the wires over on the connectors?

    David, thanks I'll do that first when I get back from lunch.



  • Active High (NC) and at low end should fix it. Also make sure your end stop cables are right to.



  • M119 is producing a comment of "Not Stopped" on X,Y and Z axis.......also on Z probe, which I did not set up???

    Should I go ahead with Active High at low end?



  • I don't have my Z probe setup yet so can't comment as to what that should be set for but the other stops I am running are from the original ender 5 and I have mine all set to Active High (NC) and at low end and they all work fine on the duet 2 wifi.



  • Thanks, not worried about the Z probe yet, just want to get the printer running.



  • It is with great pleasure that I can inform fellow forum members that the printer is now functioning as expected. Setting the endstops to active high at the low end did indeed do the trick.

    For reference the endstop LED’s are on and go off when the switches are activated.

    Many thanks one and all for your input.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.