Auto bed compensation questions and issues



  • Hey,
    I am new to Duet and trying to figure out how to work with the board correctly.
    I think that my bed compensation is not working at all. I don't feel or see the screws rotate at all during XY movement. The Z axis moves without any issue(even if I connect the 4 motors to the same driver)
    Also, when I use babysteps the bed will not move during a layer change. Not in the printer and not in the web interface. I just see the same value as the first layer after the babysteps.
    Can it be connected to the 4 motors on 1 driver? It is moving pretty smooth and the driver is not hot.

    Another question is regarding the Z probe offset, I am using an inductive sensor and I could not find information on how to adjust it right. What does (-) and (+) mean? What is my point of reference?

    I have a cartesian machine with Duet2 wifi (1.02 or later) Firmware:2.01(RTOS) (2018-07-26b2)
    0_1557051353291_config.g

    Thank you for your help



  • what stepper motors do you have?

    12v or 24v?

    are the 4 motors in series or parallel?



  • I am using NEMA 17, 24 volts.
    I have two cables for the Z motors, each connects on one side to 2 motors and on the other side to the Duet. The cables are connecting the motors in parallel. I don't know how the duet dual Z connectors work...



  • @gaz6 said in Auto bed compensation questions and issues:

    NEMA 17

    there are many different nema 17 stepper motors. please post the specific data on your steppers.



  • It is Motech motors and the datasheet is located here: http://motechmotor.com/productDetail-0104-32.html.

    The motors were able to move the bed without any problem and I have now finished printing a 400 mm tall cube but my first layer looks bad and my brim did not adhere at all.
    I don't see the connection to the motor type as before I moved to Duet I was printing with the same setup using MKS gen board and Marlin 1.9 UBL activated.
    Why do you think it is related to the motors?

    Thank you



  • you have 1.68A motors
    However if you connect 4 motors in parallel you run them at 1/4 the current.

    You configured 0.8A.

    So thats 0.2A per motor.
    not even 25%.

    The connectors on the duet run them in series.
    so start of by connecting 2 to each port.
    Then increase your current.
    You want to run your motors at 75% of their rated current, but that might be pushing it on the duet drivers.



  • Ok. I understand.
    I tried what you suggested and nothing changed. I still don't see the bed compensation in work.
    I then connected 2 motors to E1 driver and the same result. There is no compensation at all.
    In all senarios, I was able to probe the bed, move the bed all the way down and all the way up.
    When I press the Auto Bed compensation I can see the bed topography.
    What am I missing?



  • are you enabling the compensation at some point before the print?
    G29 S1 will load a saved heightmap. That needs to go into your slicer start gcode to enable it before a print.

    If you run M122 during a print, does it show compensation as "mesh" ?

    You may also want to update your firmware to 2.02.



  • @phaedrux said in Auto bed compensation questions and issues:

    compensation

    I updated the firmware. I have added the G29 S1 to the GCODE after the G28 command.
    I don't see 'compensation' or 'mesh' in the M122
    0_1557126505840_M122.txt



  • Looks like it is being loaded.

    Bed compensation in use: mesh



  • @veti said in Auto bed compensation questions and issues:

    However if you connect 4 motors in parallel you run them at 1/4 the current.

    From the description above it seems that the steppers are connected as 2P2S and thus each sees 1/2 of the current.



  • @phaedrux said in Auto bed compensation questions and issues:

    M122

    I started from scratch and now the compensation is working...

    Regarding G31 command... What is the difference between the P and the Z? How do I work with those values for an inductive sensor?

    How do I set the offset values of the probe relative to the nozzle? Do I use minus values? I know I use G31 with X and Y values but how to set them relative to my nozzle?


  • administrators

    @gaz6 said in Auto bed compensation questions and issues:

    Regarding G31 command... What is the difference between the P and the Z? How do I work with those values for an inductive sensor?

    Z is the trigger height. For an inductive sensor it should be positive (sensor triggers before the nozzle touches the bed).

    P is trigger level, and only makes much difference if you are using a sensor with an analog output.

    How do I set the offset values of the probe relative to the nozzle? Do I use minus values? I know I use G31 with X and Y values but how to set them relative to my nozzle?

    The X and Y parameters in G31 are the offsets of the probe from the head reference point (HRP). In single-extrusion printers, the HRP is normally the nozzle. So use positive values if the probe offsets are in the +X and +Y directions from the nozzle.



  • Ok, thank you.

    When I add the probe offset the printer won't probe a lot of points that my probe can reach. My inductive sensor is located inside the bed during all movement of the printer.
    My last probing point is the bed size minus the probe offset values. I would like to be able to probe from edge to edge. Is it possible?

    In Marlin, you have an interpolation command to estimate the points the probe can't reach. Does duet have it as well?

    Thank you for all the help!



  • @gaz6 RRF will automatically interpolate for the area it can't reach.


  • administrators

    @gaz6 said in Auto bed compensation questions and issues:

    My last probing point is the bed size minus the probe offset values. I would like to be able to probe from edge to edge. Is it possible?

    In your M557 command, specify the coordinates that you want to probe. Do not correct them for probe offset. The firmware will place the nozzle at the correct point so that the probe is where you asked to probe, allowing for the nozzle offset. So you can probe anywhere that the probe can reach, assuming you have set the M208 limits correctly. For example, if your probe is offset by +30mm in the X direction, and the lowest X coordinate you want to probe is X10, then the firmware will move the head to X-20 to do that - assuming that the lower X limit set by M208 is -20 or lower.



  • Thank you.
    I have just done that.
    I had to add G92 X0 to my homeall and xhome files after homing is finished so I won't have -30 in my X position after homing. Any other solution to that?



  • Well you may actually want to have that -30 in your X position if the nozzle is actually 30mm away from the edge of the bed.


  • administrators

    @gaz6 said in Auto bed compensation questions and issues:

    I had to add G92 X0 to my homeall and xhome files after homing is finished so I won't have -30 in my X position after homing. Any other solution to that?

    If your printer homes X with the nozzle 30mm off the left edge of the bed, then it's right that the X position is -30 immediately after homing X, assuming that you want X=0 to correspond to the left edge of the bed. [Another common choice is to make X=0 Y=0 the centre of the bed.]


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.