panel due 7i issue



  • Hi everyone
    I'm having some problems with mi paneldue i7, any button that i touch on the touch screen, is like if i push the emergency stop button... In the right corner on the top of the screen came out "connecting" for a couple seconds an after that came out "idle "
    Some body can tell me what should i do?
    Thanks


  • administrators

    1. Are you using the ribbon cable, or the 4-way cable? If it's the 4-way cable, check that the wiring is connect. The order of the wire colours should be reversed from one end of the cable to the other.

    2. After this has happened, run M122 on Duet Web Control or from USB, and look at the reset data to see whether the Duet really did restart.



  • thi is the report :
    M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.0(RTOS) running on Duet Ethernet 1.02 or later
    Board ID: 08DGM-9T6BU-FG3S0-7JTD8-3SJ6S-KB6VH
    Used output buffers: 3 of 20 (14 max)
    === RTOS ===
    Static ram: 28380
    Dynamic ram: 95888 of which 0 recycled
    Exception stack ram used: 428
    Never used ram: 6376
    Task NETWORK ready, free stack 324
    Task HEAT blocked, free stack 800
    Task MAIN running, free stack 3612
    === Platform ===
    Last reset 04:12:16 ago, cause: software
    Last software reset time unknown, reason: User, spinning module GCodes, available RAM 6524 bytes (slot 1)
    Software reset code 0x0003 HFSR 0x00000000, CFSR 0x00000000, ICSR 0x0441f000, BFAR 0xe000ed38, SP 0xffffffff
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 7.0ms
    MCU temperature: min 29.7, current 32.3, max 34.5
    Supply voltage: min 22.9, current 23.9, max 24.1, under voltage events: 0, over voltage events: 0
    Driver 0: standstill, SG min/max 0/0
    Driver 1: standstill, SG min/max 0/0
    Driver 2: standstill, SG min/max 0/0
    Driver 3: standstill, SG min/max 0/1023
    Driver 4: standstill, SG min/max 0/176
    Date/time: 2019-05-15 16:49:34
    Slowest loop: 78.08ms; fastest: 0.07ms
    === Move ===
    Hiccups: 3312, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm 121, MaxWait: 2370385445ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: mesh
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 0 is on, I-accum = 0.2
    Heater 1 is on, I-accum = 0.5
    === GCodes ===
    Segments left: 0
    Stack records: 2 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 54.89ms; fastest: 0.01ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8
    Interface state: 5
    === Filament sensors ===
    Extruder 0 sensor: ok
    === Expansion ===

    What it means?😅



  • @dc42 i'm using the 4 way cable, it was working ok, yesterday i change the case and after that the issue came out



  • Remove the case and try again?


  • administrators

    Also check that you have the baud rates of PanelDue and the Duet set the same (57600 baud). PanelDue sends a special message to the Duet when emergency stop is pressed, and it's just possible that a particular normal message at the wrong baud rate could be misinterpreted as emergency stop.



  • @dc42 where should i check that parameter? at the moment i can't go inside in the set up window in the paneldue


  • administrators

    @jv said in panel due 7i issue:

    @dc42 where should i check that parameter? at the moment i can't go inside in the set up window in the paneldue

    Disconnect the PanelDue from the Duet and power it from a USB cable instead. Alternatively, leave it connected but hold the Reset button on the Duet down while you enter the Setup page.



  • Hello guys, thankyou very much for your help, i solved the problem.
    The new case was pushing a little in the side of the touch panel 😣 , i put a little spacer and the touch panel now is working.
    I really aprecciate your help and the time that you take for give me your advice.
    I wish you a great day 👍


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.