First layer tuning



  • Hi,
    I Have a ender 3 pro with a duet maestro, bltouch, and Swiss all metal hot end. I have could use some advise on the first layer tuning. I have set my z probe offset to lightly grab a piece of paper. however when I print my first layer test it starts off printing in air. I have to use the baby steps in the print menu to get close to the bed my baby step offset was -.26 to get it to stick to the bed. here is a picture of the first layer. I can post what ever other data necessary to try and find the problem.
    thank you for the help

    0_1558799867109_unnamed.jpg



  • adjust the z offset until first layer is ok.

    you also might try increasing the probe point for the mesh bed levelling.



  • Ok ill give that a try. If i have my information correct i need to adjust z offset down correct? and as for the probing i currently have it set at 47 points. However, i currently do not have that set to run every print i was planning on running once every couple of days. should i run it every print?



  • if I remember correct !!
    You drop the nozzle down until it touches the bed (bed centre) and zero it out with G92 Z0.
    Move the nozzle up again 10mm G1 Z10
    and probe with G31 S-1 ? and it should tell you want the bltouch off set should be.



  • yes i have done the z offset and when i am at z0 it is a paper width from the bed but when i print it is printing in air.



  • @kmhudgins said in First layer tuning:

    s. However, i currently do not have that set to run every print i was planning on running once every couple of days. should i run it every print?

    are you sure that you are loading the heightmap after the homing?



  • Do you have in your config.g a command like this?

    G31 P500 X20.5 Y12.9 Z1.300

    If so, if your optimal baby step was -0.26mm, subtract it from the Z value and update the command. For example, with the command above, adjusting to -0.26mm babystep will result in

    G31 P500 X20.5 Y12.9 Z1.560

    (1.30 - -0.26) = 1.56

    Then power cycle the printer and print. The optimal babysteps now should be 0.

    BTW, the first layer in the picture doesn't look good. Is this with the -0.26 babysteps? Can you find a better babysteps value? Are your esteps calibrated and your hoeend clean and flows well?



  • @veti i think so i have the G21 S1 commend in the bed.g to load height map form file. is there a way to verify that this is working correctly?



  • @zapta yes i do need to do further testing that was just my first run sense getting the bltouch and setting up the mesh compensation. I will try changing the offset when i get a chance tomorrow. thank you for everyones input.



  • @kmhudgins said in First layer tuning:

    i think so i have the G21 S1 commend in the bed.g to load height map form file. is there a way to verify that this is working correctly?

    The command is G29 S1
    Running M122 while printing will tell you if the mesh is being applied



  • Hey! So i've been having similar issue recently but i think i'm making progress now. So when you calculate/measure the z offset, don't use paper!
    there is a document on the duet wiki https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe

    They say: move the nozzle until its touching the bed and i assume they mean it and that's what I do. Then follow the calibration steps on the wiki. don't use paper and move the nozzle downuntil the gap (should look like no gap at all) is closed. then measure the distance and take it over into your z offset.

    one more thing is... don't use the corner or your bed for homing z. I moved from the corner to home in the middle of my bed and it works much better with calibration.

    Since then i really have a nice first layer!



  • @nightreaver said in First layer tuning:

    Since then i really have a nice first layer!

    Have you tried the first layer challenge?

    https://www.thingiverse.com/thing:2741800



  • @veti typo It is set at G29 S1. ill check this this after noon thank you


Log in to reply