Initial Homing issues - Sequence of Errors



  • I have just complete wiring up my Duet3D WiFi and am troubleshooting the initial setup. I have installed the firmware from the RepRap configurator that is labelled for my printer, the Wanhao Duplicator i3 v2.1 (I realize it states that it has not been thoroughly tested but made the assumption that as it appears on the site it's probably not dangerous).

    After uploading the firmware and trying to Home All Axes I have had several very unpleasant experiences trying to work out what the correct process is for Homing each axis. In the latest I tried to home the Z Axis only to have the printer head raise all the way to the top of the frame at which point I had to use the Emergency Stop. Last night I tried to Home the Y Axis only to have the bed shoot to the end of the frame and then overload the motor (again leading to a rushed power off ). This last one was caused by damaged Molex connections.

    I am now very reluctant to go at this again until I am clear on the actual process for homing the printer on each axis.

    Where can I find an example of how to do this please. I don't think I'm far off doing damage at this point.

    Sorry, it's a newbie question I know, but it's better to ask than trash the printer 😞

    Attached is an example of the messages I am seeing.

    Thanks for any assistance.

    0_1559068876914_Homing Errors.png



  • Reduce the stepper current and you'll be very unlikely to do any damage even if the printer crashes, what will slip is the rotor in the motor, while it may sound terrible its just a magnetic coupling.

    To move the printer before it is homed you need to use G0 S1 or G0 S2 to override or adhere to the limit switches. (or tell the printer its okay to move without being homed).

    But sounds like you need to start by checking that your limit switches are correctly defined at the min or max of each axis, then that the motors are configured or wired to turn in the correct direction. Then the default homeall.g file should just-work(tm)



  • before doing any moves trigger the endstops manually and check with M119
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M119_Get_Endstop_Status


  • administrators



  • @veti Thanks. M119 responds with

    "M119 Endstops - X: not stopped, Y: not stopped, Z: not stopped, Z probe: not stopped"

    This was my first task this evening because of the previously mentioned reaction to a "Home All" and the "Y Axis" slamming against the back of the frame. I was confused as to why the endstop had not stopped the motion, turns out it was a defective Molex connection. All endstops are now responding as they should.



  • @b0m0a0k said in Initial Homing issues - Sequence of Errors:

    "M119 Endstops - X: not stopped, Y: not stopped, Z: not stopped, Z probe: not stopped"

    so none of your endstops are working?



  • @veti I thought that "Not Stopped" meant they had not been triggered, certainly when I manually trigger then one at a time the corresponding light comes on on the board.



  • "not stopped" is the current status, if you run M119 while triggered, the output text will change. But if the leds work, then M119 should reflect the same state.

    Thats one step closer at least 👍



  • so if the y endstop is working why exactly did the y home fail?



  • please post your config and all homing files.



  • @veti I think that was because of a failed Molex connection. I have repaired that now but am still trying to get homing to work. Am working my way through dc42's suggested reading.



  • @veti Hi, OK, got the files you requested but have removed the passwords from the config.g file.[0_1559075082911_Bart Config Files.zip](Uploading 100%) 0_1559075101598_config.g 0_1559075107396_homeall.g 0_1559075113958_homex.g 0_1559075118078_homey.g 0_1559075123270_homez.g

    I hope this is how you attach the files. It wouldn't let me attached a .zip



  • A little progress here.

    Using the information on the "Test_axes_or_motors_individually" I can confirm that the extruder can be moved through all planes and in the amounts specified via direct gcode entry. However, when I try anything in the main "Machine Control" section I still get the "G0/G1 Insufficient Axes homed".



  • unless you explicitly allow moving without homing, you need to press home all before jogging the axes



  • Perhaps this guide would help with testing things

    https://duet3d.dozuki.com/Guide/Ender+3+Pro+and+Duet+Maestro+Guide+Part+3:+Commissioning/39

    It's written for the Ender 3 but the methods would apply to any printer.



  • Your homing files need to be modified slightly to allow it to raise the Z axis before the homing moves.

    For instance, your homez

    G91                ; relative mode
    G1 Z4 F200         ; raise head 4mm to ensure it is above the Z probe trigger height
    G1 Z-210 F200 S1   ; move down to 210mm in the -Z direction, stopping if the homing switch is triggered
    G90  
    

    Would become

    G91                ; relative mode
    G1 Z4 F200 S2        ; raise head 4mm to ensure it is above the Z probe trigger height
    G1 Z-210 F200 S1   ; move down to 210mm in the -Z direction, stopping if the homing switch is triggered
    G90   
    

    Notice the S2 on the first Z move to raise it. The S2 allows the axis to move before it is homed. The S1 after that is the move to the endstop.

    The same thing would need to be changed in your other homing files. The first Z move needs the S2 switch.



  • It may be worth going through the Reprap configurator on your own and trying to input the values using this config as an example. The configs you got for the Wanhao may be for a much older version of the firmware.



  • @phaedrux said in Initial Homing issues - Sequence of Errors:

    It may be worth going through the Reprap configurator on your own and trying to input the values using this config as an example. The configs you got for the Wanhao may be for a much older version of the firmware.

    I tend to agree with you on this. There appear to be differences in the configuration that may be based on what version of the i3 you are using.

    Prior to starting this upgrade I installed Repetier-Host and took screenshots of the EEPROM from my Melzi board. I have seen other examples of this that feature some differences in settings. I think this is linked to the version of the i3 and where Wanhao tweaked the config.

    The big issue I have in running through the RepRap configurator from scratch is that I just can't seem to reconcile some of the settings it's asking for with what I have in the screenshots from my printer as it was working with the Melzi board. An example of this would be the "Max. Speed Change" setting. There isn't anything in the EEPROM that seems to match that and I don't know enough about these settings (Yet!) to make an educated guess as to whether it is safe to leave the setting at it's default on the Configurator page.

    The Ender 3 article is a big help in just checking basic functionality and I will run through this again this evening once I am back in front of my printer.

    At the heart of this I think is my misinterpretation of what I was seeing on the Duet Web Control screen. I thought that clicking on the "Home" buttons would perform the action needed and enter that into the config. I did not realize that I needed to have set the Gcode instruction (for whichever axes I was looking at) prior to this.

    As a complete newbie with GCode and the Duet3D WiFi board it's all new to me. I have an inherent dislike of making assumptions so tend to grind to a halt when I don't understand something.

    Again, I am very grateful to all here who are trying to help out. I am making progress and don't think I am too far away from completion of this upgrade.

    0_1559126942952_Printer Information - EEPROM Settings-1.png 0_1559126948362_Printer Information - EEPROM Settings-2.png



  • @b0m0a0k said in Initial Homing issues - Sequence of Errors:

    Max. Speed Change

    This refers to jerk.


  • administrators

    @b0m0a0k said in Initial Homing issues - Sequence of Errors:

    At the heart of this I think is my misinterpretation of what I was seeing on the Duet Web Control screen. I thought that clicking on the "Home" buttons would perform the action needed and enter that into the config. I did not realize that I needed to have set the Gcode instruction (for whichever axes I was looking at) prior to this.

    The configurator will generate the GCode instructions in the homex.g, homey.g, homez.g and homeall.g files for you, but they will obviously only be correct if you enter the correct information in the Endstops page of the configurator. Also you should test that the motors move in the correct directions before you test homing.


Log in to reply