Super loud Motors



  • Hi!

    I know, that this topic was mentioned a lot of times but I have read all of them and I didn't find a solution for my problem.
    I have all informations about my gear, so I hope it will help to develop a solution.

    Here is a video:
    https://www.youtube.com/watch?v=dx4rg2ep_7Y

    You can clearly hear that motors are really loud, even when idle.
    I was playing with "Reducing Stand-Still Noise" informations.
    Changing TOFF is just making the pitch different but it's always loud.

    Here is M569 P0 response:
    Drive 0 runs in reverse, active low enable, step timing fast, mode spreadCycle, ccr 0x101b4, toff 4, tblank 2, hstart/hend/hdec 3/3/0, pos 670

    And here is my motors config:
    M350 X16 Y16 Z16 E16 I1 S1
    M92 X160.00 Y160.00 Z800.00 E865.00
    M906 X900.00 Y900.00 Z900.00 E800.00 I30
    M584 X0 Y1 Z2:4 E3
    M915 X Y Z S2 F0 R0 H400

    My setup:
    24V 350W Meanwell LRS-350-24 PSU
    Motors: Nema 17 Wantai 42BYGHM809 0.9 degree Link: https://www.aliexpress.com/item/32827932505.html
    Extruder motor: Slimline Motor 0.9 degree from E3D
    Board: Duet 2 Wifi

    Firmware Version: 2.03RC3 (2019-05-25b5)
    WiFi Server Version: 1.23

    What I have noticed:
    I have the same extruder motor on my second 3D printer with TMC2208, 12V PSU and it's super silent. So I don't think that it's a problem with motors. I'm pretty sure that it's a software / tmc settings problem. (Of course tmc2208 has stealthchop mode, but with 1/256 microstepping TMC2660 should be a lot quieter than on my video, shouldn't it? Especially with higher PSU voltage.)



  • the video shows movement at 200-800mm/sec. that is going to be noisy even with stealthchop2.

    did you try the same settings that marlin uses?
    { <off_time[1..15]>, <hysteresis_end[-3..12]>, hysteresis_start[1..8] }
    #define CHOPPER_DEFAULT_12V { 3, -1, 1 }
    #define CHOPPER_DEFAULT_19V { 4, 1, 1 }
    #define CHOPPER_DEFAULT_24V { 4, 2, 1 }
    #define CHOPPER_DEFAULT_36V { 5, 2, 4 }
    #define CHOPPER_PRUSAMK3_24V { 4, 1, 4 }
    #define CHOPPER_MARLIN_119 { 5, 2, 3 }

    but there is a big difference in noise between stealthchop2 and spreadcycle



  • I have build a lot of 3D printers. Most of them were using A4988 drivers and trust me, they were quieter than Duet which should be quieter. (because of 1/256 microstepping) I have also printer with TMC2208, so I think that loudness should be somewhere in between of these printers.

    Btw. The problem is that even on idle it creates a lot of noise. It sounds like the fans are spinning but there are no fans yet. This noise is amplified when doing moves even with slow speed. And that's worrying me. When I turn spreadCycle on it's 2x times louder! I'm not a newbie in this topic 😉 I'm trying everything I can before I ask someone for help.

    With settings from Marlin it sounds smoother, I would say that it is less rough.

    If someone wants code to set these settings in Duet (It's for 24V PSU):
    M569 P0 C66180 ; set drivers. toff 4, hstrt 0, hend 5
    M569 P1 C66180 ; set drivers. toff 4, hstrt 0, hend 5
    M569 P2 C66180 ; set drivers. toff 4, hstrt 0, hend 5
    M569 P3 C66180 ; set drivers. toff 4, hstrt 0, hend 5
    M569 P4 C66180 ; set drivers. toff 4, hstrt 0, hend 5

    Values are scaled to match Marlin values.



  • @petrzmax

    In your config.g I see that you have used M584 to map drivers to axes after other parameters such as M350 and M906. The Wiki clearly states quote :

    "M584 must come earlier in config.g than any M350 and M906 commands. If it creates new axes, it must also be earlier than any M92, M201, M203, M208, M350, M566, M574 , M667 and M669 commands."

    So you probably are not using the micro-stepping that you think you are among other things.

    Also, this looks odd - M350 X16 Y16 Z16 E16 I1 S1

    The S1 parameter is undocumented in the Wiki (https://duet3d.dozuki.com/Wiki/Gcode#Section_M350_Set_microstepping_mode) so I've never come across it before - hence it looks odd to me.



  • @deckingman Thanks! I remember reading this information but finally I missed it somehow. I have added S1 parameters for the test. I found it on this forum in one of the topics about the noise.

    I have fixed the code and now there is a huge difference. Printing speeds are almost silent. Faster movements are still a bit loud but it's a lot better. Thank You deckingman again.

    Now problem with motor hissing has remained. I will play with Toff again, maybe it will change something. If someone has some other ideas just let me know 😉



  • Can you post your full config file to look over?

    For the idle noise you can try reducing the idle hold time out time with M84 S and setting a low as possible idle current value in M905 I

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M906_Set_motor_currents
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M84_Stop_idle_hold

    Some motors are just noisy at idle.



  • @phaedrux Thanks I have played with these settings and it's a bit better now. Thanks for help guys 🙂


Log in to reply