Tool Fan Behaviour - No longer able to control



  • I have been running through the document "Ender 3 Pro and Duet Maestro Guide Part 3: Commissioning" (Yes, I know I'm configuring the Wanhao Duplicator i3 V2.1) and specifically the section on Hot End and Bed Heater Tests (Steps 7 & 8).

    In my first run at the tests in step 7 I was seeing no activity from the hot end fan when the extruder reached 45 Degrees. If I used the slider on the web interface the hot end fan responded without issue. So I inspected the connection on the board and matched that to the board schematic, where I realized that FAN0 was not a member of the PWM group. That's where I had my hot end fan connected.

    So I powered off my board and changed the hot end fan to FAN1 and powered back on. This time when I reran the test the fan came on as expected as the hot end reached 45 Degrees and turned off again once the hot end cooled to under 45 Degrees. All good.

    However, I now have no control over the hot end fan from the Web interface at FAN0. That probably means that I need to change the config to look at FAN1 - but I can't seem to see that in the config files.

    Could someone please point me in the right direction?

    0_1559334300148_FANS.png



  • @b0m0a0k In a nutshell, as you have discovered Fan 0 is the part cooling fan by default. So when you are printing a gcode file, wherever there is an M106 command, by default that will control Fan 0. M106 without a fan number will default to using fan 0.

    Fan 1 you have set to be the hot end cooling fan and as you have set it to run in thermostatic mode (as is normal) you can't then control it by other means.



  • @deckingman said in Tool Fan Behaviour - No longer able to control:

    u can't then control it by other m

    Thanks @deckingman . So then it's doing what it should do and I can't use the Web Interface sliders?



  • @b0m0a0k The sliders should control Fan 0. By default, both sliders in DWC are one and the same and will move together. To control Fan1 you'd need to disable thermostatic mode then send M106 P1 Snnn.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.