Autocalibration Problems Anycubic Predator Duet Wifi 2



  • Hi Guys,

    I´m trying to autocalibrate the bed for my Anycubic Predator, but I´m failing. Maybe you can help me with explaing what I´m doing wrong. I have a Pertinax 1 mm added with Tape to the bed. I´m using the microswitch probe of the Predator.

    I got the files from a buddy who has the Predator and the Duet Wifi 2 too. Maybe there are errors I can´t see.

    This are my steps how I try to calibrate:
    Home all
    nozzle down to bed to a distance of ~0.10 mm
    G92 Z0
    G1 Z25
    adding the probe
    G30 Z1
    Adding the distance to the config.g (line G31)
    restart as the config is eddited
    homing g1 25
    adding the probe again
    G29 for probing
    M500
    leave the probe on the nozzle
    G32

    0_1559466263667_config.g
    0_1559466283874_config-override.g
    0_1559466292368_bed.g

    0_1559466393456_mesh picture.JPG

    Any help is appreciated.

    Sorry for my bad english 😛

    Best regards
    Sascha



  • from your overwrite.

    ; Delta parameters
    M665 L440.000 R227.000 H455.000 B185.0 X0.000 Y0.000 Z0.000
    M666 X0.000 Y0.000 Z0.000 A0.00 B0.00

    this does not look like the result of an auto calibration.



  • If the calibration is basically a skewed plane (and it looks like that), there is a good chance that the height of your tower max endstops is different. The height of the max endstops in relation to the bed needs to be pretty precisely the same on all towers. A hard to find but easy to run into version of this issue is if the endstop is reversed and the microswitch is on the other side, especially if the metal bar triggering the actual switch is still attached (on the anycubic linear plus, the predecessor of the predator, this could lead to that endstop not triggering at all and the motor ramming against the physical installation of the endstop, likely displacing it if you move up fast enough).



  • @oliof: then the homing should not work correctly, right? But it´s working, so the endstops on the top for the axis should be ok (?).

    Other problem (maybe part of my general problem).
    I´m homing. In the webinterface I see the headposition: x0 y0 z455
    this seems correct.
    then i move the printer head down to 1.90mm (this is the correct z0)
    I change the z=0 hight with G92 Z0 to 0mm
    after homing, the Z0 is again on 1.90, not 0.00 mm
    Why is the homing changing the Z0 height?
    How can I set the Z0



  • read
    https://duet3d.dozuki.com/Wiki/Calibrating_a_delta_printer
    especially the part about Saving the calibration results



  • i did it according to the calibration tutorial. The bed seems now to be "better"
    0_1559587869751_Unbenannt.JPG

    But this doesn´t help me with the change of the Z height. Everytime I home the towers, the Z0 is above the bed. This can´t be correct?! I need a correct Z height before I can calibrate the bed correct, or not? And of course to print afterwards on the correct height.

    How I change my Z0:
    Home all towers
    Move all towers down to +1,65 mm (bed scratches the piece of paper)
    G92 Z0

    After homing the Z0 is again on +1.65

    What step is wrong?



  • what are your saved M665 and M666 lines?


  • administrators

    @chaosfreak said in Autocalibration Problems Anycubic Predator Duet Wifi 2:

    But this doesn´t help me with the change of the Z height. Everytime I home the towers, the Z0 is above the bed. This can´t be correct?! I need a correct Z height before I can calibrate the bed correct, or not? And of course to print afterwards on the correct height.

    1. Calibrate the Z probe trigger height. See https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe.

    2. Run auto calibration a few times until the deviation is stable.

    3. Save the resulting M665 and M666 values. See https://duet3d.dozuki.com/Wiki/Calibrating_a_delta_printer#Section_Saving_the_calibration_results. The saved M665 H parameter should give you the correct Z=0 height.



  • Hi DC42

    thank you for your help. I was able to make the G32 and the G29 and get a relative good result.
    One more question
    Is it possible to increase the probing points, so the mesh is tighter?
    xmin,xmax,ymin,ymax,radius,xspacing,yspacing,xnum,ynum
    -180.00,180.10,-180.00,180.10,185.00,20.00,20.00,19,19

    I would like to have 10 mm spacing between the points if possible.

    Is there a tut how to increase the probing points?



  • @chaosfreak If you send an M557 command in the gcode console with a very small spacing set, it will probably be more points than it can support, and the error message it gives you will suggest the smallest spacing possible for you to use.

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M557_Set_Z_probe_point_or_define_probing_grid


Log in to reply