Faulty Duet 2 Maestro



  • I'm a big fan of Duet boards, I have a Duet WiFi running successfully on a Delta that I built from Open-builds hardware and the Duet Smart Effector which is awesome! With that great experience I decided to upgrade my TAZ 4 from a Rambo to a Maestro.

    Last week on Friday (6/7) I got my Maestro turned on for the first time, but didn't go well.
    I went through the setup with YAT, changed the IP address to be within my network.
    Entered my IP address in browser and quickly got the Duet GUI, next loaded up my custom RepRap config.zip file in the Systems Tab, all files uploaded quickly.

    After that I Homed all axis and that's when it happened, the browser lost connection. I tried entering the IP address and got nothing, and that is when I noticed that my Ethernet jack was not lighting up, Yellow LED not solid, Green LED not blinking. Also to note, power LEDs are on.

    I don't know what else I can check. I've gone over all my wiring and can't find anything misplaced or missed.

    I searched the forum and found that a user had a similar experience and turned out to be a faulty Ethernet module, and my board my have the same issue.

    I emailed my supplier, but was instructed to first post my experience here.

    Thanks,

    Silrocco



  • Are you still able to connect through YAT?



  • @Phaedrux, When I wrote the first post, I had removed the Maestro from the printer and part of my past diagnoses I did not attempt to reconnect to YAT, bad root cause analysis on my part. Since you asked, I tried it and it connects to YAT. I sent an M552 and return with:
    M552
    Network is enabled, configured IP address: 0.0.0.0, actual IP address: 0.0.0.0<LF>ok<LF>Network running, IP address = 192.168.86.XXX<LF> (the "XXX" are fillers)

    When I saw that, I was surprised! With that, I plugged in my Ethernet cable and now I can bring up the Duet GUI.

    Curious what happened?

    Anyhow, the Diag LED is ON, is there diag info I can get to diagnose what caused the failure?

    Thanks.


  • administrators

    Dodgy Ethernet cable perhaps? Or maybe failure to read config.g from the SD card.


  • administrators

    @silrocco could be an issue with your wiring on the printer if it works without the endstops etc connected and doesn't with the endstops connected and homed.



  • @T3P3Tony & @dc42

    I'll replace the Ethernet cable with a new one and verify all connections of end-stops and stepper motors with board installed, but connect each axis one at a time.

    I'll update on my findings.

    Thank you.



  • @Phaedrux @dc42 @T3P3Tony

    Hi all, It turned out to be the end-stops micro switches causing the board to lose connection. I read up on the on "Connecting endstop switches - What might go wrong" and then I corrected the wiring and all is good with that.

    Now I need to figure out what is causing my X and Y axis make a continuous "ta ta ta..." sound (like a machine gun), while jumping back about several mm then to a stop when it triggers the end-stop; only when I Home All and individually home the Y axis, but the X axis behaves normal in when I home individually.

    Any ideas?

    Thank you all for your help.



  • Jumping solved! Did a new RepRap Config at RRF, there may have been a error in my part on the first RRF config.

    Please closed this as solved.

    Thanks.


Log in to reply