duet2 ethernet expansion board heater 6



  • Hello Guys i have a problem that i can't solve

    I'm trying to drive a relay with an io pins.

    In my expansion board i have the heater number 6 and i disable it with M307 H6 A-1 C-1 D-1 in config.g
    But when i trying to used with M42 P6 S1, an error came out telling me

    M42 P6 S1
    Error: M42: Logical pin 6 is not available for writing

    I try it to do this with the fan1 output and the solid state relay works when i have to put it on.
    But when i put it off, the relay light turn off but the contact in the relay stay close, any body can tell me why this happens?

    Thank you so much



  • Hi JV

    Did you check if your disabled heater gets overwriten in the config-override.g file?

    Best,
    Markus



  • @change3d-gmbh

    Thanks for your reply, i found this in the config-override.g file

    M307 H6 A340.0 C140.0 D5.5 S1.00 V0.0 B0

    I cancel it from that file and now it work.

    But i still having the same issue than the fan output, i mean the led in the FOTEK solid state relay that i connected to this output, is turning on and off with the M42 P6 S1 and M42 P6 S0 commands, but the contact stayed closed when i turn it off.

    That's why i decide to use the heater 6 outputs thinking that the problems was the fan output

    Thanks



  • Is it possible that the trigger current at heater pin 6 is too small?
    http://www.fotek.com.hk/solid/SSR-1.htm

    Could you try switching the relay on and off with the heatbed output just to test if the relay works?


  • administrators

    @jv, what model of Fotek SSR is it?



  • @dc42
    Fotek SSR10DA-H


  • administrators

    @jv said in duet2 ethernet expansion board heater 6:

    @dc42
    Fotek SSR10DA-H

    Should be OK if you don't run too much current through it, that's the model I use to run my 240V 350W bed heater. However, many Fotek SSRs are fakes, typically using a lower rated triac than they should. When SSRs fail, they tend to go short-circuit. If the LED on the SSR is off, the triac should be off too.



  • @dc42
    Thanks guys for your help, i did change it with an Elco relay and it still not working...
    There is any diference between fan1 output and heater 6 output for this application?
    Thanks



  • Hi Guys, i found the problem.

    The Fotek SSR10DA-H relay works with a load in AC voltage and i was working with 24VDC voltage load and it doesn't has zero crossing.
    I use the SSR88D-360 from ELCO company and it works very fine.
    Completely solved.
    Thank you so much


Log in to reply