Motors not moving



  • My printer is a sunhokey prusa i3 and had a ramps 1.4 board. I now have a Duet Maestro. I have setup firmware config via the online configurator. I believe the board is wired correctly. All lights appear to be on. I have checked the motors are configured. I can't remember exactly what I did but they all got 800w.
    I do get an error though when doing the "initial test". It says 11.6v is lower than expected or something like that. I'm at work right now so can't remember the exact error message. I can manually move the z motor but the X and y do not respond and it says the axis haven't been homed. If I press home all it does nothing.
    I tried the motor test under initial test and the z axis went all the way down and slammed into the bed and wouldn't stop. I think that's because the z stop switch got pushed down because it was moving so fast. Anyway the issue is that the X and Y motors aren't responding.



  • Motors won't move until their axis is homed unless you override it with https://duet3d.dozuki.com/Wiki/Gcode#Section_M564_Limit_axes

    I'd suggest you get to the bottom of why you have Z but not X and Y homed though. For which you should share your config.g and homeall.g files and someone will probably be able to help you.





  • @bearer I figured out the end stop switches were wrong thanks to @Phaedrux . The motors still aren't moving properly. They kind of move, but very slowly and but as far as I request them too. I copied the steps per mm from my old marlin config. Below is the config file from my duet maestro.

    ; Configuration file for Duet Maestro (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sun Jun 30 2019 17:49:29 GMT+1000 (Australian Eastern Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"Benji" ; Set machine name
    M552 P192.168.1.20 S1 ; Enable network and set IP address
    M553 P255.255.255.0 ; Set netmask
    M554 P192.168.1.1 ; Set gateway
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Physical drive 0 goes forwards
    M569 P1 S1 ; Physical drive 1 goes forwards
    M569 P2 S1 ; Physical drive 2 goes forwards
    M569 P3 S1 ; Physical drive 3 goes forwards
    M350 X256 Y256 Z256 I0 ; Configure microstepping without interpolation
    M350 E16 I1 ; Configure microstepping with interpolation
    M92 X80.5 Y80.5 Z405.6 E644.81 ; Set steps per mm
    M566 X80?5 Y80.5 Z405.6 E644.81

              ; Set maximum instantaneous speed changes (mm/min)
    

    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; Set accelerations (mm/s^2)
    M906 X800.00 Y800.00 Z800.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X200 Y200 Z180 S0 ; Set axis maxima

    ; Endstops
    M574 X0 Y0 Z0 S0 ; Set active high endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X15:150 Y15:150 S20 ; Define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M307 H0 A594.9 C285.1 D2.7 V11.2 B0 ; parameters set by me from PID autotune.
    M305 P0 T100000 B4138 R2200 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S90 ; Set temperature limit for heater 0 to 90C
    M305 P1 T100000 B4138 R2200 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S190 ; Set temperature limit for heater 1 to 190C

    ; Fans
    M106 P0 S0 I0 F500 H T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings
    M918


    Homeall.g

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sun Jun 30 2019 17:49:29 GMT+1000 (Australian Eastern Standard Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 X-205 Y-205 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y5 F6000 ; go back a few mm
    G1 S1 X-205 Y-205 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G1 S1 Z-185 F1800 ; move Z down stopping at the endstop
    G90 ; absolute positioning
    G92 Z0 ; set Z to axis minimum (you may want to adjust this)

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning



  • @benji said in Motors not moving:

    M566 X80?5 Y80.5 Z405.6 E644.81

    could be the ? in there is tripping your config up?

    (edit: incidentally if you run M98 Pconfig.g in the g-code console it'll run through the config and maybe give you some indications of errors)



  • @bearer yes that is a silly error which I only just added. I corrected it but still it didn't fix anything. I tried. I just noticed that if I press home all the X starts moving towards the switch very slowly and stops before it gets there and then moves towards the y switch very slowly and stops. Each time I get the error "G0/G1 insufficient axes homed"



  • you'll get "G0/G1 insufficient axes homed" as long as you don't hit the endstop with a G0/G1 command that has a S1 or S3 flag set, or use G92 to set the axis to 0, or allow the override with M564.

    do but if you have copied your steps/mm from Marlin, and set the duet to use 256 microsteps, then that'll explain slow speed and short moves. either multiply your steps/mm by 16 or reduce the microstepping to 16 with interpolation to 256?



  • you should use the x16 with interpolation for all axis unless there is a very specific reason not to.
    running at x256 will put an unnecessary load on the cpu that could in some cases cause problems while printing.



  • @bearer ok thanks. That might help. I'll try that tomorrow.



  • @veti is that microstepping though? It's one of the main reasons I went with this board. I just don't know much about it though



  • Yes, hes saying that you should keep the steps/mm as is and reduce the microstepping to 16, and let the driver handle the interpolation to 256 microsteps.



  • Ok, thanks all. Hopefully this works. Then I'll move on to the next issues.



  • @bearer ok. So multiplying all steps by 16 worked. Except the extruder went ridiculously fast so I put that one back to what I had it.
    Now I have two other issues. Or three really but only two are important.
    1.) I can't get the hotend to start under active mode. Only standby mode.
    2.) The hotend fan never starts
    3.) I have a 12864 LCD that never comes on.

    I believe it's all wired correctly.



  • @benji said in Motors not moving:

    So multiplying all steps by 16 worked.

    So you're still using 256 microstepping? That's going to lead to issues down the line.

    I'm not sure what you mean about the hotend in active/standby mode. Can you describe what you're trying to do?

    For the fan, how do you have the hotend fan connected? The hotend fan should be connected to fan port 1.

    I just noticed a problem with your config for fan0.

    ; Fans
    M106 P0 S0 I0 F500 H T45
    

    The last bit should be H-1 and no T45 so that it is controlled by the slicer for part cooling.

    How do you have the 12864 display wired up? What type/brand of display is it?


  • administrators

    @benji said in Motors not moving:

    3.) I have a 12864 LCD that never comes on.

    Have you seen https://duet3d.dozuki.com/Wiki/Duet_2_Maestro_12864_display_menu_system ? In particular, the bit about using M918 P1 in config.g to enable the display.



  • @benji said in Motors not moving:

    ; Custom settings
    M918

    Looks like you're just missing the P1



  • @benji said in Motors not moving:

    Except the extruder went ridiculously fast so I put that one back to what I had it.

    My bad, as you had the config for 256 microsteps for xyz and 16 for the extruder I asumed it was deliberately and for a purpose; and as such would understand the steps only needed changing for xyz.

    But if you don't have a reason for using 256 microsteps I would suggest you go the other way and change all the microsteps to 16 and let the driver handle the interpolation to 256 like you had it for the extruder (and divide the xyz steps by 16 again).



  • @bearer do you mean that if i set to 16 i will still get 256 microstepping somehow?



  • @phaedrux i did have the P1 originally which did enable it.
    Then i'd follow up with M918 and it would say its enabled and working but the lcd doesnt light up.



  • @dc42 yes i tried that. it says its enable but nothing comes up on the screen.
    I tried plugging into the paneldue one and the screen at least lights up but nothing on the screen.
    I have copied the /menu folder contents to the right place


Log in to reply