Trigger Height and a lot of confusions



  • Hello everybody,
    I'll go crazy....

    i have a delta printer with haydn magball arms, ethernet and a smarteffector.

    ii set the trigger height exactly as it is described in the wiki.

    It does not work: /

    after a change of the carriage adapters I do not get it back ... before it worked.
    I exclude the adapter. that's not it.

    When I restart the printer (with saved height as from the wiki) I do a g28, g32.
    then I drive to Z0 and he rams me into bed.
    A G30 s-1 tells me "stopped at 0.7"

    Where is my thought error?

    My Configs are in my Pastebin:
    https://pastebin.com/u/NealzE



  • This post is deleted!


  • I assume you're talking about this process?

    https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe#Section_Calibrate_the_Z_probe_trigger_height

    The response logged in the console when doing G30 S-1 should be correct if you're following those procedures.



  • @phaedrux should it be stopped @ 0?



  • Well not necessarily. It should stop at the trigger height.

    For nozzle contact probes that would be at 0 or slightly negative as it presses into the bed a bit. For proves that have a switch of some kind mounted above and to the side of the nozzle it would be some positive value.



  • @phaedrux BUT when i drive to z=0 after g32 i should above the bed?
    That isnt working
    It drives IN the bed 😕



  • state: 
    
    M665 R225.5 L450 B185 H410.500	
    
    M558 P8 R0.4 H5 F1200 T6000
    G31 P100 X0 Y0 Z0  
    
    Nozzle 210° 
    Bed 60°
    
    • Make sure the dynamic test is successful (Z probe stops when it senses the bed) before doing this.
      -> Done. works. Bed stopped after g30

    • Use the X and Y jog buttons to position the nozzle over the centre of the bed
      -> Done x0 Y0

    • Jog the nozzle down until it is just touching the bed or just gripping a sheet of paper. If the firmware doesn't let you jog it down far enough, send M564 S0 to disable axis limits.
      -> paper scratched @ Z 1.84

    • Once you have the nozzle touching the bed, send command G92 Z0 to tell the firmware that the head is at Z=0
      -> Done ... Z=0

    • Jog the head up by 5 to 10mm
      -> Done M120
      G91
      G1 Z5 F6000
      M121

    • Send command G30 S-1. The nozzle will descend or the bed rise until the probe triggers and the Z height at which the probe stopped will be reported.
      -> G30 S-1
      Stopped at height -0.029 mm
      Z=-0.03

    • Repeat from step 5 two or three times to make sure that the trigger height is consistent.
      -> -0.022 -0.029 -0.022 -0.029

    • In Duet Web Control, go to Settings -> System Editor and edit the config.g file. Set the Z parameter in the G31 command to the trigger height that was reported. Save the file.
      -> G31 P100 X0 Y0 Z-0.025
      saved

    • Open config-override.g and check that there are no G31 commands in it. If you find any, delete those lines and save the file.
      -> done . Only PID tuning Stuff in the override

    • To apply the new trigger height, restart the Duet by sending M999 or pressing Emergency Stop.
      -> Restarted

    After All:

    • G32 (look at pastebin)

    • After that it stops at Z=5

    • when i drive to Z=0 or start the print ---- the nozzle crashes in the bed.

    G30 S-1 Stopped at height 0.797 mm

    So annoying ... whats my mistake?



  • After all:
    When i do a G30 i got the correct height ....
    Why does the g32 (bed.g) does not this?



  • i realized that there are not compensation in use.... this is exactly what the g32 should to right?

    0_1562701395242_2579ec22-b9f8-4138-9bb3-34d0397f2d55-grafik.png



  • @niels g32 will only run the commands in bed.g

    Do enable the compensation there must be a g29 S1 at some point to load the saved heightmap or G29 to run a probing cycle.

    Usually best put in the slicer start gcode. Or at the end of bed.g which ever makes best sense.



  • Yes. i know ..

    in my bed.g i do alot of g30 and the last one with s6.

    --> fail

    when i do a single s30.. it sets the height correctly....

    this is what i didnt understand



  • 0_1562702914129_00dab473-1984-425d-911a-cd644c349ead-grafik.png



  • Being that this is on a delta all I can recommend is to recheck your calibration routine. Not my area of expertise unfortunately.


  • administrators

    Try running G32 twice after power up before you drive to Z=0. If the M665 parameters in config.g are a long way from the true values, then there can still be a height error after running G32 once. This is especially true in firmware 2.03, and there will be a 2.03.1 release to fix this.


Log in to reply