My delta forgot how to delta - 4th axis



  • I trying to change my delta configuration to add a flying extruder 4th axis located at (0, 0). After changing what I believe is necessary, with the wiki as a guide, I get console messages notifying that "Homing file homeu.g not found". I understand homing the U=axis should be included in homedelta.g. Futhermore, the U-axis never does not follow the head as expected (remain homed).

    What am I doing wrong?

    config.g

    ; Configuration file for Deltex
    
    ; ===================== GENERAL SETTINGS =====================
    M111 S0                             							; Debug off
    M550 PDeltex										; Machine name and Netbios name (can be anything you like)
    M555 P2                                   						; Repetier Output
    M575 P1 B57600 S1                          						; PanelDue Comm Setup
    M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xEA 							; MAC Address
    M552 S1											; Enable WiFi
    M586 P1 S0										; Disable FTP
    M586 P2 S0										; Disable Telnet
    
    ; ===================== MOVEMENT SETTINGS ====================
    G21                                 							; Set Units to Millimeters
    G90                            								; Set to Absolute Positioning
    M83                                	 						; Set extruder to relative mode
    
    M584 X0 Y1 Z2 U4 E3									; Assign drives to each motor
    M569 P0 S0										; Drive 0 (X) goes backwards
    M569 P1 S0										; Drive 1 (Y) goes backwards
    M569 P2 S0										; Drive 2 (Z) goes backwards
    M569 P3 S0										; Drive 3 (E) goes backwards
    M569 P4 S1										; Drive 4 (4th) goes backwards
    M574 X2 Y2 Z2 U2 S1									; Endstop configuration (all endstops at high end, active high)
    M665 L500:500:500:272 R218.226 H634.072 B130.0 X0.151 Y0.120 Z0.000			; Diagonal rod length, delta radius, printable radius and homed height
    M669 K3 X0 Y0										; Location of the 4th axis tower
    M666 X1.697 Y2.831 Z-4.528 A0.00 B0.00							; Endstop adjustments
    M350 X16 Y16 Z16 E16 U16 I1    								; Set 16x microstepping with interpolation
    M92 X200 Y200 Z200 U80 E414								; Set steps/mm
    M906 X2100 Y2100 Z2100 U600 E700 I45							; Set motor currents (mA) and increase idle current to 45%
    M201 X1200 Y1200 Z1200 E1200 E5000							; Accelerations (mm/s^2)
    M203 X10000 Y10000 Z10000 U10000 E20000							; Maximum speeds (mm/min)
    M566 X400 Y400 Z400 U400 E2000 P1							; Maximum instant speed changes (mm/min)
    
    ; ================ HEATING AND COOLING SETTINGS ==============
    ; Thermistors
    ;M305 P0 B4725 C7.060000e-8								; Bed temperature sensor parameters
    M305 P0 B3950										; Bed temperature sensor parameters
    M305 P1 B4725 C7.060000e-8								; Hotend temperature sensor parameters 
    M570 S180										; Configure heater fault detection, allow it 180 seconds
    M307 H0 A633.5 C317.1 D3.7 S1.00 V24.2 B0 F10						; Set bed heating process parameters and use PID at 10Hz
    M307 H1 A520.7 C251.5 D5.2 S1.00 V24.2 B0						; Set hotend heating process parameters and use PID
    
    M143 H0 S200										; Set maximum bed temperature to 200
    
    ; Fans
    M106 P0 H-1 										; disable thermostatic mode for fan 0 (part cooling)
    M106 P1 S255 T45 H1									; enable thermostatic mode for fan 1 (hotend)
    ;M106 P2 T35:65 H100:101:102								; enable thermostatic mode for fan 2 (system)
    
    ; ====================== TOOL SETTINGS =======================
    M563 P0 D0 H1 S"Hotend"              							; Define hotend
    G10 P0 S0 R0                        							; Set tool 0 operating and standby temperatures
    M207 S0	R0 F3000 T1200 Z0								; Set default retraction settings
    
    ; =================== CALIBRATION SETTINGS ===================
    M558 P5 A5 S0.03 X0 Y0 Z0 H2 F250 T10000						; Z probe is a switch, tap max 5 times with 0.03 mm tolerance, move 2mm above the bed at 250 mm/min and travel at 10000 mm/min
    G31 X0 Y0 Z-0.23 P10  		        						; Set the zprobe height and threshold (more negative values translate into a higher nozzle)
    M557 R120 S15										; Define probing mesh grid
    
    
    M912 P0 S-12.35										; Set temperature offset for MCU
    T0											; Select hot end
    M501											; Load settings from config-override.g
    

    homedelta.g

    ; Homing file for Deltex
    G91					; use relative positioning
    G1 S1 X1000 Y1000 Z1000 U1000 F4000	; move all carriages up 700mm, stopping at the endstops
    G1 S2 X-3 Y-3 Z-3 U-3			; move all carriages down 3mm
    G1 S1 X6 Y6 Z6 U6 F250			; move carriages slowly up 6mm, stopping at the endstops
    G1 Z-5 F2000				; down a few mm so that we can centre the head
    G90					; back to absolute positioning
    G1 X0 Y0 F2000				; centre the head and set a reasonable feed rate


  • @nxt-1 said in My delta forgot how to delta:

    homeu.g

    Tried creating an empty homeu.g?



  • AFAIK homeu.g would (normally) only be called if homeall.g didn't either sucessfully hit an endstop with G1 S1 Unn (or S3?) or a G92 Unn command was encountered.



  • @bondus said in My delta forgot how to delta:

    @nxt-1 said in My delta forgot how to delta:

    homeu.g

    Tried creating an empty homeu.g?

    That eliminated the error, but not it's cause I believe. AFAIK the firmware should not even be looking for a homeu.g

    @bearer said in My delta forgot how to delta:

    AFAIK homeu.g would (normally) only be called if homeall.g didn't either sucessfully hit an endstop with G1 S1 Unn (or S3?) or a G92 Unn command was encountered.

    In delta config's, there is no homeall.g, only a homedelta.g. During home the U-endstop is correctly triggered.



  • Adding G92 U0 (or U what-ever-the-correct-value-is) after the G1 might be worth a try to see if it still wants to call homeu.g



  • @bearer said in My delta forgot how to delta:

    Adding G92 U0 (or U what-ever-the-correct-value-is) after the G1 might be worth a try to see if it still wants to call homeu.g

    I cannot manually set the position with G92 as the position changes after each auto-calibration run and is thus not known 'at compile time' for the home file.



  • Even 0 or an approximate value will allow you to test if the problem is the firmware not thinking the U axis is homed by the end of homeall.g/homedelta.g. Sounds like there is either a config issue or a firmware bug.



  • Is there anything odd in your config-override.g?


  • administrators

    Which firmware version are you running? You need 2.03 or 3.0 beta to support additional delta axes.



  • @blt3dp said in My delta forgot how to delta - 4th axis:

    Is there anything odd in your config-override.g?

    I feel embarrassed now, I forgot there's an M665 in there, doh. Stuff works as expected now.