Motors “bang” at power up during home (x/y)



  • When I home x and y, they power up and slam into motion. my Motors for x and y are set around 70% current. Kysan 1.8 degree 1.5amp nema 17.

    Any clue to why they would jerk so hard while powering up when start to home?

    Seems to work fine during printing. No binding on the rails. Jerk and accelerations are pretty tame.



  • I think a certain amount of "bang" is normal for when the stepper motor is powered up and the rotor aligns to the magnet field the first time. if you want to avoid it maybe look into if you can have the motor position itself on a full step before powering down, or to reduce the motor current as part of the homing, increasing it after the motor is energized?



  • @bearer said in Motors “bang” at power up during home (x/y):

    ...maybe look into if you can have the motor position itself on a full step before powering down

    How would you do that?

    Would be useful also to eliminate the buzzing sound in standby mode.



  • @cts5191 Post your homing files so that we can see what's amiss.



  • @zapta presumably by trying to set microstepping to 1 at the end of a print or something? I haven't got a plan for how, its just an explanation of why it may happen, how to fix it is left as an exercise to the reader sort of speak.

    Stand by buzzing can be tuned in the drivers chopper settings i think, but mine went away when I increased the supply voltage so I never did any more research into that.



  • What kind of hardware is it? Quite possible large screws will "bang" more than a belt drive as well. I've only ever noticed this on my cnc router, and after replacing the Gecko G540 with a Duet its a lot less pronounced, but the current is also lower while waiting to get a new power supply. The biggest difference I would think is relatively large ballscrews vs belts.



  • If you simply don't like the noise/bang then you could lower the steppers current for the homing process...

    Add...

    M400 ; wait for moves to finish
    M913 X50 Y50 ; lower XY stepper current to 50%

    to the top of your homing gcode. And add to the end...

    M400 ; wait for moves to finish
    M913 X100 Y100 ; get back to 100% current

    To get 100% of your desired current again.



  • Motors “bang” at power up...

    A shot in the dark, did you get them from Banggood?


  • administrators

    You could also try increasing the current gradually in your homeall.g file:

    M913 X20 Y20 Z20 ; set 20% current
    G91 ; relative mode
    G1 S2 X0.1 Y0.1 X0.1 ; move the motors a tiny amount to energise them
    G4 P100 ; wait 100ms
    M913 X100 Y100 Z100 ; restore normal current
    ; rest of homeall.g follows...



  • @zapta said in Motors “bang” at power up during home (x/y):

    Motors “bang” at power up...

    A shot in the dark, did you get them from Banggood?

    Doh...


Log in to reply