New board, can't connect (failed to retrieve network list)



  • Hello!

    I am just configuring my brand new Duet2 wifi board but i am facing a problem setting up the wifi connection to my home network.

    I have it setup for an automatic DHCP (default) I have the wifi module started (reporting "Wifi module is idle"). After looking a bit on the forum i tried the following:

    Updating firmware to (and DuetWifiServer as well):

    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.03 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2019-06-13b2
    

    Tried to connect manually with M587 S"" P"":

    M587: Failed to add SSID to remembered list
    Error retrieving WiFi status message: bad reply format version
    [ERROR] Error retrieving WiFi status message: bad reply format version
    

    M587 returns:

    M587: Failed to retrieve network list
    

    Am i doing something wrong?

    Thanks in advance!



  • Do you know what version of Wifi server you're running? Perhaps it's mismatched to the main firmware. For 2.03 it should be 1.23.



  • Seems to be fixed. Not sure which specific step i did made it work, after a bunch of restarts i re-create the config from the configurator tool, then i edited the SetNetwork macro, commented the M552 S1 from the config and run the macro instead..

    Time to explore the rest!



  • @phaedrux Thanks for the quick reply! i used the Wifi server from the same release as the firmware so i guess it was ok. After a few tries it seems to work now 🙂


Log in to reply