Duet 2 maestro problems



  • This is on an ender 3 pro with a titan aero that I installed before I wired the board. I changed connectors and was very careful.

    Loaded the config files and fired it up and had a menu error.

    I finally connected with yat and updated firmware and then connect with web control. Now the screen is blank and I'm getting ground short errors. Y axis seemed to home and wont move anymore. X wants to go left instead of right and is making an awful noise. Z will not do anything.

    BLtouch probe flashes red.

    Ready to chunk it all



  • need more info, ref https://forum.duet3d.com/topic/5909/guide-for-posting-requests-for-help/1

    @humanxv2 said in Duet 2 maestro problems:

    X wants to go left instead of right and is making an awful noise.

    sounds like only one phase is working, double check wiring. possibly related to ground short error. reverse motor direction in config.g or swap pins 1 <--> 3 and 2<--> 4 on the connector to make it move in the correct direction.



  • Ok X had one if the wires come lose inside the connector so it is acting fine now and homing.

    Still having ground fault on Z. Z will not move at all.

    Tried several different menu files and nothing will display. Just a blue screen. Yesterday before firmware update screen showed a fault in line 3.

    I have to change the config for the titan aero because it is showing a heater fault.



  • Seeing the thread is started I am having a duet maestro problem with the motors
    the motors jerk back and forth but no real movement, the only one that will move is the Y and that jerks a lot before it starts to move and after it hits the home switch it must be jerking when it is trying to back off I had the current set to 800ma now at 400ma its still not right
    I checked my duet wifi and they are set at 1800ma on a delta and working good for over a year.

    I am including my config if anyone can see anything wrong I am also trying to set it for 2 z motors... home switches and probe are triggering ok temp for bed and hot end seem ok
    just motor problems, I know there wired right I had them running on a X5 Mini board..

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Jul 02 2019 13:29:03 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"mycartiesan" ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Physical drive 0 goes forwards
    M569 P1 S0 ; Physical drive 1 goes forwards
    M569 P2 S0 ; Physical drive 2 goes forwards
    M569 P3 S0 ; Physical drive 3 goes forwards
    M569 P4 S1 ; Physical drive 3 goes forwards
    M350 X32 Y32 Z32 E32 I0 ; Configure microstepping without interpolation
    M92 X200.00 Y200.00 Z200.00 E420.00 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X3000.00 Y3000.00 Z180.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; Set accelerations (mm/s^2)
    M906 X400.00 Y400.00 Z400.00 E400.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M564 H0
    M84 S30 ; Set idle timeout

    ;Dual Z
    M584 X0 Y1 Z2:4 E3 ; two Z motors connected to driver outputs Z and E1
    M671 X-20:330 Y0:0 S0.5 ; leadscrews at left and right of X axis
    M208 X-5:325 Y0:325 ; X carriage moves from -5 to 205, Y bed goes from 0 to 200
    ;

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X330 Y330 Z330 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S1 ; Set active high endstops

    ; Z-Probe
    M558 P5 I1 R0.4 H5 F1200 T6000 ; Set Z probe type to effector and the dive height + speeds
    G31 P500 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X15:300 Y15:300 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T97700 B3950 R2200 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.060000e-8 R2200 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H1 T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    thanks gary



  • @gorf26 Please start your own thread. It becomes very difficult to try and help multiple people in the same thread.



  • There is a very detailed guide in the documentation in multible parts.

    https://duet3d.dozuki.com/Guide/Ender+3+Pro+and+Duet+Maestro+Guide+Part+1:+Wiring/37

    recheck the phase of the motor that you have indeed wired it correctly.
    i would suggest to get a new wire. the standard wires are all black and make it difficult to match the phase.



  • Wiring has been checked. I tried it with another motor and it still does it. It doesn't do it with the wire unplugged.

    It had a new wire since the z axis cable got lost during the process and I even made a new one just in case. I'm gonna take the wire off of x and use it for a and see if it works.

    And I still have to contend with the screen and the heat fault.

    Thanks



  • if that does not work see if it works with another driver.

    remap z to e1 using M584
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M584_Set_drive_mapping



  • Whenever I swap wires whatever ends up with the all black OEM cable works fine. The new wires are color coded and the connector that plugs into the motor is the same and wires are in the same slots. I cut the old board side connectors off and crimped new pins for the correct connectors. I have tried 2 new cables on it.

    This is maddening



  • did you check the wires with a multimeter?



  • @phaedrux

    will do sorry



  • Have tried 3 cables now. Checked with meter. If I power up with nothing plugged in I get no errors. If I plug the cable in and don't plug it into motor it gets errors so it points to being the cable but I cannot find anything wrong.

    Even after i figure this part out i still have a heat fault and a screen that doesn't work. Pretty close to throwing it in the trash since it's been nothing but problems.



  • Ok so it makes no sense but I read the reviews of the cables I got and one guy said he had to swap the green and red wires so i did that and it worked. Now the errors are gone with the motors but now z will not home. I don't have the z stop hooked up since I'm using a bltouch and I have to touch the probe to get the motor to stop.



  • @humanxv2 said in Duet 2 maestro problems:

    now z will not home. I don't have the z stop hooked up since I'm using a bltouch and I have to touch the probe to get the motor to stop.

    ?

    Homing is achieved by moving until it hits a endstop, and setting the axis to a known value. The homing is moving until it trips the endstop or probe. So you need to let the motor run until the probe touches the bed, or add a end stop.



  • @bearer said in Duet 2 maestro problems:

    @humanxv2 said in Duet 2 maestro problems:

    now z will not home. I don't have the z stop hooked up since I'm using a bltouch and I have to touch the probe to get the motor to stop.

    ?

    Homing is achieved by moving until it hits a endstop, and setting the axis to a known value. The homing is moving until it trips the endstop or probe. So you need to let the motor run until the probe touches the bed, or add a end stop.

    Well the bed is all the back at home so there's it's not there for the probe to touch.



  • I moved the switch for y so that it's there for the probe to touch



  • @humanxv2 said in Duet 2 maestro problems:

    Well the bed is all the back at home so there's it's not there for the probe to touch.

    well move the bed then.



  • Got everything working. Started a print the other day and I noticed that when it got the the upper layers it was printing in midair and not laying down filament.

    I pulled the nozzle and it was clogged so I unclogged it and put it back on and now the heat is faulting out saying the heat is rising too slow. I switched the motor and heats from e0 to e1 and the heat is still faulting.



  • Would suggest something changed with respect to wiring or the thermal response in your hotend. Check the wiring and retune the heater.



  • The heat block was a tad bit loose so I removed the heater cartridge and thermistor to tighten it a little and put them back. I can't tighten it real tight cause the angle the wires end up at, they run into the cooling ducts.

    The thermistor reads the temp correctly when plugged into e0 but read 2000c when plugged into e1.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.