SOLVED motor phase A may be disconnected reported by driver(s) 1



  • @dc42
    My printer has been working fine for a few weeks now. All of a sudden (because stuff always happens suddenly) my Y-axis is making a horrible noise and I'm getting this warning---motor phase A may be disconnected reported by driver(s) 1

    I checked the wiring and connections. All good. Is this a bad stepper? Hope this is still under warrantee because this is the second board Filistruder has sent me. The first one had a bad EO stepper. I'm starting to have buyers remorse.


  • Moderator

    Can you test a different motor on the same driver, and the same motor on a seperate driver to isolate the issue?



  • @phaedrux already tried a couple of different motors. Not sure how to use the extra extruder stepper for the Y-Axis.


  • Moderator

    You'd have to modify the drive mapping command in your config.g

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M584_Set_drive_mapping



  • @phaedrux I looked at that. Not sure what stepper motor number to put for Y is it just YE1 ?


  • Moderator

    Can you post what your current config looks like? Then we can go from there.



  • @phaedrux M586 P1 S0 ; Disable FTP

    ; Drives
    M569 P0 S0 ; Physical drive 0 goes backwards
    M569 P1 S0 ; Physical drive 1 goes backwards
    M569 P2 S1 ; Physical drive 2 goes forwards
    M569 P3 S1 ; Physical drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E415.00 ; Set steps per mm
    M566 X600.00 Y600.00 Z60.00 E300.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X9000.00 Y9000.00 Z600.00 E6000.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z120.00 E5000.00 ; Set accelerations (mm/s^2)
    M906 X700.00 Y800.00 Z800.00 E500.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X235 Y235 Z250 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F120 T6000 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P500 X-28 Y5 Z0.80 ; Set Z probe trigger value, offset and trigger height
    M557 X10:220 Y25:220 S65 ; Define mesh grid

    ; Heaters
    M305 P0 T98801 B4185 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T98801 B4185 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F20 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0 I0 F20 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S0 I0 F20 H1:0 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 S"Hotend" D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S21 R23 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory
    T0 ; Select first tool


  • Moderator

    It looks like you've cut off the top of your config.g that has the M584 command


  • Moderator

    Also, what board do you have?



  • @phaedrux
    Duet2Wifi.
    There is no M584 command. Everything above that is for wifi network.
    That's what the RepRap configurator gave me.


  • Moderator

    Alright, then it's going to be the default.

    On the wiring diagram you can see the drivers listed along the top along with what axis they are associated with by default.

    Drivers

    So if it's your Y driver that is giving issues, and we want to connect the Y motor to the unused E axis driver, we'd need to tell the firmware a new association with M584.

    M584 must come before several other commands, so it would be best to add this line near the top.

    M584 X0 Y4 Z2 E3

    This has X on driver 0, Y on driver 4, Z on driver 2, and the extruder on driver 3. You'd then switch the Y plug to the E1/Driver 4 plug.

    I think that should work.



  • @phaedrux
    Hmm same issue. The motor gets jerky and the Y fails to home.


  • Moderator

    So there may be a problem with the motor itself.

    Does it still produce the same motor phase error?

    Are you sure the motor phases are wired correctly?


  • Moderator

    I'm guess this is a cartesian printer?
    Does the bed move freely and smoothly by hand with the belt detached from the motor?

    What are the specs of the motor?
    Is 800ma enough current for it?
    Do you have another motor to test with?



  • @phaedrux
    Yea all the same issues. But it's acting like a bad connection. I'm thinking there has to be bad wire somewhere even though all the connections look good. I'll deal with it tomorrow.


  • Moderator

    Yeah a bad wire could fit the description. A continuity tester / multimeter may be helpful. Redoing the crimps/replacing the wire hopefully helps. Hopefully the issue isn't in the motor. But at least it doesn't seem like the issue is on the board.



  • @phaedrux
    I hope its not the board. I really like the Duet2Wifi. I just don't have the tools here so I'll have to look at it again tomorrow. Tried 3 different LDO motors that I know work and it's all the same, so I'm thinking a bad wire somewhere since it did the same thing on the E1 driver.



  • You could also try swapping the cable with one of the others (if possible) to see if the fault also moves.



  • Be careful about swapping cables. If you do have an intermittent connection, you may kill the motor driver. It's best to test the cables off the board- use a meter and move the cable as you read the resistance- it should remain constant. Visually inspect the connector(s) to make sure that all looks right there.



  • @mrehorstdmd said in motor phase A may be disconnected reported by driver(s) 1:

    Be careful about swapping cables. If you do have an intermittent connection, you may kill the motor driver. It's best to test the cables off the board- use a meter and move the cable as you read the resistance- it should remain constant. Visually inspect the connector(s) to make sure that all looks right there.

    That's a good point. I would remake or replace the cable completely just to be sure. Intermittent faults, by their nature can be hard to track down especially if you have no test equipment (DVM etc).



  • @keith
    @dc42

    What version of the reprap firmware are you running? I am / was having the same "phase A" problem you have, but on the extruder stepper drive(s). Replaced the cabling and stepper motor with known good units and tried both E0 & E1 stepper drivers on my DuetWiFi board.

    I made the mistake of doing multiple simultaneous upgrades to my delta printer without incrementally testing the changes. While I was waiting on a Zesty Nimble extruder I tore down my delta printer and upgraded the firmware on the DuetWiFi from version 1.19.2 to version 2.03 (also tried 2.04RC1) and on the PanelDue from version 1.17 to version 1.22.1 while I was waiting. Now I get / got the same "phase A" error with both sets of wiring, stepper motors or stepper drivers.

    Managed to downgrade the firmware on the DuetWifi to 1.21 with some difficulty(?)

    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 1.21 (2018-03-21)
    WiFi Server Version: 1.23
    Web Interface Version: 1.21

    Completed more testing and with version 1.21 I do not get "phase A" errors on either E0(Drive 3) or E1(Drive 4) stepper drivers with previously good Titan Aero wiring & motor. Re-tested again with the wiring and stepper motor I ordered to go with the Zesty nimble and again there are no "phase A" errors, even driving the extruder to the point where it starts chewing the filament. (The Zesty Nimble has a fixed drive "tension".)

    At this point (at least to me,) the problem seems to reside in the version 2.0+ firmware. Which is a shame as Christian Hammacher's new Duet web control 2 interface which works with it is really nice. I haven't been able to run it with RepRapFirmware version 1.21.


  • administrators

    Please post a link to the specification for your stepper motors you were using when you had the warning messages, and tell us what motor current you had set.

    The "motor open circuit" warning is new in recent firmware versions. We are aware that it is unreliable in some situations, which is why it is disabled at low motor current settings.



  • @dc42

    I had the same problem with the e3d stepper motor supplied with my Titan Aero (Genuine) extruder and the stepper motor I ordered to use with the new Zesty Nimble.

    Titan Aero supplied stepper motor - P/N MT1703HSM168RE Current set to 1000ma.

    Ordered for the Zesty Nimble:
    Stepperonline - P/N 70HS10-0704S Current (set to various values) up to 700ma. "phase A" errors at all values.

    0_1567974400991_Stepper-Motor_MT1703HSM168RE.pdf
    0_1567974463817_StepperMotor_70HS10-0704S.pdf

    (Made many successful prints with the Titan Aero on RRF version 1.19.2 before starting the updates.)



  • @dc42
    NEMA 17.
    1.8° Step Angle.
    200 Steps Per Revolution.
    1A Phase.
    0.48Nm Holding Torque.
    40mm Body.
    19mm Output Shaft (5mm diameter)
    750mm wire lead with Molex connector

    Motor current set to .8 amp.

    I think I have it sorted out. One of the wires in the cable has a short. I cut the connectors off and checked the wires without any connectors which is surprising considering the Y axis motor and motor wires never move. I might expect a wire to wear down on something like the direct drive motor over time but not the Y axis. Seems to be working now with a new cable. What Molex connectors are these? I want to order some backup connectors.


  • Moderator


Log in to reply