SOLVED Heater showing 2000



  • OK so I know this has been asked many times before. I have looked through the posts and have not found one that answers my issue.

    Everything is connected properly, there is no shorts or lose wires.

    My extruder heater shows 2000. As a test, I unplugged my bed thermistor (which is showing the correct temperature) and plugged it in to my extruder thermistor and it also shows 2000, which I believe confirms that it is definitely not the wiring. Can someone please help?



  • @Elliot if it's a thermocouple it could be a shortage to the heater block: https://forum.duet3d.com/topic/6272/thermocouple-faults-to-2000
    You can check resistance between thermistor and heat block and check whether cabling is ok.

    To help better, additional information is helpful: where did you connect, what type of thermistor do you use, image of thermistor and connection to the board, Duet board version and configuration file.



    1. When you tested with the bed sensor; what happens when you switch it back; does the bed now show the correct temp again?
    2. As JoergS5 says; to help you we need to see the type of both sensors; and to know if they are both thermistors, etc.
    3. Are the M305 P0 & M305 P1 settings from your config the same? Please share these here.

    With thermistors a reading of 2000 normally means a disconnected sensor; open circuit.

    I once saw something identical (but with the bed sensor).

    • In my case it was a RTFM confusion; I was plugging the thermistor into a fan circuit, not into the bed sensor.. This destroyed the sensor; I got through a couple of them before finding my face with my palm.


  • @JoergS5 @EasyTarget I am not by my printer at the moment, but as soon as I am I will post pictures of both the board and thermistors.

    They are both stock ender 3 wires that I plugged into the corresponding places on the Duet.

    When I unplugged the bed thermister from the extruder slot and put it back in its right place, the beds temp was correct.

    Here is my config file. I have also tried plugging the extruder into e1 instead of e0, and changed the config file to M305 P2 instead of P1.

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu Sep 06 2018 21:21:12 GMT-0700 (Pacific Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 Pe3 ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400 E95 ; Set steps per mm
    M566 X1000 Y1000 Z100 E30000 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z500 E1500 ; Set maximum speeds (mm/min)

    M201 X300 Y300 Z100 E5000 ; Set accelerations (mm/s^2) was 500 you changed it to 300 for stall guard
    M906 X500 Y500 Z500 E1000 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S300 ; Set idle timeout

    ; Axis Limits
    M208 X-5.5 Y-10 Z0 S1 ; Set axis minima
    M208 X258.5 Y246 Z260 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M307 H4 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H2.5 F120 T6000 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P25 X-31 Y0 Z1.86 ; Set Z probe trigger value, offset and trigger height
    M557 X50:185 Y50:185 S65 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 X150 T"K" ; Set THERMOCOUPLE parameters for heater 1 X150 is the right channel (terminal block) on the daughterboard. X151 is the right channel.
    ;M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S345 ; Set temperature limit for heater 1 to 345C

    ; Fans
    M106 P0 S0 I0 B0.5 F250 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 B0.5 F500 L255 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Minimum Speed is 1/3 aka 87 Thermostatic control is turned on triggered at nozzle temp 45;
    M106 P2 S0 I0 B0.5 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings
    M591 D0 P5 C3 R10:300 E3.0 S1 ; Duet3D laser sensor for extruder drive 0 is connected to endstop input 3 (E0), tolerance 10 to 120%, 3mm comparison length



  • @Elliot said in Heater showing 2000:

    M305 P1 X150 T"K" ; Set THERMOCOUPLE parameters for heater 1 X150 is the right channel (terminal block) on the daughterboard. X151 is the right channel.
    ;M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1

    If they are stock ender 3 then the current M305 line is wrong as you do not have a thermocouple.
    uncommend the line underneath and comment the line above.



  • @Veti Thanks I have done that. I still have the 2000 problem though.

    I take that back! it works!
    Thank you so much



  • I have two other issues. should i open new threads for them (to do with the screen and bltouch)



  • @Elliot I would seperate, so if someone searches with a similar question in the future, he finds it easier. Nice that you fixed your problem.



  • I spoke too soon. I am now getting an error temperature rising much more slowly than expected 1.8c / sec

    Edit: Fixed it, hotend wires were in the wrong place e1 and not e0


Log in to reply