SOLVED Not using X0 Y0 for home



  • I thought I saw something a while about this but cannot find it...
    I use stall guard to home my printer and not x y end stops. I have a mount on the left side of my hotend to hold my BLTouch. This causes issues and gives my print a slight offset if it pauses halfway through as it seems to rehome at the pause.
    How can I make X280 Y0 my homing point?

    Thanks!



  • Check your M574 configuration. Change X1 to X2 (endstop is at high end instead of low end).
    G28 will now home X at the M208 high limit for X.



  • you will also need to modify your homex.g and homeall.g to move x into positive rather than negative


  • Moderator

    I'd tend to remove the rehome from the pause script. Or it could be that there is a move in the script that it's not quite able to complete. My pause.g is:

    ; pause.g
    ; called when a print from SD card is paused
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Aug 15 2019 14:51:07 GMT+0100 (British Summer Time)
    M83            ; relative extruder moves
    G1 E-10 F3600  ; retract 10mm of filament
    G91            ; relative positioning
    G1 Z5 F360     ; lift Z by 5mm
    G90            ; absolute positioning
    G1 X0 Y0 F6000 ; go to X=0 Y=0
    

    Check that the last move in your pause.g (`G1 X0 Y0 F6000' in mine) doesn't cause the X motor to skip.

    Ian



  • This seems to work, but doesn't go back 5mm from 280mm...
    The below is a mess from other configs I have used testing things. Let me know if I should remove anything.

    homex

    M913 Y50 X50 ; reduce motor current to 70% to prevent belts slipping
    M915 X Y S2 R0 F0 ; X sensitivity to 5, do nothing when stall, unfiltered
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 X305 F4000
    G1 X275 F6000 ; go back a few mm
    M913 Y100 X100 ; motor currents back to normal

    G90 ; absolute positioning



  • @droftarts
    I already have the same settings as you... You just must be able to make them bend to your will better than I can...

    pause.g

    M83 ; relative extruder moves
    G1 E-10 F3600 ; retract 10mm of filament
    G91 ; relative positioning
    G1 Z5 F360 ; lift Z by 5mm
    G90 ; absolute positioning
    G1 X0 Y0 F6000 ; go to X=0 Y=0


  • Moderator

    Can the X motor move at F6000 when the motor current has been dropped? Maybe put the motor current back to normal before doing this move.

    Is there a G28 in your resume.g? Mine (stock) doesn't have one:

    ; resume.g
    ; called before a print from SD card is resumed
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Aug 15 2019 14:51:07 GMT+0100 (British Summer Time)
    G1 R1 X0 Y0 Z5 F6000 ; go to 5mm above position of the last print move
    G1 R1 X0 Y0          ; go back to the last print move
    M83                  ; relative extruder moves
    G1 E10 F3600         ; extrude 10mm of filament
    

    If you're printing and just want to pause the print, then resume, I don't see why it should need to home. If you're turning off the machine and saving position, then yes, you'll need to home after power on. On the whole, there is a problem using stall guard to home to an repeatable exact position, as it can be between 1 to 4 full motor steps out. See the wiki here for details, of which I'm sure you're well aware!

    Ian



  • @droftarts
    I was able to get everything working last night but didn't yet test the pause and how it reacts... I am in the middle of printing birthday gifts.... As I am not expecting it to be different with the current config, I set it to go back to X5 Y5, instead of X0 Y0 when paused. But as I said, printing.... I did this as my Magnetic monitor sensor keeps pausing the print for low filament movement randomly. And actually no idea why... When I check it it's always 97% to 103% and I have it's range 85 to 115%.... So after I resume it starts a bit off the print and that layer is a major weak point. With a bit of Force, maybe a single drop it breaks into two. It hasn't paused in the last two prints but just in case it does....



  • @droftarts
    I have heard stall guard about it being off by said steps, but never had this problem until recent changes to my printer. The only one that could effect this is noticing the BLTouch mount was lose and screwing it down better... It's what was hitting the wall, making the x motor skip for stall guard to work. It's weird it worked better lose. The mount flexes every time it hits...


  • Moderator

    Perhaps check how the magnetic monitor sensor is wired, might be picking up interference from stepper motors or other electronics? Shielded twisted pair wiring is probably safest for sensor wiring.

    Ian



  • @droftarts
    Talking about Interference, my PanelDue used to give me errors all the time. I even posted on this forum about it. But they stopped right after I installed the laser filament monitor. I forgot about it and never shared that odd piece of info...
    The cabling for the Magnet Monitor is as far as can be. Closest point is that the monitor needs to be close to the extruder to be accurate.


  • Moderator

    Might be time to twist some cables.



  • Well... No idea. After pause it no longer gives me a slight offset (by going to location X5 Y5 and not rehoming). I didn't have this problem before the updates.... But it appears on resume it doesn't completely go back to the correct Z height and skips a few layers.
    I am going to go back and re check all of the screws for the Z motors and make sure nothing is lose but thought I would ask in case someone has seen this before.

    You can see the missing layer just above the rabbits tail.

    IMG_20190925_215239~2.jpg

    Thanks!



  • Everything seems to be tight and I still seem to miss a layer or two after a pause.
    IMG_20190928_230949~2.jpg



  • The skipped lines was actually an empty nozzle.

    On pause, the nozzle pulls back 10mm.

    On resume, it pushes out 10mm.

    The nozzle always extrudes a bit at the 10mm push... which means, when it gets back to to printing, the nozzle is empty.
    I don't know why this was never an issue on resume before, but I ended up have it set the resume for 35 mm to ensure the nozzle will be full enough to properly extrude when it gets back to printing. That seems like alot, and odd I haven't noticed this issue before.
    I did recently complete some upgrades. Upgraded to 3 Z motors to enable actual bed leveling, and swapped out the laser filament monitor for the magnetic one.


Log in to reply