CoreXY, weird movement in Y when I move in X!



  • Hi,
    My printer is acting weird. I noticed that my print dimensions are not correct, and the straight line is not straight.
    After a close looking I noticed that when I order it to move in X, G1 X400, it also moves slightly in Y (a few millimeters back and forth).
    The opposite is true as well, If I move it in Y it will move slightly in X.

    I increased the current of X and Y motors from 1100mA to 1500mA to check if it's the problem but it wasn't.
    It seams to me that the firmware is doing this because the movements seem always the same, in the same place check the video:
    https://youtu.be/DDekE31NHzw

    All the belts are straight and parallel with equal tension.
    XY steps are both 80.

    I updated the firmware and the problem still here.

    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 2.04RC1 (2019-07-14b1)
    WiFi Server Version: 1.21RC4(08b3)
    Web Interface Version: 1.22.6

    I would appreciate any help.



  • post your config



  • ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Tue Jun 05 2018 01:10:26 GMT+0200 (CEST)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 PMy printer ; Set machine name
    M552 S1 ; Enable network
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M569 P4 S0 ; Drive 4 goes forwards
    M350 X16 Y16 Z16 E16:16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z800 E2208:2208 ; Set steps per mm
    M566 X900 Y900 Z100 E40:40 ; Set maximum instantaneous speed changes (mm/min)
    M203 X30000 Y30000 Z1000 E5000:5000 ; Set maximum speeds (mm/min)
    M201 X10000 Y10000 Z50 E1200:1200 ; Set accelerations (mm/s^2)
    M906 X1100 Y1100 Z1000 E400:400 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S480 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X430 Y365 Z430 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S1 ; Set active high endstops
    ;M574 Z1 S3 ; Set endstops controlled by motor load detection

    ; Z-Probe
    M558 P4 C2 H5 F120 T18000 ; Set Z probe type to switch and the dive height + speeds
    ;G31 P600 X0 Y0 Z0 ; Set Z probe trigger value, offset and trigger height
    M557 X15:385 Y40:300 P4 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    M305 P2 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 2
    M143 H2 S280 ; Set temperature limit for heater 2 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1:2 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1:2 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z-1.85 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H2 ; Define tool 1
    G10 P1 X0 Y-0.4 Z-1.95 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured



  • .........and check all the grub screws on your pulleys. It sounds a bit like one pulley is slipping on the motor shaft. To get either pure X or pure Y on a CoreXY, then both motors (and pulleys) have to turn an equal amount, either in the same directions or in opposite directions. So if you have some movement in the Y direction when doing a pure X move, then one motor or pulley or belt is moving further than the other, and the most likely cause is a mechanical issue.



  • ..........and 10,000 mm/sec^2 is very high acceleration so you might be getting skipped steps. Try 1,000 and see if that helps.



  • the config looks fine. as @deckingman said it is most likely a mechanical issue.
    i would slow down the movement as low as possible and while its happening check every pulley.

    in the video from 0:45-0:47 you can see the belt lowering by itself. that should not happen.
    As far as i understand the white belts have steel cores that do not bend very well. this could be problematic.



  • I, too, suspect a mechanical problem, specifically related to using steel core belts on small pulleys. It takes significant force to bend the belt around a (small) pulley. Moving in Y requires that each belt bend around 3 pulleys. Moving X requires that each belt bend around at least 5 pulleys. Maybe the motors are running out of torque, maybe the steel core wires have broken inside the belt(s) somewhere.

    Steel core belts and small pulleys are a bad combo- the belts will not last because the steel core wires will break due to repeated flexing. If you must use steel core belts, you must also use large diameter pulleys if you want the belts to last.

    Try installing glass core belts. They are much more flexible and easier to bend around small pulleys. The cores will last a long time without breaking. If you're worried that they stretch, use 9-10mm wide belt. They don't stretch enough to matter, and your printer will be much more reliable.



  • All grub screws are tight and good.
    tried 1000 mm/sec^2 same problem.
    Doesn't matter the speed I choose, nothning changes.
    All pulleys are smooth and good.
    All belts are in correct place in pulleys.
    Not a motor torque issue (tested).
    Will try normal belts instead of my steel core belts.



  • Thanks guys! Problem is solved. Replaced the steel-core belts with normal belts and the problem is solved!



  • @RajaaKahel Glad you got it fixed. For info, I use "normal" 6mm wide belts and throw 3Kgs around on one of my gantries. Never had a problem with stretching or breaking.



  • @deckingman
    Thank you.
    Good, I'll stick with normal 6mm belts for now then..
    Strange, these steel core belts were working fine.



  • @RajaaKahel As @mrehorstdmd alluded, steel belts need a wider bend radius so they may have worked initially but then one or more of the steel cores could have broken when being bent around a small pulley. This then enables the belts to stretch.



  • I put some of them on a delta I built for someone Had to replace them within 2 weeks as the cores snapped causing the belt to stretch by at least 2 mm strange this was (Well not really strange) it was all in the same place.


Log in to reply