SOLVED CR-10S Dual Z Config



  • I've recently install duet 2 wifi to my CR-10S. Everything is going well except for the Dual Z Stepper set up. I have read a lot of post about it and moved my second Z Stepper to E1 spot. I have only made these changes to my config.
    " M569 P0 S0 ; Drive 0 (X) goes backwards
    M569 P1 S0 ; Drive 1 (Y) goes backwards
    M569 P2 S1 ; Drive 2 (Z1) goes forwards
    M569 P3 S0 ; Drive 3 (E) goes backwards
    M569 P4 S1 ; Drive 4 (Z2) goes forwards
    M584 X0 Y1 Z2:4 E3 ; Driver 0=X, 1=Y, 2+4=Z, 3=E

    "
    and i still can't have it working properly. My CR-10S modifications are these mentioned below.

    • Bondtech Direct Drive
    • E3D V6 12V
    • BLTouch

    As you can see i have not changed my PSU to 24V its still the stock 12V. If its not needed i would not like to change to 24V as it means that i have to change few things to the 24V version. I would really appreciate it if you guys would let me copy your config.g if you have the same modifications as i did. Aside from that i would really appreciate your help to how i can fix this dual Z issue.



  • what is not working? is only one stepper moving?



  • Yes, its not moving in sync. when i move my Z only one of the Z stepper is turning smoothly. and the other is moving as if its forced to.



  • check each cable to the z motor that is not moving correctly with a multimeter.
    there could be bad crimps.
    check that the phases are connected correcly



  • i did try to switch between the 2 on my board.
    Prev, Right side Z stepper is on Z Drive 2( Z stepper slot) its moving smoothly.
    Then, i switch Right side Z stepper (Drive 2) placement with the other Z stepper. and now its the other way around. the left one turn smoothly while the right one does not. so im pretty sure that my Cables are fine. Is there anything i have to add to my config aside from the ones that i have posted to make this work?



  • did you observe the correct order of the commands.
    see
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M584_Set_drive_mapping
    Order dependence

    M584 must come earlier in config.g than any M350 and M906 commands. If it creates new axes, it must also be earlier than any M92, M201, M203, M208, M350, M566, M574 , M667 and M669 commands.


  • i just knew about the thing you send me but unfortunately. my current config is in the right order for that part.

    M569 P0 S0 ; Drive 0 (X) goes backwards
    M569 P1 S0 ; Drive 1 (Y) goes backwards
    M569 P2 S1 ; Drive 2 (Z1) goes forwards
    M569 P3 S1 ; Drive 3 (E) goes forwards
    M569 P4 S1 ; Drive 4 (Z2) goes forwards
    M584 X0 Y1 Z2:4 E3 ; Driver 0=X, 1=Y, 2+4=Z, 3=E
    M350 X16 Y16 Z16 E16:16 I1 ; configure microstepping with interpolation
    M92 X100.00 Y100.00 Z400.00 E415.00:400.00 ; set steps per mm
    M566 X900.00 Y900.00 Z24.00 E300.00:24.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X60000.00 Y60000.00 Z6000.00 E1500.00:6000.00 ; set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z100.00 E10000.00:100.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E650:800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout



  • Hi,

    As a test create a config.g file that uses this command and change everything else as needed

    M584 X0 Y1 Z2:3 E4

    Frederick



  • Guys, Thanks alot for the reply and help. i really appreciate it. I have fixed my issue. it was a stupid mistake on my part i did not reinstall the black jumpers on the extra open Z slot on my duet. once i installed it back. everything went smoothly.



  • @Kaizer said in CR-10S Dual Z Config:

    M350 X16 Y16 Z16 E16:16 I1 ; configure microstepping with interpolation
    M92 X100.00 Y100.00 Z400.00 E415.00:400.00 ; set steps per mm
    M566 X900.00 Y900.00 Z24.00 E300.00:24.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X60000.00 Y60000.00 Z6000.00 E1500.00:6000.00 ; set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z100.00 E10000.00:100.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E650:800 I30 ; set motor currents (mA) and motor idle factor in per cent

    you might also want to clean up the second e settings, as you only have one e driver now



  • @Kaizer

    Glad to hear you got it working.

    Frederick


Log in to reply