Duet Maestro XY Layershift



  • Hi everyone...

    I have problems with the Duet Maestro and layer shifts in XY.

    I use this motor:
    https://www.omc-stepperonline.com/nema-17-bipolare-59ncm-84oz-in-2a-42x48mm-4fili-w-1m-cable-and-connector.html?search=17HS19-2004S1

    The Firmware settings are:

    M566 X1200.00 Y1200.00 Z10.00 E300.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X35000.00 Y35000.00 Z800.00 E10000.00 ; Set maximum speeds (mm/min)
    M201 X1500.00 Y1500.00 Z800.00 E5000.00 ; Set accelerations (mm/s^2)
    M906 X1300.00 Y1300.00 Z1300.00 E1300.00I30 ; Set motor currents (mA) and motor idle factor in per cent

    The board is cooled active by an 40x40mm fan.

    The problem occurs more at the same time on a building board at the print of several models at the same time. So mostly in longer print jobs...

    The mechanical setup runs very smoothly...

    What I am doing wrong... ?

    Thank you in advance! 🙂



  • are you at least on 2.03? there was a timing bug that causes layer shifts on longer prints.

    M203 X35000.00 Y35000.00 that max speed is WAY to high.

    M906 X1300.00 Y1300.00 Z1300.00 E1300.00I30 ; Set motor currents (mA) and motor idle factor in per cent

    there is a space missing between E and I. this will cause the command not to be executed.

    the stepper motors are wrong for the maestro.
    see
    https://duet3d.dozuki.com/Wiki/Choosing_and_connecting_stepper_motors

    Duet 2 Maestro (recommended maximum motor current 1.4A with good fan cooling) => Stepper motor rated current <= 1.7A. Hower, if you use motors with lower rated current (e.g. 1.0 to 1.2A) and 24V power, then the drivers will run cooler.



  • @Veti said in Duet Maestro XY Layershift:

    are you at least on 2.03? there was a timing bug that causes layer shifts on longer prints.

    M203 X35000.00 Y35000.00 that max speed is WAY to high.

    M906 X1300.00 Y1300.00 Z1300.00 E1300.00I30 ; Set motor currents (mA) and motor idle factor in per cent

    there is a space missing between E and I. this will cause the command not to be executed.

    the stepper motors are wrong for the maestro.
    see
    https://duet3d.dozuki.com/Wiki/Choosing_and_connecting_stepper_motors

    Duet 2 Maestro (recommended maximum motor current 1.4A with good fan cooling) => Stepper motor rated current <= 1.7A. Hower, if you use motors with lower rated current (e.g. 1.0 to 1.2A) and 24V power, then the drivers will run cooler.

    Are you sure about this? According to most GCode specs I know, spaces are completely irelevant and ignored.



  • @Veti said in Duet Maestro XY Layershift:

    the stepper motors are wrong for the maestro.

    Using the same motors I had the discribed layershifts as well, so I switched to the recommended ones.
    That solved nothing, same issue.
    I my case, in the moment of the layershift I can hear a crack.
    Till today I was not able to find any reasons for that behavior on the mechanical side.
    After reading this, it seems to me that one motor is blocking.
    So, is blocking the behavior for a overload (heat) protection? I can't believe that....



  • one more thing to try is to turn off stealthchop2 by issuing M569 PX D2 for every motor.



  • @Veti Ok this sounds interessting! 🙂 I did not know that this is possible... Thank you! 🙂



  • @Veti
    Thank you! I will give it a try.



  • I had a bizarre instance yesterday.

    Had been printing fine with 2.03 firmware, made some physical adjustments to the bed, next print it started layer shifting on the bottom layer infill in the same spot. Assumed I had joggled some cable's but after checking twice came across this thread.

    Updated to 2.04 this morning and so far, with any luck seems to have fixed it.



  • I take that back, no difference 🙂


Log in to reply