Can't connect my mac to Duet 2 Wifi



  • I am trying to connect my Duet 2 Wifi to my mac to set it up for a new Wifi network, however when I try to connect via USB, I don't see any USB drivers when I type the 'ls /dev/tty.*' command in terminal. All I see is '/dev/tty.Bluetooth-Incoming-Port'.
    I has no issues setting the Duet up with this mac initially, so I'm not sure what the issue is now.


  • administrators

    @vfwfw1 if the Duet is working otherwise then a possible issue is the USB cable.



  • I have tried a few different cables with no real difference. But the cable wouldn't make a difference to whether I can find the USB driver in Terminal would it?


  • administrators

    @vfwfw1 if it was a charge only cable then yes, but if you have a known good cable then you could try a different computer. Also try with nothing but USB connected to the Duet



  • @T3P3Tony
    So are you saying that when I type the command 'ls /dev/tty.*' it will only list the USB file if the Duet is connected with a data USB cable?

    Surely there is some way of seeing if the USB drivers are installed on the mac without having something connected?



  • I have a portable backup drive that connect via USB, so there must be USB drivers somewhere in the OS. When I have the portable drive connected and type the same command (ie. ls /dev/tty.*) it still does not display any USB file.
    Unfortunately I am only a newbie when it comes to Mac's and don't fully understand how the OS works.



  • Tony means don't have any motors, endstops, heaters etc connected to the Duet, as these could be shorting out the board. What's connected to the Mac shouldn't matter. Also remove the SD card from the Duet, in case an error in your config.g is causing a boot loop or the Duet to get stuck. See the guide here if you can't connect: https://duet3d.dozuki.com/Wiki/What_to_do_if_your_Duet_won't_respond

    Let us know the outcome of those tests, particularly what LEDs are lit on the Duet, and how they behave.

    The drivers for the Duet are build into the Mac OS kernel, so no additional driver is required.

    Ian



  • @droftarts
    Thanks Ian, that makes a bit more sense, although I still don't understand why I don't see anything when I type the ls /dev/tty.* command? Does the mac OS only display the USB driver when it has a device connected?
    In Step 3 of the connection guide on the Duet3D.dozuki site it mentions that I should see something like '/dev/tty.usbmodem1411' when I run the ls /dev/tty.* command. What is that actually telling me? I have been assuming that in a similar way to a Windows machine, it is pointing to a driver file in the OS somewhere.



  • I guess it's not showing because the Duet isn't being seen! Go through the troubleshooting guide. When a connection is made, the USB driver creates a mount point in the file system for the Duet (or any other device); this is how Unix/Linux/BSD works. So you're not seeing the 'driver', you are seeing the device in the file system, hence a file path to the device. Unlike Windows, you'll see the same device whether the firmware is loaded or not. This is what it looks like in the Terminal; first time I send ls /dev/tty.* the Duet is not connected, second time it is:
    Screenshot 2019-10-08 at 12.38.04.png
    You can also see connected devices in the System Profile; click the Apple menu > About this Mac > System Report > USB
    Screenshot 2019-10-08 at 12.45.41.png
    Just noticed this does actually say 'Duet'! I suspect if the firmware was erased that it would report as something else, maybe 'Unknown device', in the profiler.

    PS I'm on Mac OS Mojave 10.14.6

    Ian



  • Is there an easy way of telling if a USB cable is data or charge only?



  • Try with another device, eg external USB hard drive? Or... https://electronics.stackexchange.com/questions/140225/how-can-i-tell-charge-only-usb-cables-from-usb-data-cables

    There's also a 'theory' that data cables have the USB trident logo on the plugs, and charge only cables don't. But not sure how reliable that is.

    So true...

    alt text

    Ian


Log in to reply