USED duet ether-not connecting to web-control



  • Bought a cnc machine which has duet installed. The machine WAS working neatly. I brought the machine to my house, but I am unable to connect to web control.
    YAC gave me 192.168.1.33, but browser displays ''site can't be reached''. Changed IP from config.g to P192.168.1.44 in case my router didn't like it....

    Machine is connected through ethernet to a desktop with wifi connetion and through usb cable.
    Below is my config file

    Any thoughts????

    ; Configuration file for Duet
    ; executed by the firmware on start-up
    ; WorkBee Firmware Version 1.0.3

    ; General preferences
    G90 ; Set absolute coordinates

    ; Network
    M550 P3Dedge Termite ; Set machine name
    M552 S1 P192.168.1.33 ; Enable network
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M584 X0 Y1:3 Z2 ; Apply custom drive mapping
    M92 X54.070 Y53.334 Z400 ; Set steps per mm
    M350 X16 Y16 Z16 I1 ; Configure microstepping with interpolation
    M566 X500 Y500 Z500 ; Set maximum instantaneous speed changes (mm/min)
    M203 X10000 Y10000 Z2500 ; Set maximum speeds (mm/min)
    M201 X150 Y150 Z150 ; Set accelerations (mm/s^2)
    M906 X2400 Y2400 Z2400 I100 ; Set motor currents (mA)

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X550 Y520 Z94 S0 ; Set axis maxima

    ; Endstops
    M574 X2 Y2 Z2 S0 ; Set active low endstops

    ; Tools
    ;M563 P1 S"XYZ-Probe" ; Define XYZ Touch Probe Tool

    ; Custom settings
    M564 S1 H1 ; Disable jog commands when not homed
    M140 H-1 ; Disable heated bed
    M501 ; Load Stored Parameters


  • administrators

    Can you ping your machine? What kind of Duet are you using (Ethernet/WiFi)? What is the IP address of your router?



  • Machine is connected through ethernet to a desktop with wifi connetion and through usb cable.

    duet ethernet.
    router ip is 192.168.1.1


  • administrators

    Run M115 and make sure you are on a recent firmware version. Also, try to take out your SD card and make sure there is at least reprap.htm and/or index.html in the /www directory. Make sure to turn off the machine before you remove the SD card and power it back on after the card has been inserted.

    Also, it would be quite useful to know if you can ping your machine at all (press <Win>+R and enter "ping -t 192.168.1.44").



  • did everything you said, windows displayed connection failure.

    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.01(RTOS) ELECTRONICS: Duet Ethernet 1.02 or later FIRMWARE_DATE: 2018-07-26b2<LF>ok<LF>Network running, IP address = 192.168.1.33<LF>

    The thing is, that IT WAS PERFECTLY working on this other guy's pc!



  • just to make sure again, both ethernet & usb cable are connected to pc!


  • administrators

    What about the ping output?



  • updated fw via YAT to 2.0.3, tried 192.168.1.33 which is what the m552 gives me.

    Stll nothing....



  • @chrishamm what do you mean with ping output??



  • @CozyP said in USED duet ether-not connecting to web-control:

    M552 S1 P192.168.1.33 ; Enable network

    try to remove the P part to enable dhcp acquisition.



  • Machine is connected through ethernet to a desktop with wifi connetion and through usb cable.

    If you are using separate interfaces (wifi & eth) on your PC to connect to your home network and duet, than you have a few options:
    A You set up somekind of bridge on those interfaces, and use the bridge interface as your interface to the network (assign ip to it etc.)
    B You set up different subnets on the different interfaces (For ex. 192.168.1.X and 192.168.2.X both with a subnet of 24 (255.255.255.0))
    C you set up your route table manually and specify that your duet's ip should be looked up on the eth interface

    Otherwise your computer will not know which interface whould be used to reach the duet (will not know where to route the ip packets)

    I hope this makes sense, if not, ask away, I'm happy to help



  • If the Duet is connected directly to your PC via ethernet, the easiest option is usually to set it up on a different subnet, separate from your home network (the WiFi one), as @denke suggests in option B in his post. This is easiest done by setting the ethernet port of your PC as a different network. This is similar to connecting two PCs together without a router, so if the following isn't sufficient, google "connect two pc directly ethernet".

    You should be able to do this using a normal ethernet cable, you're unlikely to need a crossover ethernet cable.

    1. Go to “Control Panel -> Network and Internet -> Network and Sharing Center -> Change Adapter Settings.”

    2. Click on “Change Adapter Settings.” This will reveal different connections. Select the appropriate connection. Usually, but not necessarily, the connection will be called Ethernet and have the description network cable unplugged. Right-click on the connection and select “Properties.” The local area’s connection properties window will appear.

    3. Under the network tab select “Internet protocol version 4 (TCP/IPv4),” then click on “Properties.”
      In the Properties windows set the IP address and subnet masks of the first computer to:

      IP – 192.168.2.1
      Subnet Mask – 225.225.225.0

    4. Set the IP address and subnet Mask on the Duet as follows:

      IP – 192.168.2.2
      Subnet Mask – 225.225.225.0

    Note: it is important to ensure that the last values of the IP address for both computers are different.

    Then connect to the Duet by opening a browser and going to 192.168.2.2

    Ian



  • OK, i tried removing the P from config.g, nothing happened.
    entered m557 s192.168.1.33, nothing happened.

    Tried the method of @droftarts, but windows 10 says
    ''ou have entered invalid subnet mask. The subnet mask has to be contiguous. Please entered a valid mask''

    My question is, HOW I cannot access to Duet web control via usb only????? It was perfectly working on previous PC!!!!! It's unbelievable....



  • should I erase the firmware and re-install?? Even if, there isn't an erase button. Could this be done via yat???

    Any solutions to suggest any1??



  • can it be the case that the previous owner could have connected duet ethernet cable to a router and the usb to a pc??? And I am connecting both ethernet and usb to pc???


  • administrators

    @CozyP connecting the Duet directly to a PC, rather than through a router, will require you to have the Ethernet network on the PC setup to work on the same network as the Duet.

    By looking at your previous posts you have the Duet set to use 192.168.1.33 (or 192.168.1.44 now?) either way you need to set the network on the PC:

    Navigate to network properties, adaptor options, TCPIP v4 -> properties and ensure the network address you set for the thernet is in the same subnet, in this case 192.168.1.x (don't use 0 or 255 or the Duet's address):

    f04f78ba-63f8-410c-98f4-a806795e9dc9-image.png

    Once that is done and the Duet is connected by ethernet and powered, try pinging the address of the Duet from the windows command prompt/powershell.

    If that works, then try going to the address of the duet in a browser.



  • @CozyP said in USED duet ether-not connecting to web-control:

    can it be the case that the previous owner could have connected duet ethernet cable to a router and the usb to a pc??? And I am connecting both ethernet and usb to pc???

    More than likely! Connecting the Duet to your router is the standard way of connecting any Ethernet-enabled device to your network. I think we assumed that you wanted to connect the Duet to your PC directly, because the router wasn't accessible to the Duet. So yes, connect the Duet to your router, it will solve your problem without having to make any changes, other than reverting the M552 (not M557 as you posted, this does something else) line to:

    M552 S1 P192.168.1.33
    

    You are going to need to get familiar with the Gcodes, and what the switches do. S1 enables the network, P### gives the Duet it's ip address. See https://duet3d.dozuki.com/Wiki/Gcode#Section_M552_Set_IP_address_enable_disable_network_interface

    If you still want to connect your PC directly to the Duet via ethernet, you need to follow my earlier post about setting your PC and Duet up with a different network subnet.

    The USB is only required to power the Duet for initial testing, until you hook the Duet up to a power supply. It does let you control the Duet via YAT too, but most people just use the web interface. Once you have a power supply connected to the Duet, and connection to the web interface, you can disconnect the USB.

    There are extensive guides in our wiki, that will help you understand how the Duet works. It's a learning curve, not plug-and-play. See https://duet3d.dozuki.com/Wiki/Step_by_step_guide

    Ian



  • I just connected duet to a modem without wifi and it worked. Nothing from the above solutions worked. Seems classical method wins!!!!


Log in to reply