Precision piezo auto bed compensation issues. Please help.



  • Hi.
    So I’ve fitted the Piezo and have my printer homing as it should. It triggers perfectly and homes great. Then my problems start. If I run the Auto bed compensation from the web interface it pushed the nozzle into the bed, about 3-5mm. The Piezo triggers (blue led comes on as it touches the bed) but it carries on down 5mm or so then gives the error: Error: Z probe was not triggered during probing move
    If I use the G30 command from the counsel it does the same except it try’s to find each corner, each time pushing the bed down. I can see that the piezo triggers when it touches the bed (blue led on the piezo comes on) but it ignores that. The error at the end is: G30 Error: Z probe was not triggered during probing move
    I am lost can anyone advise?

    Config.g has this in it.
    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Dec 24 2018 18:36:17 GMT+0200 (South Africa Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    ; M550 P"TEVO BLACK WIDOW"
    M550 P"PETERS TEVO BLACK WIDOW" ; Set machine name
    M552 S2 ; Enable Network in Acess mode
    ;M552 S1 ; Enable network In Normal WiFi Mode
    M589 S"TEVOBWDO" P"POIUYTRE" I10.5.0.19 ; Configure access point. You can delete this line once connected
    ;M587 S"Tech5_753CE0_EXT" P"landeach108" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z1600 E448 ; Set steps per mm
    M566 X700 Y700 Z12 E10 ; Set maximum instantaneous speed changes (mm/min)
    M203 X2000 Y2000 Z500 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z300 E200 ; Set accelerations (mm/s^2)
    M906 X1050 Y1050 Z1000 E1050 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S10 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X335 Y250 Z270 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Set active low endstops

    ; Z-Probe
    ;M558 P0 H5 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X0:335 Y0:240 S20 ; Define mesh grid

    ;Piezo settings
    M558 P5 I1 R0.4 F300 X0 Y0 Z0
    G31 X0 Y0 Z-0.1 P500



  • @PeterA said in Precision piezo auto bed compensation issues. Please help.:

    M574 X1 Y1 Z1 S0 ; Set active low endstops

    you configured z as an endstop rather than a probe

    M574 Z1 S2 ; set endstops controlled by probe



  • @Veti said in Precision piezo auto bed compensation issues. Please help.:

    M574 Z1 S2

    Thanks for helping,
    I put the M574 Z1 S2
    in my file, but now it drills down into the bed. ;(
    I tried this as well
    M574 X1 Y1 S0
    M574 Z1 S2

    Didn't get to the auto mesh as it drills down when homeing. Is the config.g the right place to put this?



  • I use the Orion on my CoreXY printer. It works very nicely!

    In my config.g I have the following to set up the probe and grid, the Orion is connected to the Z-probe input on the Duet WiFi:

    ; Z-Probe
    M574 Z1 S2 ; Z end stop is probe at low value
    M558 P8 R0.4 I1 H5 F360 T6000 ; Set Z probe type to inverted, unfiltered piezo and the dive height + speeds
    G31 P500 X0 Y0 Z-0.015 ; Set Z probe trigger value, offset and trigger height
    M557 X5:290 Y5:275 P14 ; Define mesh grid

    When I home Z, my homez.g macro contains:

    G91 ; relative positioning
    G1 Z5 F360 S2 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 X148 Y140 F6000 ; go to homing probe point
    G30 ; home Z by probing the bed

    ; Lift Z again after probing

    G91 ; relative positioning
    G1 S2 Z5 F360 ; lift Z relative to current position
    G90 ; absolute positioning

    And when I create a new levelling mesh, I have a macro which does this:

    M291 P"Do you really want to create a new levelling mesh?" R"Create Levelling Mesh" S3
    G28 ; Home all
    G91 ; Set relative positioning
    G1 Z50.0 F360 ; Move the platform down to save cooking things
    M291 P"Heating, don't go away!" R"Create Levelling Mesh" S0 T5
    M104 S130 ; Start heating extruder
    M190 S75.0 ; Heat bed and wait for it to reach temperature
    M109 S130 ; Wait for extruder to reach temp before proceeding
    M291 P"Make sure head is free from plastic and press OK" R"Create Levelling Mesh" S2
    G29 S2 ; clear any current levelling map
    M561 ; clear any bed transforms to start levelling from scratch
    G28 ; Home all (also does three motor Z plane correction)
    G29 S0 ; Do mesh probing, save and activate results
    G1 Z50.0 F360 ; Move platform down
    M104 S0 ; hot end heater off
    M140 S0 ; bed heater off
    M291 P"Finished!" R"Create Levelling Mesh" S0 T5

    When printing, I put G32 in my start g-code in the slicer. Instead of having G32 create a new levelling mesh via bed.g, I first make sure that the bed and hot end are heated to the same temperature as I used when creating the levelling mesh, then G32 makes bed.g run which merely does this:

    G29 S2 ; clear any currently active mesh
    M561 ; clear any bed transforms to start levelling from scratch
    G28 ; Home all (also does three motor Z plane correction)
    G29 S1 ; Load heightmap.csv and activate it



  • @grizewald
    Hey thanks for that. I’m not at the printer till tomorrow now but I will defiantly try a few of those settings.
    Keep my fingers crossed as I've spent hours trying to solve it.
    I'll let you know how it goes.



  • @PeterA My settings should work fine for you. The important things are that the probe is defined as such and not as an end stop, as Veti pointed out. Also that your probe is connected to the Z-probe input and not an end-stop input.

    I've actually refined my solution even more. I noticed that the way my print bed deforms is very temperature dependent. It's much more flat at higher temperatures, so I now have two macros to create a levelling map - one at 55C and the other at 75C. So I have two maps to choose between and I use filament specific G-codes in my slicer to load the correct map depending on if I'm printing PLA or PETG/nylon.

    You should also check that your probe triggers properly. If I've replaced a part or worked on my hot end mount, I always double check that the probe is working as expected before homing or doing anything that depends on the probe. I've found that just tapping the nozzle from underneath with a fingernail should always make the blue LED blink on and the red LED go off for a moment. If that happens and the configuration is correct then I know that probing from 5mm height with a speed of 6mm/s will always result in the probe triggering

    Good luck!



  • @PeterA said in Precision piezo auto bed compensation issues. Please help.:

    Error: Z probe was not triggered during probing move

    Still problems.
    My piezo wors as it it triggers great. Red led on, touches bed blue flashes and when homing it works.
    When using home all or home z it works beautifully with the homez.g settings bellow. however my config.g has to have this line
    M574 X1 Y1 Z1 S0 ; Set active low endstops

    If I put M574 Z1 S2
    Then when homing it pushes down into the bed.

    The problem is trying to set it on auto mesh, the z triggers (blue light as touches the bed) but it pushed down at least 5mm. The error is as before Error: Z probe was not triggered during probing move But I can see it was and when normal homing it triggers and works correctly.
    The auto mesh starts and homes, triggers great and sets itself, then it moves on to the first point and moves down onto the bed, blue light triggers as before, but it goes down a further 5mm.
    I’ve tried @grizewald settings but it drills down into the bed on homing unless I change the m574 to z1 s0. Then back to the original problem. Homing then works but everything else drills down into the bed.

    My homez.g
    ; generated by RepRapFirmware Configuration Tool on Mon Dec 24 2018 18:36:17 GMT+0200 (South Africa Standard Time)
    ;G31 Z0 P1000 ; peters attempt and the piezo
    G91 ; relative positioning
    G1 Z3 F800 S2 ; lift Z relative to current position
    G1 S1 Z-275 F400 ; move Z DOWN until the endstop is triggered
    G1 Z2 F300 S2 ;LIFT Z FOR SECOND PROBE
    G1 S1 Z-5 F80 ; move Z DOWN until the endstop is triggered
    G92 Z-0.2 ; set Z position to axis minimum (you may want to adjust this)



  • is there any way the wireing could be wrong with the red light on and the blue light triggering? It doesn't seem logical but I'm lost.



  • Post your entire config.g, homeall.g and bed.g

    Can you confirm that your Orion is connected to the port labelled "Z Probe Header" in this picture?

    alt text



  • @PeterA said in Precision piezo auto bed compensation issues. Please help.:

    @PeterA said in Precision piezo auto bed compensation issues. Please help.:

    Error: Z probe was not triggered during probing move

    Still problems.
    My piezo wors as it it triggers great. Red led on, touches bed blue flashes and when homing it works.
    When using home all or home z it works beautifully with the homez.g settings bellow. however my config.g has to have this line
    M574 X1 Y1 Z1 S0 ; Set active low endstops

    If I put M574 Z1 S2
    Then when homing it pushes down into the bed.

    The problem is trying to set it on auto mesh, the z triggers (blue light as touches the bed) but it pushed down at least 5mm. The error is as before Error: Z probe was not triggered during probing move But I can see it was and when normal homing it triggers and works correctly.
    The auto mesh starts and homes, triggers great and sets itself, then it moves on to the first point and moves down onto the bed, blue light triggers as before, but it goes down a further 5mm.
    I’ve tried @grizewald settings but it drills down into the bed on homing unless I change the m574 to z1 s0. Then back to the original problem. Homing then works but everything else drills down into the bed.

    My homez.g
    ; generated by RepRapFirmware Configuration Tool on Mon Dec 24 2018 18:36:17 GMT+0200 (South Africa Standard Time)
    ;G31 Z0 P1000 ; peters attempt and the piezo
    G91 ; relative positioning
    G1 Z3 F800 S2 ; lift Z relative to current position
    G1 S1 Z-275 F400 ; move Z DOWN until the endstop is triggered
    G1 Z2 F300 S2 ;LIFT Z FOR SECOND PROBE
    G1 S1 Z-5 F80 ; move Z DOWN until the endstop is triggered
    G92 Z-0.2 ; set Z position to axis minimum (you may want to adjust this)

    Your homez.g is using the probe as an end stop and not as a probe. If you look again at my homez.g you will see that I use the command G30 to home the Z axis. G30 means "probe the bed". You are telling the printer that you are using a Z end stop and not a Z probe.

    You must configure the probe as a probe and use it as a probe. It is not an end stop!



  • @grizewald said in Precision piezo auto bed compensation issues. Please help.:

    G32

    Holy Cow!! How backward can I be. My wires are connected to the endstop. Thanks for the picture, with out it I would have been convinced we where talking about the same thing.
    I've just redone it now and started the mess. Looks like its working.
    Many Many thanks. You've been a huge help.



  • @PeterA said in Precision piezo auto bed compensation issues. Please help.:

    @grizewald said in Precision piezo auto bed compensation issues. Please help.:

    G32

    Holy Cow!! How backward can I be. My wires are connected to the endstop. Thanks for the picture, with out it I would have been convinced we where talking about the same thing.
    I've just redone it now and started the mess. Looks like its working.
    Many Many thanks. You've been a huge help.

    My pleasure!


Log in to reply