Orion triggers during tuning but not when Z homing



  • @gtj0 No, there's a very obvious difference in the light and the blue is completely out. I can see the blue even when its only barely flickering. Will try to grab photos of the difference with the red led too

    Appreciate the assist, will be back later with photos



  • Do you have it connected to the Z Probe input and not the Z End Stop input? It won't work as a probe on the end stop input.



  • I haved similar issue.... Was the heat skin fan, that vibrantes and cause false poaitives

    Try with fans powered off



  • @peirof I saw that as well, just after I fitted my Mosquito hot end. The tiny little 25mm fan they use was not balanced in any way and caused so much vibration that I could see the trigger LED flickering all the time. Of course, this lead to false triggering when probing and made it impossible to produce a levelling map.

    I cured the vibration by printed an adapter and replacing the 25mm fan with a 30mm fan from my E3D V6.

    However, if vibration was causing the OP's problem, he would be seeing error messages about the probe triggering prematurely. It won't stop the probe from triggering.



  • @Veti 4.jpg 3.jpg 5.jpg

    Setup doc.docx

    See setup doc for explanation of wiring



  • @gtj0 2.jpg 11.jpg

    First image is printer idle or during tuning, second is during homing - see difference in the red light intensity. Blue light decided to appear during second photo but does not trigger



  • @peirof Thanks, it's not fan vibration on this one. Likely to be PEBCAK though



  • @Foden YIKES - way bigger than i expected

    I setup the BLTouch originally and then moved to the Precision PCB then the Orion. Never got the Piezo to be reliable so switched back to the BLTouch. The Orion setup was done so long ago it's probably a PEBCAK issue - just can't see it until it's pointed out in public i guess ☺

    I like the RJ45 easy swap-out setup - as it means i can usually carry on if i break something or it wears out. Makes for easier testing/modding too



  • What are the blue and blue/white wires which are connected to the left two pins of the Z-probe header?

    From your notes, the Orion does not seem to be connected to the Z-probe header. Therefore, it won't work.



  • Yeah it does look like it's not connected to anything at all. Hmmm. Somehow I switched into a mobile layout. Gimme a sec. 🙂

    That was weird.

    Anyway, the green signal wire from the sensor should be on terminal 5 on the RJ45 break out board (white/blue) and the black ground wire to terminal 4 (blue/white). The red wire (3.3v) on terminal 3 will be the white/green wire but I can't see where that's connected on the Duet.

    Anyway for reference, those breakout boards go like this...

    1 white/orange
    2 orange/white
    3 white/green
    4 blue/white   |  Yes, these are reversed.
    5 white/blue   |
    6 green/white
    7 white/brown
    8 brown/white
    


  • RJ45 Pib Out v1.2.docx

    Doc is a revised version, showing BLTouch and Piezo

    Cable colours depend on the cabling standard used B or A - B being the preferred

    straight-through-cable.jpg

    For the Piezo the blue & blue/white wires aren't used. They are only used when i have a BLTouch in play

    On the 50pin expansion pin 1 is voltage and pin 2 is ground. gtj0 has found the issue, the signal wire is in the wrong place - voltage and ground should be OK though

    Also fighting a cold and some hideous gastro thing which makes this all the more fun!

    Thanks for all the help - will take another look

    Update - correct - i'm pushing "5v to it rather than +3.3 so need to change that too



  • @Foden Giving up for today and going to bed ☹

    From the spec the Orion can cope with 3.3 - 5v so guess it could stay on current 5v pin.

    Will play more tomorrow, i hope

    Thanks again



  • @Foden said in Orion triggers during tuning but not when Z homing:

    From the spec the Orion can cope with 3.3 - 5v so guess it could stay on current 5v pin.

    While the Orion might be 5V tolerant, your Duet WiFi is a revision 1.03 board and the probe input is NOT 5V tolerant. Move the Orion's power input to the 3.3V output which is available on the Z-Probe header.



  • @grizewald I hooked it up to the 3.3v and changed the signal as per gtj0 and it is much better. Maybe something changed in the firmware at some stage because it was working of a fashion at one stage previously. Anyways, moving on problem now when I run mesh compensation Almost none of the points are measured in a constant fashion .Sometimes the head lightly touches the bed (awesome) other times it slightly bends the carriage (not so good). Most of the time homing Z is a gentle touch

    I'm still not 100% myself and will switch back to my BLTouch for now - or i may break something



  • I'm guessing that when the carriage bends the tool head is closer to the middle of the bed than the ends, yeah? A few things to keep in mind if you go back to the Orion... Your Z azis speed may be too low to reliably trigger the sensor. When the tool head is closer to a high or low end, there's less Z "give" in it which would make the contact more sharp. Also do the "tap" test with the tool head in various positions. Make sure you tap upwards on the nozzle and not just sideways on the heat block or something.

    Hope you feel better!!



  • @gtj0 I will speed up the travel if i go back to it. I testes using the tap test and it seemed ok. I have 2 Orions and they are both way more sensitive to movement left/right than up/down

    Thanks for the help and best wishes



  • Yeah, the left/right movement actually results in more force on the piezo elements especially the further down from the sensor you tap. And it's a differential force to boot so it'll always be easier to trigger than a straight up tap. I've often wondered if I could just use the Orion to sense XY limits as well as Z. 🙂



  • @gtj0 Hopefully cleared this by the end of the weekend, as its a PITA

    Will try upping the Z movement speed for a smarter tap



  • @Foden Hmmm, OK had another go at this and speeded up he Z axis move. BUT, whilst i can get it to zip up and down darn fast when homing it goes much slower

    Originally the Z max speed was 200 and I up'd that to 2000. In my Home Z / home all the Z movement is 5000 (i know it wont do that speed as the max is 2000)

    When I move Z up or down 50mm it takes less than 2 seconds, but when I home from that distance it takes over 8 seconds. Looking at the parameters for G30 there doesn't appear to be a speed option. Sooo, I'm missing what ever limits the homing speed as that soes not match the subsonic speed at which i can now move the Z axis. I can adjust the Orion so it doesnt trigger simply by bed movement but am still getting inconsistent probing

    IMG_20191021_202904.jpg IMG_20191021_202952.jpg IMG_20191021_203044.jpg



  • Hi,

    Your M558 command for configuring the Z-probe specifies the travel speed and probing speed.

    Frederick


Log in to reply