Issues with Ender 3 and Duet Maestro



  • Hi all!

    I am having some issues with my E3 and maestro and hoping you guys can help me out. I purchased the printer 2nd hand with the board installed. The guy had just installed a bltouch and was having issues.

    I was able to get my offsets set but am having the following issues:

    • when homing, the printer is not homing the Y axis. As long as I push it back to endstop before, it does just fine but will not home it.

    • slicing a file in cura or slic3r, with even using a profile for ender3duet, the print speeds are super slow. I’m talking a 30 min print taking 4 hours. It also stops after each layer (I changed this in slic3r, but still does it)

    • I cannot get the maestro to connect to my laptop over Ethernet connected to the laptop. It gives a bad ip regardless if I use 0.0.0.0 or assign one. When using M552 S1 with a static Ip, it won’t say it’s running until I unplug and replug the cable. I have not tried it connected to the router cause of the location but should work same with the Pc?

    I really need to get this working and I’ve tried a couple different configurations on my files. Any ideas what to start looking for or doing?



  • Check out the extensive Ender 3 / Maestro conversion guide on the wiki, especially the wiring and configuration sections

    https://duet3d.dozuki.com/Guide/Ender+3+Pro+and+Duet+Maestro+Guide+Part+1:+Wiring/37



  • @Octomodz said in Issues with Ender 3 and Duet Maestro:

    • when homing, the printer is not homing the Y axis. As long as I push it back to endstop before, it does just fine but will not home it.

    Really need to see your config.g, homeall.g and homey.g files to be able to work out what's going on.

    • slicing a file in cura or slic3r, with even using a profile for ender3duet, the print speeds are super slow. I’m talking a 30 min print taking 4 hours. It also stops after each layer (I changed this in slic3r, but still does it)

    Most likely you have the 'gcode flavor' in Cura set to 'Marlin'. It should be 'RepRap', set in Preferences > Printers > Machine Settings > Printer Tab. This usually limits printing to 8mm/s! It puts in some motor settings at the beginning of the gcode Not sure about Slic3r. There's

    • I cannot get the maestro to connect to my laptop over Ethernet connected to the laptop. It gives a bad ip regardless if I use 0.0.0.0 or assign one. When using M552 S1 with a static Ip, it won’t say it’s running until I unplug and replug the cable. I have not tried it connected to the router cause of the location but should work same with the Pc?

    Normally, you plug your Duet into your router. This sorts out the ip address and connection to your network. If you are connecting the Duet directly to your laptop via Ethernet, you need to set up the Duet and your PC in their own point-to-point sub-network, as there's no router to do the network negotiation for them. This is similar to connecting two PCs together without a router, so if the following isn't sufficient, google "connect two pc directly ethernet". Do this (assuming Windows PC, and you normally connect over WiFi to your network/internet):

    1. On your PC, go to “Control Panel -> Network and Internet -> Network and Sharing Center -> Change Adapter Settings.”

    2. Click on “Change Adapter Settings.” This will reveal different connections. Select the appropriate connection. Usually, but not necessarily, the connection will be called Ethernet and have the description network cable unplugged. Right-click on the connection and select “Properties.” The local area’s connection properties window will appear.

    3. Under the network tab select “Internet protocol version 4 (TCP/IPv4),” then click on “Properties". Example:

      alt text
      In the Properties windows set the IP address and subnet masks of your PC to:

      IP – 192.168.4.1
      Subnet Mask – 225.225.225.0

    4. Set the IP address and subnet Mask on the Duet as follows:

      IP – 192.168.4.2
      Subnet Mask – 225.225.225.0

    Note: it is important to ensure that the last values of the IP address for both computers are different.

    Then connect to the Duet by opening a browser and going to 192.168.4.2

    Ian


Log in to reply