No z-probe option crashes bed into nozzle



  • Because the mount of my mini IR probe has become very slightly bent and does no longer trigger before the nozzle hits the bed I want to manually bring the nozzle to the bed and use a sheet of paper to get the offset for now.

    On the wiki it says that if you use the no z-probe option (M558 P0) it will prompt me to bring the nozzle to the bed manually but this doesn't happen when I press the home Z button on the web interface or when starting a print, instead it will bring the bed up without stopping and then just crashes the bed into the nozzle until I press the emergency stop button.

    Why do I not get prompted and what do I need to do to fix this?



  • do you have a z endstop? also share the complete config to help diagnose.



  • @Raven The easiest thing to do is simply keep nudging the bed towards the nozzle, then when it's just touching the paper enter G92 Z0.



  • @bearer I do not have a z-endstop.

    Here is my config.g:

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"My Printer" ; set printer name

    M667 S1 ; select CoreXY mode

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S0 ; physical drive 3 goes backwards
    M584 X0 Y1 Z2:4 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z800.00 E420.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X230 Y210 Z200 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; set active high endstops
    M574 Z1 S2 ; set endstops controlled by probe

    ; Z-Probe
    M558 P0
    M557 X15:215 Y15:195 S20 ; define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C



  • @deckingman How do I do this using the duet wifi web interface?



  • @Raven said in No z-probe option crashes bed into nozzle:

    @deckingman How do I do this using the duet wifi web interface?

    Use the Z minus buttons - the line of buttons to the right of Home Z.

    Edit - if you go too far, use the Z plus buttons to jog in the other direction ☺

    You might need to use M564 H0 to allow movement.



  • @deckingman Thank you for the information!
    But I still have the problem that the bed goes automatically up when I home Z. This shouldn't happen but I can't figure out why it does this. Would you have any idea what causes this?



  • @Raven If you don't have a switch or a probe or any other means of detecting when the nozzle and bed are close together, then you can't home Z other than manually doing it using G92 as I described.

    Homez will run whatever commands are in the your homez macro. If you used to homez with the IR probe, but now that IR probe doesn't trigger because it's slightly bent, then don't use that homez macro.


  • administrators

    @Raven said in No z-probe option crashes bed into nozzle:

    Because the mount of my mini IR probe has become very slightly bent and does no longer trigger before the nozzle hits the bed I want to manually bring the nozzle to the bed and use a sheet of paper to get the offset for now.

    On the wiki it says that if you use the no z-probe option (M558 P0) it will prompt me to bring the nozzle to the bed manually but this doesn't happen when I press the home Z button on the web interface or when starting a print, instead it will bring the bed up without stopping and then just crashes the bed into the nozzle until I press the emergency stop button.

    Why do I not get prompted and what do I need to do to fix this?

    It's probably because your homez.g file or the Z homing section of homeall.g is incorrect. It should use a G30.command to probe the bed, not a G1 H1 Z command. See https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter#Section_Homing_Z_using_a_Z_probe.



  • Thank you for your reply,
    The problem turned out to be the "M574 Z1 S2" command. When removed the bed would no longer raise automatically.

    I still do have another problem.
    When manually setting the offset of the Z-axis I set the the Z-axis value at 0 when I probed it manually using some paper but once I start a print it will start to print 2 to 3 cm in the air. Why is that? Where does this offset come from and where would I change this?



  • You need to post your homeall.g so we can see what's going on when you home the printer.


Log in to reply