Wifi adapter not enabling



  • I have a duet 2 wifi, this one is a brand new board. I have tried using the "Getting Connected to your Duet" but I keep getting an error: ok<LF>WiFi reported error: no known networks found<LF>WiFi module is idle.

    I get the same error when I check the status, try to disable it or when I try to enable it. When I power the board on, the blue light flashes for about a half of a second.

    Does anyone have any ideas?



  • If you send M115 and M122 in the console what firmware versions does it say you have installed?

    You'll get a more readable response if you change the YAT line endings as described in the getting connected guide.



  • Verify the firmware and wifi server versions are up to date as Phraedrux mentioned after that the process I follow with a new board

    Using YAT open a terminal session with the board

    M587 (List stored networks) See if any networks are listed
    M588 S"*" (cleared existing stored networks)
    M587 S"SSID" P"NetPass" (set network wifi credentials)
    M552 S1 (launch wifi, obtain IP address)

    There are times in this process where I have to toggle wifi on/off using
    M552 S0
    then
    M552 S1

    Hope that helps

    Edit: I just found this
    https://forum.duet3d.com/topic/7563/solved-connecting-to-wifi/3



  • @Phaedrux said in Wifi adapter not enabling:

    If you send M115 and M122 in the console what firmware versions does it say you have installed?

    You'll get a more readable response if you change the YAT line endings as described in the getting connected guide.

    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.04 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2019-11-01b1

    The Duet is constantly repeating:
    WiFi reported error: no known networks found
    WiFi module is idle



  • @bricor said in Wifi adapter not enabling:

    Verify the firmware and wifi server versions are up to date as Phraedrux mentioned after that the process I follow with a new board

    Using YAT open a terminal session with the board

    M587 (List stored networks) See if any networks are listed
    M588 S"*" (cleared existing stored networks)
    M587 S"SSID" P"NetPass" (set network wifi credentials)
    M552 S1 (launch wifi, obtain IP address)

    There are times in this process where I have to toggle wifi on/off using
    M552 S0
    then
    M552 S1

    Hope that helps

    Edit: I just found this
    https://forum.duet3d.com/topic/7563/solved-connecting-to-wifi/3

    With the M587 command I get this: M587: Failed to retrieve network list

    With M588 S"*" I get this: M588: Failed to reset the WiFi module to factory settings



  • Did you try M552 S0 then M552 S1?

    I would try that and then from the top

    M588 S"*" (cleared existing stored networks)
    M587 S"SSID" P"NetPass" (set network wifi credentials)
    M552 S1 (launch wifi, obtain IP address)





  • @craigrezac7 Are you using YAT or some other serial programme to talk to the Duet? We recommend using YAT, because it can send upper and lower case letters; most other serial terminal programmes convert everything to upper case. So if your router's SSID and/or password has a mix of cases, these will not be sent to the Duet correctly. However, it is possible to send upper and lower case letters:

    Many programs used to send GCodes convert all characters to uppercase. In firmware 1.19.2 and later, within any quoted string you can use a single-quote character to indicate that the following character should be changed to lowercase. For example, M587 S"ABC" P"P'A'S'SW'O'R'D" would specify that the password is PassWord. Use two single quote characters to represent one actual single quote character in the password or in the SSID.

    Someone also reported recently that the serial terminal software they were using in Linux caused other characters (in their case, hypen) to be sent incorrectly.

    If you can't use YAT or the above doesn't work, set the Duet up in Access Point mode, connect directly to the Duet, and use the console in the Duet Web Interface to add your network.

    Ian



  • Sorry, just seen you have replied and you are using YAT!

    Are you expecting the Duet to discover your WiFi network? Unfortunately, it doesn't work like this. You need the WiFi network name (SSID) and password, and send this to the Duet in the form:

    M587 S"your-network-ssid" P"your-network-password"
    

    which will add it to the list of remembered networks, ie the 'known' networks.

    Ian



  • @droftarts I guess what I expected is what I remember from the last board and that is the blue light on the wifi module actually turning on and then it connecting to the wifi.

    With M587 S"" P"" I get this:

    M587: Failed to add SSID to remembered list
    Error retrieving WiFi status message: bad reply format version



  • @craigrezac7 said in Wifi adapter not enabling:

    With M587 S"" P"" I get this:

    well you need to specify your wifi ssid and password.



  • @Veti I understand that, I just didn't want to post it.



  • @droftarts In AP mode I get this error:

    M589 S"Rezac" P"Floxxxxxxx" I192.168.86.27
    M589: Failed to configure access point parameters
    ok
    Error retrieving WiFi status message: bad reply format version



  • Can you send M408 S5 and post the response? This shows the firmware version for the Duet, and the firmware version of the WiFi module (dwsVersion). Have you updated the firmware since receiving the Duet?

    Sending M552 should tell you the status of the Wifi module. Turn the module off using M552 S-1, which should report "WiFi module stopped". Wait a few seconds. When the WiFi module is stopped, you can't add SSID or AP parameters to the remembered list. I usually find it's best to add these when the module is 'disabled', ie after sending M552 S0, rather than when idle/connected M552 S1. Just seems to work more reliably for me. Check that you have no saved SSIDs with M587 on it's own, same with saved AP parameters with M589. Delete with M587 S"*" and/or M589 S"*". Then try adding the SSID again with M587 S"your-network-ssid" P"your-network-password"

    If you can post responses to all these commands, might give a clearer picture what's going on.

    Ian



  • That was it!! I think what made it realize what was going on was the M552 S-1. I didn't even notice that command. I always put either S0 or S1, never did I notice M552 S-1. Thank you so much!

    @droftarts I did update the board to 2.0.4 to see if I could get the light to enable.

    M408 S5 response: {"axisMins":[-85.00,-85.00,-0.20],"axisMaxes":[85.00,85.00,250.00],"accelerations":[1000.00,1000.00,1000.00,1000.00,1000.00,250.00,250.00,250.00,250.00,250.00,250.00,250.00],"currents":[1000.00,1000.00,1000.00,800.00,800.00,0.00,0.00,0.00,0.00,0.00,0.00,0.00],"firmwareElectronics":"Duet WiFi 1.02 or later","firmwareNam20.00,20.00,20.00,2.00,2.00,2.00,2.00,2.00,2.00,2.00],"maxFeedrates":[333.33,333.33,333.33,60.00,60.00,20.00,20.00,20.00,20.00,20.00,20.00,20.00]}

    M552
    WiFi reported error: no known networks found
    WiFi module is idle
    WiFi module is changing mode

    M552 S-1
    WiFi module stopped

    M552 S0
    ok
    WiFi module started

    M587
    Remembered networks:
    TNCAP2FCC19 IP=192.168.1.14 GW=0.0.0.0 NM=0.0.0.0
    ok

    M587 S""
    M587: Bad or missing parameter
    ok
    M589 S"
    "
    ok

    M587 S"Rezac" P"Flxxxxxxxxx"
    ok

    M552 S1
    ok
    WiFi module is connected to access point Rezac, IP address 192.168.86.249



  • @craigrezac7 Great!

    M587 S"*" (needs an asterisk) will delete all SSIDs, but if you want to delete a specific one, use M588, for example, M588 S"TNCAP2FCC19". It can also delete all SSIDs with M588 "*" like M587. M589 S"*" will delete all AP configurations.

    Strange response to M408 S5, as it's missed out the firmware versions. Mine looks like:

    SENDING:M408 S5
    {"axisMins":[-106.00,-110.00,0.00],"axisMaxes":[114.00,118.00,180.00],"accelerations":[500.00,500.00,20.00,250.00,250.00,250.00,250.00,250.00,250.00,250.00,250.00,250.00],"currents":[1000.00,1000.00,800.00,1000.00,0.00,0.00,0.00,0.00,0.00,0.00,0.00,0.00],"firmwareElectronics":"Duet WiFi 1.0 or 1.01","firmwareName":"RepRapFirmware for Duet 2 WiFi/Ethernet","firmwareVersion":"2.04RC1","dwsVersion":"1.23","firmwareDate":"2019-07-14b1","idleCurrentFactor":30.0,"idleTimeout":30.0,"minFeedrates":[15.00,15.00,0.20,2.00,2.00,2.00,2.00,2.00,2.00,2.00,2.00,2.00],"maxFeedrates":[100.00,100.00,10.00,20.00,20.00,20.00,20.00,20.00,20.00,20.00,20.00,20.00]}

    Admittedly I'm still using 2.04RC1 on this board... must update it!

    Ian



  • This post is deleted!


  • @craigrezac7 Probably best to start a new thread, but if this is enough to get you going...
    This thermistor? https://www.sliceengineering.com/collections/all-products-collection/products/thermistor-high-temperature. There's a link to the 'RT Table' that has the specs for the thermistor.

    Also, the RRF config tool has this thermistor built-in already. Go to the Heater tab https://configtool.reprapfirmware.org/Heaters and under Heater Configuration, click on one of the 'R25' parameters. This should give you a drop down list of thermistors, of which one is "Slice Engineering High Temperature Thermistor". This gives values of:

    R25: 500000 Ω
    β: 4723 K
    C: 1.196220e-7
    

    Code for this for config.g is:

    M305 P1 T500000 B4723 C1.196220e-7 R4700 ; set thermistor + ADC parameters for heater 1
    

    I'm sure others on here are running these, so any other questions, probably start a new thread.

    Ian


Log in to reply