true bed leveling dual independent lead issue



  • Hey I'm not a 100% sure if my problem is only IR probe related, but here's the description of my issue.
    I used a BLTouch on my duet 2 wifi before running 2.04 firmware now I replaced the BLTouch with the mini IR probe, if I do a G32 a few times in a row the level get's better with every iteration and I usually stop doing it with sub 0.008 mm deviation.
    but sometimes it's like increasing the deviation. so really no repeatable behaviour.
    But then no matter what I do next be it a bed mesh calibration or starting a print or just moving the z-axis up and down, the gantry is tilted again.
    I also have the impression that the z-motors don't run simultanious.
    btw I'm using black printbite plus.

    I would highly appreciate any hints that could point me to the cause of that issue.



  • post your config.g and bed.g



  • 0:/sys/config.g
    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.4 on Tue Oct 08 2019 18:53:18 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"VLN_CR10S" ; set printer name

    ; Network
    M551 P"killer33" ; set password
    M552 S1 ; enable network and acquire dynamic address via DHCP
    M587 S"printer.printer" P"shippuden"
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M584 X0 Y1 Z2:4 E3
    M569 P0 S0 ; physical drive 0 goes backwards
    M569 P1 S0 ; physical drive 1 goes backwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S0 ; physical drive 3 goes backwards
    M569 P4 S1 ; Physical drive 4 goes forwards
    M350 X32 Y32 Z32 E16 I0 ; Configure microstepping without interpolation
    M584 X0 Y1 Z2:4 E3
    M669 K0.9
    M671 X-27:327 Y155:155
    M92 X160.00 Y160.00 Z800.00 E406.00 ; Set steps per mm
    M566 X360.00 Y360.00 Z12.00 E260.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X15000.00 Y15000.00 Z600.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X900.00 Y900.00 Z200.00 E360.00 ; Set accelerations (mm/s^2)
    M906 X1000.00 Y1000.00 Z800.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X310 Y310 Z400 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; set active high endstops

    ; Z-Probe
    ;M574 Z1 S2 ; set endstops controlled by probe
    ;M307 H3 A-1 C-1 D-1 ; disable heater on PWM channel for BLTouch
    ;M558 P9 H5 F120 T6000 ; set Z probe type to bltouch and the dive height + speeds
    ;G31 P500 X+32 Y-2 Z2.319 ; set Z probe trigger value, offset and trigger height
    ;M557 X35:275 Y35:275 S50 ; define mesh grid
    ;M557 X35:280 Y35:280 S50

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P1 H5 F200 T9000 I0 R0.5 ; Set Z probe type mini ir sensor
    G31 P500 X-2 Y-16.4 Z2.114 ; Set Z probe trigger value, offset and trigger height
    ;M557 X30:270 Y30:270 S80 ; Define mesh grid
    M557 X30:280 Y45:280 S45

    ; Heaters
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4267 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4092 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0 I0 F500 H-1 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S0 I0 F500 H-1 ; set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss

    M501

    ==========================================================================================
    ; bed.g
    ; called to perform automatic bed compensation via G32
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.4 on Tue Oct 08 2019 18:53:18 GMT-0400 (Eastern Daylight Time)
    M561 ; clear any bed transform
    G30 P0 X35.0 Y155 H0 Z-99999
    G30 P1 X275.0 Y155 H0 Z-99999 S2



  • alt text

    lattest bed mesh height map



  • @gueee78 said in true bed leveling dual independent lead issue:

    M350 X32 Y32 Z32 E16 I0 ; Configure microstepping without interpolation

    Unless there is a very specific reason, you should be running x16 with interpolation.

    M669 K0.9

    This command makes no sense. K requires an integer

    there is something wrong with your probe if the bed looks like that. (
    or if thats the actual bed, consider getting a new one)



  • the wiki says fudge factor default is 1.0 doesn't seem to be an integer? the probe is new, the bed as well and it's a precision milled cast aluminum plate. no interpolation was accidently set, cause I got parts of the config from a buddy with a flex3drive with 40:1 gear reduction. I have a feeling that it could be PSU related, it's still the stock 12 volts psu of the cr10s




Log in to reply