PT-100 temperature constantly at 2000 degrees after failure



  • Hi,

    I had the issue on the first print after finally fixing the homing config issue, that the temperature reading showed "Failure". I had to turn the printer off and on again in order to get it working again. Sadly after it failed a second time and it went into reading 2000 degrees ever since then. I'm using a PT-100 sensor and the daughter board and i even switched to the second RTD Pin but it's still reading 2000 degrees. I've even replaced the sensor with no luck.


  • administrators

    Does it read 2000 even with just usb power? If so then you have a bad connection, either in the wiring between the daughter board and the sensor, or the links you use for 2-wire connection are not working. Use a multimeter to check the wiring. The resistance of the sensor should should be a little over 100 ohms at room temperature.



  • The other possibility that happened to me was electrical interference from the extruder stepper. So every time I fed filamenthe PT100 went to 2000C and tripped out on safety. To solve it I ran double shielded super flex microphone cable between the duetwifi and the PT100, no issues in 3+months. PS only earth it at the duetwifi end if you do this.



  • The issue still exists if only connect through USB. As this setup has worked before i don't think that there is any interference. I'm using the E3D PT-100 sensor but the strange thing is that i cannot measure any resistance not with the sensor that used to work nor with the new sensors that hasn't been used before. I have also another PT-100 sensor where i can measure its resistance to be around 100 Ohms, but the issue with the 2000 degrees still exists.


  • administrators

    When you say you cant measure any resistance, is that with the PT100 connected to the daughterboard? if so then please try with it not connected to the daughterboard. At that point if it is not ~100R then you have a issue in the sensor or the wiring.



  • No, i cannot measure it when sensor is not connect to the daughterboard. But it seems still strange, it would mean I have two new E3D PT100 sensors that do not work? But even with the PT100 sensor from the Ultimaker Original where i can measure the resistance I sill have the same issue with the temperature reading. This would mean i have 2 issues at hand and even with the same setup that used to work before it went 2 times into failure. This is utterly strange.



  • Did you inspect the PWB board and connectors to make sure that none of the circuit traces are broken or if there is damage on the solder joint or connector?



  • I don't see anything that any of the circuit traces are broken nor does anything look damaged.

    With the reprapfirmwar tool i get this config for the E3D thermistor:

    [[language]]
    M305 P1 T100000 B4725 C7.060000e-8 R4700 X201 ; Set thermistor + ADC parameters for heater 1 and remap it to channel 201
    
    

    But i also tried everything else even:

    [[language]]
    M305 P1 X201
    
    

  • administrators

    Do you have the PT100 connected to the first or second channel on the daughter board? 201 is the second channel, the first is 200.



  • Right now i have on the second channel. As I've said, it used to work on channel 1 until the failures and since then it doesn't even work on channel 2.


  • administrators

    Do you have a resistor of between 100 and 200 ohms that you can connect to the terminal block in place of the PT100?



  • No i don't have a resistor around but i think this won't make a difference. Since the Ultimaker Original has a measurable resitance of around 100ohms. It measures like in the image below (the green connection has around 110 ohms):

    It seems to me that the issue is with the daughter board or the duet itself.


  • administrators

    Do you have anything else connected to the SPI bus, for example a ribbon cable connecting the CONN_SD port on the Duet to the PanelDue for using a second SD card?

    If the answer is no, please ask your supplier for a new daughter board.



  • Well, I've ordered a new daughter board but i still get the same issue. And no I've nothing connected to SPI bus. There is no PanelDue nor a second SD card.


  • administrators

    Have you removed the PT100 sensor from the hot end or is it still installed? I'm wondering whether it may have developed a short between the element and the case.



  • It's the same even if installed in the hotend or not. If I read the voltage on the middle 2 pins I get a reading of about 2V with the E3D PT100 and about 0.2V for the Ultimaker PT100. With both those voltages i get 2000 degrees in the Frontend.


  • administrators

    The 0.2V with the Ultimaker sensor sounds plausible, the 2V with the E3D one sounds like an open circuit sensor, or else it's a thermistor not a PT100.

    If you send the M305 P1 X201 command from the Gcode Console, does it return an error message?



  • It is all fine when I send M305 P1 X200 or X2001, no error message whatsoever. It even turns off the fan shortly that is set to start at 40 degrees but that runs continuously now because of the 2000 degrees.


  • administrators

    What voltage do you read across the outer 2 pins of the 4 pin terminal block? It should be the same 0.2V that you get across the inner ones, with the good PT100 connected.



  • Yes the outer 2 pins show 0.2 V as well. I really don't get this, why did it used to work and now nothing helps? There is nothing burnt or damaged on the duet itself.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.