Connecting to wifi



  • So I have a new wifi router that I am using for my other printers (OctoPrint setups). I am trying to get my Duet 2 wifi connected and am running into nothing but problems. I am following the wiki instructions and this forum post (see below). I've gone through all of the steps and when I run M587, I get this:

    Remembered networks:
    IMAKESTUFF IP=0.0.0.0 GW=0.0.0.0 NM=0.0.0.0

    Thanks for any help!

    Pat

    bricor 8 Nov 2018, 13:17
    Verify firmware version (as requested by dc42).

    After some time struggling, I found this to be the best method to set Wifi parameters and successfully join a wireless network.

    Verify device is in range of the wifi router
    Avoid close proximity to multiple routers and multiple SSIDs

    Start a terminal session (YAT) connected via USB

    M587 (List ALL stored networks)

    If there are any networks listed that you do not want your device to access they need to be removed from the List of Available Networks (M588 gcode)
    I removed ALL that were listed. Completely clearing the list.
    I had to remove them one by one since the M588 S"*" gcode didn't work for some reason

    M588 "what ever net name is there to be removed" (remove network from the stored network list) (MUST be typed verbatim (letter for letter) and inside quotation marks ("))

    <<<Edit: M588 S"*" works as expected to remove all networks.>>>

    Once the list of stored networks is clean add you wifi network information (M587 gcode)

    M587 S"SSID" P"NetPass" (set YOUR network wifi credentials)(MUST be typed verbatim (letter for letter) and inside quotation marks ("))
    If the SSID or Password has spaces or funky characters (anything other than 0-1, a-z, A-Z) you may experience issues. Make sure the SSID and Password are typed EXACTLY the same as what the router is expecting. To rule out typos, try changing SSID and Password to something less exotic. Remove spaces and funky characters.

    Finally, once the network list is clean (M588) and you have successfully joined the wifi network (M587) Launch network services (M552 gcode)

    M552 S1 (launch wifi, Duet will obtain IP address)

    The terminal session will display the IP of the Duet, connect to DWC via a browser.



  • If I understand the question...

    use a 588 to remove the network that is remembered. Specifically

    M588 S"IMAKESTUFF"

    or

    M588 S"*"

    and check again that M587 returns nothing.

    Then proceed with adding your network as the instructions state.


  • administrators

    @BearcatTD, what response do you get when you send M552 S1 ?



  • It has been setting on for a couple of days now and it has now connected to wifi. Usually it pops up within seconds. I've turned the machine on and off and it now connects perfectly! Thanks!


Log in to reply