Endstops coming up as triggered when not triggered - duet 3



  • Hiya,

    I've wired some old makerbot endstops to the new duet 3 I got - with the red/black wires going from 3v3 to gnd, and the green signal wire into the in pin of each 5-pin connector. I have tried both active-high and active-low and switched cables/connectors but they always show the opposite of their physical state - so not triggered when they are triggered etc. I'm building a cartesian printer and running RRF 3.0beta12

    I'm kinda lost as to what I'm doing wrong here - I've tried a load of different software configurations and it's always the same. Has anyone else had this problem, and if so what am I doing wrong?

    Thanks 🙂



  • @ehd Have you tried inverting the pin? i.e. using an exclamation mark. This is how I invert my Z axis switch M574 Z1 P"!2.io1.in". Note the exclamation mark after the first quotes.


  • administrators

    please share your config.g so we can see how the M574 commands are setup



  • @deckingman I can't believe I didn't think of that! I knew it'd be something really simple lmao, thank you!

    @T3P3Tony all solved, so I won't waste your time with my config file 🙂



  • @ehd Glad that solved it for you.☺


Log in to reply