Substantial z offset after mesh level



  • I swear to Pete that if it isn't one thing, it's another. I had two nice prints then the Duet gods wouldn't give me anymore. I do a G29 and check my heightmap before every print. It worked great for about two days, then this morning after running G29, I get the "Warning: the height map has a substantial Z offset. Suggest use Z-probe to establish Z=0 datum, then re-probe the mesh.
    9 points probed, min error 0.085, max error 0.220, mean 0.143, deviation 0.042"

    Here are my files:
    retractprobe.g
    rehome.g
    homez.g
    homey.g
    homex.g
    homeall.g
    deployprobe.g
    config.g
    bed.g

    Thanks for any suggestions!



  • This post is deleted!


  • Also, I did this right before the G29...

    Calibrate the Z probe trigger height

    Make sure the dynamic test is successful (Z probe stops when it senses the bed) before doing this.

    1.Use the X and Y jog buttons to position the nozzle over the centre of the bed
    Jog the nozzle down until it is just touching the bed or just gripping a sheet of paper. If the firmware doesn't let you jog it down far enough, send M564 S0 to disable axis limits.

    2.Once you have the nozzle touching the bed, send command G92 Z0 to tell the firmware that the head is at Z=0

    1. Jog the head up by 5 to 10mm

    2. Send command G30 S-1. The nozzle will descend or the bed rise until the probe triggers and the Z height at which the probe stopped will be reported. If you are using a nozzle-contact Z probe, the trigger height will be slightly negative. For any other type of Z probe where the probe triggers before the nozzle contacts the bed, it will be positive.

    3. Repeat from step 5 two or three times to make sure that the trigger height is consistent.

    4. In Duet Web Control, go to Settings -> System Editor and edit the config.g file. Set the Z parameter in the G31 command to the trigger height that was reported. Save the file.

    5. Open config-override.g and check that there are no G31 commands in it. If you find any, delete those lines and save the file.

    6. To apply the new trigger height, restart the Duet by sending M999 or pressing Emergency Stop.



  • your g29 command must come after the g30 command. and there cant be a g28 in between.



  • Gave it a try, got the same results. This is what I did.

    1. Power cycled the machine, gave it time to connect.
    2. Ran G28
    3. Ran G30
    4. Ran G29 Got "Warning: the height map has a substantial Z offset."


  • @BearcatTD said in Substantial z offset after mesh level:

    g: the height map has a substantial Z offset."

    post a picture of the heightmap



  • 606991A2-9AD4-4339-945D-829FB8F8200F.jpeg



  • G1 X51 Y20 F6000 ; go to first bed probe point and home Z

    M557 X50:185 Y50:185 S65 ; Define mesh grid

    your first probe position and your mesh dont overlap

    try changing your probe point from homeall to the middle of the bed.

    also S65 is way to large, this will give no good result. try S20 or S15



  • I changed S65 to S20. I'm not sure what you mean by the rest. Do I need to do something with this line?

    G1 X51 Y20 F6000 ; go to first bed probe point and home Z

    As always, I very much appreciate your help!!



  • @BearcatTD said in Substantial z offset after mesh level:

    G1 X51 Y20 F6000 ; go to first bed probe point and home Z

    change that to G1 X100 Y100 F6000 for now


Log in to reply