Large Core Homing issue



  • Hello, I have this little issue.
    I have set the homez.g and homeall.g files, for the head to probe the center of the bed for z homing (x250, y250).
    It never does, it just goes to x250 y0 and probes there.
    Can you please check and let me know what I have done wrong? That also affects the bed compensation i think, its never correct.

    I have the files here for your consideration, thank you for all the help.

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.3 on Tue Dec 10 2019 00:14:51 GMT+0200 (Eastern European Standard Time)
    G91 ; relative positioning
    G1 H2 Z5 F12000 ; lift Z relative to current position
    G1 H1 X-520 Y-520 F4800 ; move quickly to X or Y endstop and stop there (first pass)
    G1 H1 X-520 ; home X axis
    G1 H1 Y-520 ; home Y axis
    G1 X5 Y5 F12000 ; go back a few mm
    G1 H1 X-520 F480 ; move slowly to X axis endstop once more (second pass)
    G1 H1 Y-520 ; then move slowly to Y axis endstop
    G90 ; absolute positioning
    G1 H2 X250 Y250 F6000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F200 ; lift Z relative to current position
    ;G90 ; absolute positioning

    ...............................................................................................................................

    ; homey.g
    ; called to home the Y axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.3 on Tue Dec 10 2019 00:14:51 GMT+0200 (Eastern European Standard Time)
    G91 ; relative positioning
    G1 H2 Z5 F12000 ; lift Z relative to current position
    G1 H1 Y-520 F4800 ; move quickly to Y axis endstop and stop there (first pass)
    G1 H2 Y5 F12000 ; go back a few mm
    G1 H1 Y-520 F480 ; move slowly to Y axis endstop once more (second pass)
    G1 H2 Z-5 F12000 ; lower Z again
    G90 ; absolute positioning

    ..................................................................................................................................................................

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.3 on Tue Dec 10 2019 00:14:51 GMT+0200 (Eastern European Standard Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"GIANTCORE" ; set printer name

    M667 S1 ; select CoreXY mode

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S0 ; physical drive 3 goes forwards
    M569 P4 S1 ; physical drive 4 goes forwards
    M584 X1 Y0 Z2 E3:4 ; set drive mapping
    M350 X16 Y16 Z16 E16:16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E100.65:100.65 ; set steps per mm
    M566 X1500.00 Y1500.00 Z800.00 E10000.00:10000.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X48000.00 Y48000.00 Z3200.00 E18000.00:10000.00 ; set maximum speeds (mm/min)
    M201 X3000.00 Y3000.00 Z500.00 E10000.00:10000.00 ; set accelerations (mm/s^2)
    M204 P500 T4000
    M906 X1900 Y1900 Z2000 E1800:1800 I20 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X-16 Y-37 Z0 S1 ; set axis minima
    M208 X507 Y477 Z517 ; set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; set active low and disabled endstops
    M574 Z1 S2 ; set endstops controlled by probe

    ; Z-Probe
    M307 H7 A-1 C-1 D-1 ; disable heater on PWM channel for BLTouch
    M558 P9 H3 F240 T8000 X0 Y0 Z1 ; set Z probe type to bltouch and the dive height + speeds
    G31 P25 X-46 Y-4.6 Z1.21 ; set Z probe trigger value, offset and trigger height
    M557 X20:460 Y50:425 S30 ; define mesh grid

    ; Heaters
    M140 H-1 ; disable heated bed
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C
    M307 H1 A250.9 C92.9 D10.4 V24 B0 S1 ; PID tuning parameters (gain, tc, dt, volt.PWm)

    ; Fans
    ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S0 I0 F500 H-1

    ; Tools
    M563 P0 S"E1" D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C
    M563 P1 S"E2" D1 H1 F0 ; define tool 1
    G10 P1 X0 Y0 Z0 ; set tool 1 axis offsets
    G10 P1 R0 S0 ; set initial tool 1 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M501 ; load saved parameters from non-volatile memory
    M911 S23.5 R24 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss
    T0 ; select first tool


  • Moderator

    What firmware version are you actually running? Send M115 and post the response.

    Your homeall.g looks very similar to that created by the configuration tool. However, I'm not sure that this move needs to be an H2 move:
    G1 H2 X250 Y250 F6000
    Try removing the H2.

    Also, can your X and Y axis really do 48000mm/min (800mm/sec)?!
    M203 X48000.00 Y48000.00 Z3200.00 E18000.00:10000.00 ; set maximum speeds (mm/min)

    Ian



  • @droftarts That's correct. On a CoreXY, an H2 move will normally only use one motor so H2 Xnn Ynn might do strange things. Once homed, any G1 move within axis limits should work so I agree that removing the H2 parameter ought to fix it.


  • Moderator

    @deckingman looks like the configuration tool is wrong, then. I’ll report it to @chrishamm.

    Ian



  • @droftarts Not sure but I think G1 H2 Xnn will give +X +Y and G1 H2 Ynn will give +X -Y. So G1 H2 Xnn Ynn will give (+X+Y)+(+X-Y) = +X only (the +Y and -Y cancel each other out). Not 100% sure but I think that's what happens.




  • Moderator

    @Veti said in Large Core Homing issue:

    @droftarts
    it was reported and fixed
    https://github.com/chrishamm/configtool/issues/18

    Different issue. Tested on current RRF configuration tool 2.1.4, it puts in:

    G90                     ; absolute positioning
    G1 H2 X15 Y15 F6000     ; go to first bed probe point and home Z
    G30                     ; home Z by probing the bed
    

    Reported here: https://github.com/chrishamm/configtool/issues/19

    Ian


Log in to reply