Z Offset



  • No matter what i do i can not get my Zoffset so that my nozzle is just touching paper over the bed? i have calibrated my z offset and checked config files any idea?

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Tue Oct 09 2018 13:27:56 GMT+0300

    ; General preferences
    M80 ; Turns on the ATX power supply
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 PBLV mgn Cube ; Set machine name
    M552 S1 ; Enable network
    M587 S"TelstraEA8841" P"nrsn4wdrjz" ; Configure

    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards blv: its was S1
    M569 P1 S0 ; Drive 1 goes backwards blv: its was S1
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes backwards WAS 0
    M569 P4 S0 ; Drive 4 goes backwards WAS 0
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X200 Y200 Z405 E425 ; Set steps per mm for Bondtech.
    M566 X420 Y420 Z24 E300 ; Set maximum instantaneous speed changes (Jerk) (mm/min)
    M203 X15000 Y15000 Z350 E5000 ; Set maximum speeds (mm/min)
    M201 X1500 Y1500 Z300 E5000 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Bed Leveling
    M584 X0 Y1 Z2:4 E4 P2 ; two Z motors connected to driver outputs Z and E1
    M671 X-50:347 Y0:0 S3 ; leadscrews at left (connected to Z) and right (connected to E1) of X axis

    ; Pressure advance
    M572 D0 S0.3.5 ; disabled Pressure advance

    ; Axis Limits
    M208 X-23 Y0 Z0 S1 ; Set axis minima
    M208 X320 Y321 Z350 S0 ; Set axis maxima

    ; Endstops
    M574 Z1 S2 ; Set endstops controlled by probe
    M574 X1 Y2 S1 ; Set active high endstops edit: Y endstop is high(max). (M574 X1 Y2 S1)
    M574 Z1 S2 ; Define Z to use Probe. Home to Min

    ; Filament sensor
    M591 D0 P1 C3 S1 ; Set Filament sensor Simple type (High) for extruder drive 0, connected to endstop input 3 (E0)

    ;Disable Heater
    M307 H7 A-1 C-1 D-1 ; Disable the 7th Heater for BLTOUCH

    ; Z-Probe
    G31 X40 Y-20 Z1.18 ; Z Probe Trigger Height
    M558 P9 H5 F100 T4000 A5 S0.050 R0.5 B1 ; Set Z probe type to bltouch and the dive height + speeds
    M557 X0:240 Y60:270 S35 ; Define mesh grid

    ; Heaters
    M307 H7 A-1 C-1 D-1 ; Disable the 7th Heater to free up PWM channel 5 on the Duex board.
    M305 P0 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S100 ; Set temperature limit for heater 0 to 100C
    M305 P1 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S260 ; Set temperature limit for heater 1 to 260C

    ; Fans
    M106 P0 F500 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 F500 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 F500 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S21 R22 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured
    M564 H0 ; Let the Jog buttons work blv: added to allow jog buttons

    ; bed.g
    ; called to perform automatic bed compensation via G32
    ;
    ; generated by RepRapFirmware Configuration Tool on Tue Oct 09 2018 13:27:56 GMT+0300
    M291 P"Bed tilt levelling" R"Probing.." S1 T2
    G28 ; home all axis bb
    G29 S2
    M561 ; clear any bed transform
    G90 ; absolute positioning bb
    G30 P0 X0 Y150 H0 Z-99999
    G30 P1 X240 Y150 H0 Z-99999 S
    M291 P"Bed tilt levelling finished !" R"Probing.." S1 T2
    M291 P"Probing mesh grid" R"Probing.." S1 T2
    G28 ; home all axis bb
    G90 ; absolute positioning bb
    M557 X0:240 Y60:270 S30 ; Define mesh grid
    G29 S0 ; Probe the bed and save height map to file
    M374 ; Save calibration data. Default is sys/heightmap.csv



  • @Mickyg02 said in Z Offset:

    Z405

    Is your Z axis steps per mm really 405? I could see 400.

    What do you have in homeall?



  • @Mickyg02 said in Z Offset:

    G31 X40 Y-20 Z1.18 ; Z Probe Trigger Height
    M558 P9 H5 F100 T4000 A5 S0.050 R0.5 B1 ; Set Z probe type to bltouch and the dive height + speeds

    Try flipping the order of these lines.



  • Home All
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 X-355 Y355 F6000 ; move quickly to X or Y endstop and stop there (first pass)
    G1 S1 X-355 ; home X axis
    G1 S1 Y355 ; home Y axis
    G1 X5 Y-5 F6000 ; go back a few mm
    G1 S1 X-355 F360 ; move slowly to X axis endstop once more (second pass)
    G1 S1 Y355 ; then move slowly to Y axis endstop
    G90 ; absolute positioning
    G1 X152 Y166.4 F6000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed
    G92 Z1.24
    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning



  • @Mickyg02 said in Z Offset:

    G92 Z1.24

    Remove that. You're forcing a Z position AFTER you've used the probe to find the actual Z0 position.



  • I only just added that sorry my issue was before i added it



  • @Phaedrux said in Z Offset:

    G31 X40 Y-20 Z1.18 ; Z Probe Trigger Height
    M558 P9 H5 F100 T4000 A5 S0.050 R0.5 B1 ; Set Z probe type to bltouch and the dive height + speeds

    In that case, Try flipping the order of these lines.



  • So simple but it worked thank you so much a minor Christmas miracle for me, have a good Christmas 🙂



  • Ho ho ho



  • Green Giant ....


Log in to reply