Z offset is .030 too high after starting print?



  • I am having a strange issue where the Z is starting .030 higher than it should after starting a print. I have looked through my start GCODE and my config, and I can't see where this would be coming from... does anyone have any ideas on where to look?

    Start GCODE:
    G1 Z5 F15000 ;Move the platform down 5mm
    G28 ;Home

    ;Prime the extruder
    G92 E0
    G1 F200 E3
    G92 E0

    Config:
    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.4 on Tue Dec 17 2019 00:47:57 GMT-0500 (Eastern Standard Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Hypercube" ; set printer name
    ;M564 H0 ;allow movement before homing
    M667 S1 ; select CoreXY mode

    ; Network
    M550 Phypercube ; Set machine name
    M552 S1; Enable network
    M552 S1; P0

    M586 P1 S1 ; enable FTP
    M586 P2 S1 ; enable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M569 P4 S1 ; physical drive 4 goes forwards
    M584 X0 Y1 Z2 E3:4 ; set drive mapping
    M350 X16 Y16 Z16 E16:16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E80.00:80.00 ; set steps per mm
    M566 X1500 Y1500 Z12 E120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X10000 Y10000 Z180 E1200:1200 ; Set maximum speeds (mm/min)
    M201 X4000 Y4000 Z250 E2000:2000 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800:800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X300 Y300 Z300 S0 ; set axis maxima

    ; Endstops
    M574 X0 Y0 Z0 S0 ; set active high endstops
    ;M574 Z1 S2 ; set endstops controlled by probe

    ; Z-Probe
    ;M307 H7 A-1 C-1 D-1 ; disable heater on PWM channel for BLTouch
    ;M558 P9 H5 F500 T4000 X0 Y0 Z1 ; set Z probe type to bltouch and the dive height + speeds
    ;M558 P9 H5 F100 T2000
    ;G31 P25 X20 Y5 Z.8 ; set Z probe trigger value, offset and trigger height
    ;M557 X15:290 Y15:290 S40 ; define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C
    M305 P2 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 2
    M143 H2 S280 ; set temperature limit for heater 2 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S0.5 I0 F500 H1:2 T100 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H2 ; Define tool 1
    G10 P1 X-18.1 Y.4 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ; Custom settings are not defined



  • you can define a z offset using M206
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M206_Offset_axes
    if you dont have a probe.

    however i would highly recommend a probe unless your bed is perfectly flat

    also your thermistor settings are wrong B4138 is the default, and wrong for your thermistors.

    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1
    M305 P2 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 2



  • Thanks, I didn't realize the thermistors were wrong, I will fix that.
    I was trying to set up a BLTouch earlier but I had so many issues with it... So I gave up and went back to the endstop setup.

    I ran M206 and it came back with Axis offsets: X0.00 Y0.00 Z0.00
    I guess I can just set -.030? still not sure where it's getting that offset from.



  • I just tried M206 X0 Y0 Z-0.030 and then started a print, the offset is still +.030... any other ideas? I'm stumped.



  • @TheBasedDoge said in Z offset is .030 too high after starting print?:

    M208 X0 Y0 Z0 S1 ; set axis minima

    i think you will need to allow negative movement.

    try
    M208 X0 Y0 Z-1 S1 ; set axis minima

    what was your problem with the bltouch?



  • What do you have in homeall?

    If you're not using a probe, how are you homing the Z axis?



  • @Veti

    Ok thanks, i'll try this after the current print finishes.

    The BLTouch wasn't reliably deploying and retracting.... I had two times where it woudn't deploy and the bed smacked into the hotend and cracked the glass 😞
    Then I had an issue where the probe fell out of the housing, i took it apart and saw that it was just held up by a piece of heat-shrink or something. I don't know if i have a defective one or an old one or something but it's just giving me too many issues.

    @Phaedrux

    here is my homeall.g. All the BLTouch stuff is commented out now. I went back to just a regular endstop

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.4 on Tue Dec 17 2019 00:47:58 GMT-0500 (Eastern Standard Time)
    ;G91 ; relative positioning
    ;G1 H2 Z2 F7200 ; lift Z relative to current position
    ;G1 H1 X-305 Y-305 F3300 ; move quickly to X or Y endstop and stop there (first pass)
    ;G1 H1 X-305 ; home X axis
    ;G1 H1 Y-305 ; home Y axis
    ;G1 X10 Y10 F7200 ; go back a few mm
    ;G1 H1 X-305 F300 ; move slowly to X axis endstop once more (second pass)
    ;G1 H1 Y-305 ; then move slowly to Y axis endstop
    ;G90 ; absolute positioning
    ;G1 H2 X-5 Y10 F7200 ; go to first bed probe point and home Z
    ;G1 H1 X-305 ; home X axis
    ;G1 H1 Y-305 ; home Y axis
    ;G30 ; home Z by probing the bed

    G91 ; relative positioning
    G1 H2 Z5 F9000 ; lift Z relative to current position
    G1 H1 X-305 Y-305 F3600 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X5 Y5 F9000 ; go back a few mm
    G1 H1 X-305 Y-305 F300 ; move slowly to X and Y axis endstops once more (second pass)
    G1 H1 Z-305 F300 ; move Z down stopping at the endstop
    G90 ; absolute positioning
    G92 Z0 ; set Z position to axis minimum (you may want to adjust this)

    ; Uncomment the following lines to lift Z after probing
    G91 ; relative positioning
    G1 S2 Z2 F120 ; lift Z relative to current position
    G90 ; absolute positioning



  • @Veti said in Z offset is .030 too high after starting print?:

    i think you will need to allow negative movement.
    try
    M208 X0 Y0 Z-1 S1 ; set axis minima

    Note that if you do this with an endstop, the homing move on the Z axis will set the position to -1 since that's what the minima is set to.

    In your homeall you have a G92 after the Z axis homing move to reset the position to whatever you want. Currently 0. So if the resulting position isn't accurate, you can adjust this G92.

    However, this assumes your bed is level and perfectly flat.

    How are you measuring 0.03 anyway?

    It sounds like your BLTouch was faulty. Was it a clone? What version?



  • @Phaedrux When I homeall, the offset shows 0. Once I start the print it says Z is .030 under head position on the Machine Status screen, and then it starts printing in the air above the bed. It's really weird.

    Not sure what version my BLTouch is... I bought it over a year ago and only tried putting it on now. Maybe i should get a brand new one and try again? The housing says 3DTouch on it, but the PCB says BlTouch. no idea of it's a clone.



  • @TheBasedDoge said in Z offset is .030 too high after starting print?:

    3DTouch

    that is a clone. they tend to be unreliable.

    @TheBasedDoge said in Z offset is .030 too high after starting print?:

    Once I start the print it says Z is .030

    what layer height have you specified in your slicer.
    the first print starts at the layer height that you specified. it never starts at 0 because there would be no space for the plastic to go.



  • @TheBasedDoge said in Z offset is .030 too high after starting print?:

    3DTouch

    It's a clone. Get a genuine Antclabs BLTouch V3.1.

    There are other good probe options. The DC42 IR probe is really good as well. The print surface will need to work with the IR sensor though.



  • Ok, I guess i'll order another real BLTouch. Im using PEI over glass so I dunno if an IR probe will work

    In the mean time i still need to figure out the weird offset issue. My layer height is .2 right now, using Cura to slice.



  • Can you post the first 50 lines or so of your sliced gcode file?

    Do you have an offset configured in cura?

    Are you able to use the baby stepping function in the web control to adjust your first layer to print properly?

    Have you calibrated the extruder so that you're getting the right amount of extrusion?



  • No offset configured in cura.
    I can use the baby stepping to fix it but I have to click it a ton of times... I've just been manually turning the z motor to adjust the offset.

    Here is the GCODE:

    ;FLAVOR:Marlin
    ;TIME:10883
    ;Filament used: 5.77495m
    ;Layer height: 0.1
    ;MINX:117.122
    ;MINY:126.967
    ;MINZ:0.3
    ;MAXX:183.437
    ;MAXY:171.213
    ;MAXZ:74.4
    ;Generated with Cura_SteamEngine 4.4.0
    M140 S60
    M105
    M190 S60
    M104 S225
    M105
    M109 S225
    M82 ;absolute extrusion mode
    G1 Z5 F15000 ;Move the platform down 5mm
    G28 ;Home
    
    
    ;Prime the extruder
    G92 E0
    G1 F200 E3
    G92 E0
    G92 E0
    G92 E0
    G1 F1500 E-6.5
    ;LAYER_COUNT:742
    ;LAYER:0
    M107
    G0 F2215.4 X118.845 Y138.206 Z0.3
    ;TYPE:SKIRT
    G1 F1500 E0
    G1 F1200 X119.46 Y137.693 E0.03996
    G1 X119.512 Y137.65 E0.04332
    G1 X120.337 Y136.988 E0.09609
    G1 X121.752 Y135.797 E0.18837
    G1 X122.38 Y135.373 E0.22617
    G1 X122.98 Y135.054 E0.26007
    G1 X123.046 Y135.02 E0.26378
    G1 X124.288 Y134.392 E0.33321
    G1 X126.703 Y133.084 E0.47023
    G1 X129.059 Y131.72 E0.60605
    G1 X130.064 Y131.104 E0.66486
    G1 X130.114 Y131.074 E0.66777
    G1 X130.708 Y130.723 E0.70219
    G1 X130.795 Y130.673 E0.7072
    G1 X131.073 Y130.519 E0.72305
    G1 X131.446 Y130.339 E0.74372
    G1 X131.917 Y130.145 E0.76913
    G1 X132.007 Y130.11 E0.77395
    G1 X132.443 Y129.944 E0.79722
    G1 X132.726 Y129.849 E0.81212
    


  • Can you try updating to the latest 2.05 firmware release?



  • I did that yesterday actually, no change



  • @TheBasedDoge said in Z offset is .030 too high after starting print?:

    G0 F2215.4 X118.845 Y138.206 Z0.3

    are you sure the web gui is report 0.03 and not 0.3 ?



  • Yes ^

    Ok, so I tried PrusaSlic3r and it's not doing it? Where in Cura would be causing this weird issue?



  • Can you save a .3mf file from cura and post it somewhere to share it here?




Log in to reply