duet wifi printing really slowly



  • I just installed a duet 2 wifi onto my creality cr10s5 and now it prints incredibly slowly. I've double checked my reprap configuration and I have the correct steps per mm. It will home and move the individual axis and the speed I want but whenever I load a print file it slows to a crawl. It also stops before completing a print. According to the machine properties tab in the web control interface it's only moving at 8.33 mm/s. I have it set to 100 mm/s in the reprap configurator.
    I reflashed the firmware about a dozen times too. The very first time I tried to load it there was a bug where the axis kept running into the endstops but the motors tried to keep turning. I solved that one by using an older version of the firmware (2.0 vs 2.05).
    I'm using ultimaker cura and have the correct gcode flavor output set according to the machine properties. I don't know what's going wrong.



  • your start gcode in cura contains lines that are not compatible with duet.

    remove them.



  • @Veti said in duet wifi printing really slowly:

    your start gcode in cura contains lines that are not compatible with duet.
    remove them.

    Which lines exactly?



  • you might find your previous firmware and RRF could differ where one needs mm/s and the other mm/min for the feed rates etc



  • @bearer
    There is no previous firmware. It's a brand new duet board and I've only ever installed reprap on it.



  • did the cr10 have a firmware on it?
    did that firmware have its settings in mm/s?
    does rrf have its settings in mm/min?

    I guess its not just the printer that is slow..



  • @bearer
    I took the old Creality control board, and therefore all the firmware on it, out of the printer entirely. The only micro controller operating any g code commands is a factory new Deut 2 wifi board that has reprap software I installed on it. Configurator specifically lists the speed setting in mm/s. I previously had Marlin installed on the Creality board and it also lists the acceleration, feedrate, Jerk, retraction, and travel speed settings in mm/s.



  • and as veti suggested, cura is likely overriding it with its start g-code, which is still in mm/s and interpteded as mm/min by the duet.

    if thats not the case you need to post you config and the g-code as the above is the obvious issue.


  • administrators

    @usescoasters, post your config.g file, also the first 50 or so lines (not counting comment lines) of the GCode file you are trying to print.



  • @usescoasters said in duet wifi printing really slowly:

    Which lines exactly?

    there will be lines like
    M201 X500.00 Y500.00 Z100.00 E5000.00 ;Setup machine max acceleration
    M203 X500.00 Y500.00 Z10.00 E50.00 ;Setup machine max feedrate
    M204 P500.00 R1000.00 T500.00 ;Setup Print/Retract/Travel acceleration
    M205 X8.00 Y8.00 Z0.40 E5.00 ;Setup Jerk
    M220 S100 ;Reset Feedrate
    M221 S100 ;Reset Flowrate
    in your start g code in cura.

    remove those lines completly



  • Thanks! Now its actually printing at a decent speed. The only problem left is that is pauses for long intervals during the print. It will complete one section of a part or one pass of the exterior and then stop before eventually moving onto the next movement. I think this is something to do with a G92 command in the gcode files generated by the slicer.



  • @usescoasters said in duet wifi printing really slowly:

    I think this is something to do with a G92 command in the gcode files generated by the slicer.

    3cc43e29-734c-4a99-bddd-cc672cbc0a93-image.png



  • Here's my config.g.
    config.g



  • it must be a setting you have selected in cura. there is nothing in the config that explains it. but there are errors non the less.

    M350 X64 Y64 Z16 I0 ; configure microstepping without interpolation
    M350 E16 I1 ; configure microstepping with interpolation

    unless you have a very specific reason stay with x16 and interpolation for all your axis.

    M906 X800 Y800 Z800 E800 ; set motor currents (mA)

    these are default values and should be adjusted for your motors

    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1

    B4138 is the default and wrong for your thermistor.


Log in to reply