Dual Z bed Leveling right side drops after every print



  • I leveled my bed multiple times to get it within .09 deviation. Now it is deviation of .233 However every time I run a G32 it homes Z in center of bed, then checks left and right sides at the Y position of the lead screws as far left and right as the print head will go. And every time the right side of the bed is lower and needs compensation, even after I have manually leveled the 2 sides to make sure lead screws were in exact same height position. It is like after every print the Right side motor allows the bed to fall. I have Left Z Stepper plugged into Z driver and I have the Right Z Stepper plugged into E1.

    Last G32 - Leadscrew adjustments made 0.842 -1.177, points used 2, deviation before .731 after 0.000
    4 points probed (have it set to just 4 to try and get this figured out quicker), min error -.319, max error 0.251, mean -0.071, deviation 0.233 Height map saved to file heightmap.csv (attached)![alt text](![image url](image url))

    Printer is a Core XY Hypercube with 375mm Z travel

    My Z steppers are e3d High Torque Axis motors 2 phases 1.68A / phase holding torque >4.4kg-cm(61 Oz.in). Lead screws are T2 4 start 8mm leads.

    Here are my config.g and my bed.g files, let me know if anyone has any advice? Or is this something I will just have to live with?
    Config.g
    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Alex's Hypercube" ; set printer name

    M667 S1 ; select CoreXY mode

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S0 ; physical drive 3 goes backwards
    M584 X0 Y1 Z2:4 E3 ; set drive mapping
    M671 X-30:330 Y156:156 S1.5 ; leadscrews at left and right
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X161 Y160 Z809 E819 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z300.00 E350 ; set maximum speeds (mm/min)
    M201 X3000.00 Y3000.00 Z100.00 E350 ; set accelerations (mm/s^2)
    M906 X1400 Y1400 Z1400 E1000 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z-5 S1 ; set axis minima
    M208 X280 Y280 Z370 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; set active high endstops
    M574 Z1 S2 ; set endstops controlled by probe
    M591 D0 P5 C3 R40:120 E3.0 S0 ; Duet3D laser sensor for extruder drive 0, connected to endstop input 3 (E0), tolerance 40 to 120%, 3mm comparison length, disabled

    ; Z-Probe
    M558 P1 XO YO H3 F200 T9000 B1 R0.1 A5 ; set Z probe type to modulated and the dive height + speeds
    G31 P500 X-27 Y0 Z1.650 ; set Z probe trigger value, offset and trigger height
    M557 X20:240 Y20:260 S220 ; define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4725 C7.06e-8 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M307 H1 A390.9, C258.2, D5.4, S1 ; hot end thermister tuning
    M305 P1 T100000 B4725 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S0.5 I0 F500 H1 T45 ; set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss

    ; bed.g
    ; called to perform automatic bed compensation via G32
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.4 on Tue Dec 24 2019 07:12:06 GMT-0500 (Eastern Standard Time)
    M561 ; clear any bed transform
    G28 ;home
    G30 P0 X0 Y156 Z-99999 ; probe left leadscrew
    G30 P1 X260 Y156 Z-99999 S2 ; probe right leadscrew and calibrate 2 motors
    G29 ; run mesh bed leveling

    [img]https://i.imgur.com/fhoqzrP.png[/img]



  • I would try to replace the leadscrews to single start 2 mm or even lower, 8mm 4 start are bad at holding any load...



  • I had a similar problem... turned out one of my z steppers was bad


Log in to reply