dual extruder questions



  • A couple of questions regarding a dual extruder setup with one extruder running PLA and the other running PETG.

    Both extruders have had auto tuning run on it and with 50W cartridges have been reduced to a 60% PWM duty cycle to avoid over heating.

    1. Even with the reduced power (PWM) to the heaters I get considerable overshoot in temperature (between 5 and 8 degrees) and I am not aware of any setting in Cura to allow printing to start at a higher setting (unlike where it allows starting to print even if it hasn't fully reached temperature).
      I have tried reducing the PWM power and the A parameter keeps going down but it keeps overshooting.
      The config-override.g file specifically states not to edit it (I was thinking of increasing A) .... do I just forget about the config_override.g file, delete the appropriate lines and move them into config.g? Besides watching autotune and correcting things every time I run an autotune, are there any other implications?
      Is there an alternative way of reducing overshoot ?

    2. When the extruder is switched, the nozzle goes to the purge tower SUPER slow even when temperatures seem to be good to print. Is this an expected tactic to dawdle while temperatures adjust or did I screw up someplace in the configuration ?


  • Moderator

    @jens55 said in dual extruder questions:

    The config-override.g file specifically states not to edit it

    This is because it will get over written the next time you use M500 to save something and what you changed might not carry over.

    To use manual values you would want to put them into config.g and remove the line from config-override.

    @jens55 said in dual extruder questions:

    Is there an alternative way of reducing overshoot ?

    Use a small wattage heater?

    @jens55 said in dual extruder questions:

    When the extruder is switched, the nozzle goes to the purge tower SUPER slow even when temperatures seem to be good to print. Is this an expected tactic to dawdle while temperatures adjust or did I screw up someplace in the configuration ?

    You mean the travel speed is super slow? Was a feed rate set low unintentionally elsewhere?



  • Thanks for replying.
    The heater is only 50 watts and this is for a Volcano. I am also at a 60% pwm rate for the heater so a lower wattage heater should not be required. The heater block is solid brass so has considerable mass and that might have something to do with this.
    I will bring the heater setting over from config_overwrite.g to config.g and mess with the A parameter.

    Yes, the travel speed is super slow, maybe around 5 mm/sec. I will do through the gcode file and see if it is set super slow just before the move starts. Normal travel speed is around 120 mm/sec. I thought at first it was intentional to allow the nozzle temperatures to reach the needed value but that doesn't seem to be the case.
    Anyway, I will poke around and see if I can find a reason for this slow travel speed (only when going to the purge tower).

    Thanks.



  • I have had some success with the temperature overshoot but generally I have not had much luck in finding a method to set the other parameters for the heaters. I think I might have to live with the issue until such time as Cura decides to include a setting for the high temperature at which point printing can start.

    I have dug more into the gcode for the slow travel between model and prime tower and here too I seem to be stuck waiting for Cura to include some sort of travel speed setting.
    With my somewhat limited understanding, it appears that Cura does not honour the 'travel speed' setting and uses the printing speed for the prime tower as the travel speed for the prime tower. I have printing speed set for 10 mm/sec and that is what I get for the travel move from the model to the tower as well.
    It would appear that this is something I have to get used to.

    If anyone knows of a way to bypass these 'issues', I am all ears.



  • @jens55 As to the heater overshoot, I would second @Phaedrux's advice to use a smaller heater cartridge. I had a similar issue with a 5 colour Diamond hot end which by default and for some unknown reason, comes with a massive 80 Watt heater. This proved to be untameable even when using 40% PWM. Changing the heater to a more suitably sized 40Watt version cured all the overshoot problems. Also I sleep better in the knowledge that if a MOSFET failed and the heater was stuck on at full power, at least it will no longer reach temperatures that can melt aluminium 🙂.



  • In my mind, although the 50W heater is a bit high in output, I don't think it makes sense to reduce it to 40W. As it sits now I have about 3 degrees overshoot which isn't too bad (with a 60% pwm setting).
    Because of the size of the heater block and the fact that it is solid brass, even with those 3 degrees it takes a while to cool down during which time the printer sits and waits. Most annoying .....
    I gather that while the printer can tolerate that small difference in temperature, it has to reach the right temperature first in order to switch to a mode where it isn't so critical about the actual temperature.
    I could probably change out the heater blocks to aluminum and that would fix things too .... but I was hoping I could work around these obstacles rather than just ordering new parts and crossing my fingers.
    I might have 40W heaters in my stash ... got to check.

    I still think that Cura should add a high temp setting at which to start printing. Maybe one of these days 🙂



  • @jens55 If you are getting overshoot with a 50 Watt cartridge at 60% PWM, then 30 Watt would be a more suitable choice.



  • A bit of an update: I switched the volcano hot blocks from brass to aluminum and the resulting temperature overshoot was close to half of the overshoot with the brass block. The temperature also appears to fall much faster so the wait time in dual extrusion prints should be noticeably reduced.

    This information is preliminary as I have not actually used this configuration.



  • Had this same problem not too long ago.

    Check your tool change macros, the default is to have it wait until temperatures are within 1-2 C. I updated it with a larger 'acceptable temperature' band to account for the overshoot See the following:

    https://forum.duet3d.com/topic/9130/tool-change-macro

    • Actions to do with the new tool before it is selected - macro name: tpreN.g where N is the tool number;
    • Actions to do with the new tool after it is selected - macro name: tpostN.g where N is the tool number.

    Removing the wait for temperatures command from the macros altogether is also a decent choice.



  • Thank you very much for that TLAS. While I don't actually have any waits in my tool change files it got me thinking - what if there is a wait command active from a previous section of g code? I currently have the M116 commented out. Well, that isn't applicable but I looked at the M116 command again and by golly, there is a temperature range that I can specify! This is exactly what I have been looking for !
    Thank You !


Log in to reply